Jump to content


Photo

Drive On Primary Drive Is Frozen!


  • Please log in to reply
22 replies to this topic

#1 DickE

DickE

    X-S Member

  • Members
  • Pip
  • 81 posts

Posted 15 April 2006 - 10:37 PM

Hi,

I'm using XboxHDM, and making a new xbox hard drive using:
Seagate Barracuda 7200.9 80G ST3802110A (seems v.compatable on the xbox HD compatability chart)

Made the partitions, placed all the files I need in the C and E partitions, now when it comes to locking it (using option 3 from the main XboxHDM menu, the linux option) It tells me:

"Drive on primary master is frozen
Cannot chage the security status of a frozen drive! Try to disable 'automatic detection' on the primary IDE channnel in your PC BIOS and reboot"

Obiously I went to the bios but cannot find this option anywhere, the closest I could find was:
Primary IDE controller: Enable/Disable (I tried disabling it, but then wouldn't boot xboxhdm giving me a disk error, same one when you have a floppy in PC at startup) The PC I am using is a compaq pentium 3

Next I tried to have the HD disconnected at startup, then plug it in at the xboxhdm menu, but when I try option 3 the PC reboots and tells me its found a Hard Drive grr.gif and to press F1 to accept the changes the system.

So is there any thing else I can try, or if in the bios it could be called anything else?

Cheers for any help,

DickE


#2 Epaige

Epaige

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,112 posts
  • Xbox Version:v1.6b
  • 360 version:v3.0 (falcon)

Posted 16 April 2006 - 03:14 AM

Well there should be a way to either turn auto detection off for primary master or set it to none. Maybe you could give a list of the options your bios gives you. That would help. Im gonna check what i have to goto then ill post back. I had the frozen drive problem also. BRB


EDIT: OKk for mine it under the main tab. And then i scroll down to primary master click enter then use plus or minus to select auto or none. None is what you want. But you proll dont hav the same bios.

Edited by Epaige, 16 April 2006 - 03:25 AM.


#3 DickE

DickE

    X-S Member

  • Members
  • Pip
  • 81 posts

Posted 16 April 2006 - 04:23 AM

Ok my bios:

Compaq Computer Corporation Setup Utility
  • File
    Just the PC info, no options to change
  • Storage
    Device Configuration
    Storage Options
    IDE DPS Self Test
    Boot Order
  • Security
    Setup Password
    Power On Password
    Smart Cover
    Device Security
    Netwrk Sevice Boot
    System ID's
    Master Boot Record
  • Power
    Energy Saver
    Timeouts
    Energy Saver Options
  • Advanced
    Power-On Options - IPB Image
    Onboard Devices
    PCI Devices
    Bus Options
    Device Options - IPB Image

I included those images cause I thought those might be the menu's most likely to contain the option, but I seriously cant see the automatic detection anywhere grr.gif

Is there maybe a command that I can use at after I have booted into linux, to look for HD's because then I could connect the HD only after the PC has checked for HD's (It does this at bootup, and when entering linux)

Has anoyone got any other ideas?

Cheers,

DickE

edit to earlier post:
Obiously when I got that disc error before when I disabled the IDE controller, was because the CD drive was on that controller as well as the HD, I just didnt have my head switched on then lol.


#4 TheAgedGamer

TheAgedGamer

    X-S X-perience

  • Members
  • PipPip
  • 452 posts
  • Location:Southern Indiana
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 16 April 2006 - 04:43 AM

I have this same problem on my E-Machine. To get around it, boot up xboxhdm without the ide connected to your new xbox hd ( go ahead and have the power plugged in on you xbox hd). After xboxhdm displays the 1st screen, plug in your ide and then pick option 3. Works for me every time this way.

#5 DickE

DickE

    X-S Member

  • Members
  • Pip
  • 81 posts

Posted 16 April 2006 - 05:23 AM

QUOTE(TheAgedGamer @ Apr 16 2006, 04:50 AM) View Post

I have this same problem on my E-Machine. To get around it, boot up xboxhdm without the ide connected to your new xbox hd ( go ahead and have the power plugged in on you xbox hd). After xboxhdm displays the 1st screen, plug in your ide and then pick option 3. Works for me every time this way.


Yeah I tried that, but when I've connected the drive and select number 3, before it goes into the linux menu, it kind of reboots (only does this when i connect the drive after bootup) and displays the auto message something along the lines of, found that the system has been changed (shows the addition of the HD) press F1 to confirm and make the changes to the system(it doesn't give me any other options), then it reboots fully and I am back where I started grr.gif

Cheers anyway,

DickE

P.S.
Off topic
I tried another PC now that I know has the HD auto detection in the bios. But it doesn't boot the xboxhdm cd uhh.gif (even though it is a good copy, boots on every other PC) It boots a XP disc, but for some reason the PC seems to know that it isn't a 'system' disc, and therefore won't boot it, giving a disc error (It isn't the CD,the Connections or the CD drive) but like it's locked to only boot 'system' discs not any old 'boot disc', maybe cause it's a very old PC a P133 uhh.gif

#6 jonels

jonels

    X-S Expert

  • Members
  • PipPipPip
  • 634 posts

Posted 16 April 2006 - 12:43 PM

Use the xbox to lock it, have both drives powered via a splitter, then swap the ide lead when using a locking tool.

#7 DaddyJ

DaddyJ

    X-S Messiah

  • Dev/Contributor
  • PipPipPipPipPipPipPip
  • 3,919 posts
  • Xbox Version:unk
  • 360 version:none

Posted 16 April 2006 - 03:59 PM

the best & easiest way, it to leave the hard drive's power unplugged, and have the ide pluggin

boot the pc, and wait until the xboxhdm screen shows
then plug in the power to the hard drive. then boot from the disk as normal.

#8 DickE

DickE

    X-S Member

  • Members
  • Pip
  • 81 posts

Posted 16 April 2006 - 04:28 PM

QUOTE(DaddyJ @ Apr 16 2006, 04:06 PM) View Post

the best & easiest way, it to leave the hard drive's power unplugged, and have the ide pluggin

boot the pc, and wait until the xboxhdm screen shows
then plug in the power to the hard drive. then boot from the disk as normal.


Yeah I just tried that, and now the PC isn't rebooting when I select option 3, dont know what I've changed for it to do that, cause I changed so many options, different hardware etc.

However it is having trouble booting the CD (I think) cause the PC is crashing when loading Linux, weird.
One problem after another, lol.

So I'm just going to get some new CDR, and burn the iso again.

On my first disc I had stuff in the C: and E: folders, but dont need that anymore, so should I burn it without to improve reading? Or should I add some dummy files on the disc to improve reading?

Cheers,

DickE

#9 DickE

DickE

    X-S Member

  • Members
  • Pip
  • 81 posts

Posted 16 April 2006 - 06:33 PM

Ok, plugging in the HD in after bootup doesn't work. As when it trys to load linux (option 3) it fails
it says:

loading /isolinux/lockimage..........................................................................
loading initrd.gz..........................................................................................
Ready

Then just hangs there with the cursor blinking

However when the HD is connected from start up, the linux locking tools will boot up fine, howver then the HD is frozen grr.gif

I have even tried to connect the HD as the slave (CD as master) after the boot up, and using the:
find-cd2 check (to mount the xboxhdm CD)
hdtool -d /dev/hdb -e /CD/eeprom/eeprom.bin -o LOCK
command that I found on the faq page, but the computer just tells me that it can't find the HD, even though it is connected!

Anyone got any suggestions?

DickE

#10 JrracinFan8

JrracinFan8

    X-S Freak

  • XS-BANNED
  • PipPipPipPipPip
  • 1,512 posts
  • Location:Ohio
  • Xbox Version:v1.6
  • 360 version:none

Posted 17 April 2006 - 12:24 AM

QUOTE(DickE @ Apr 15 2006, 11:30 PM) View Post

Ok my bios:
[*]Storage
Device Configuration



Try going in there to turn off autodetection.

#11 jonels

jonels

    X-S Expert

  • Members
  • PipPipPip
  • 634 posts

Posted 17 April 2006 - 12:39 AM

Have you tried locking it with evox ? just unhash the "lock drive entry" in the config file, and swap the ide lead just before locking. There is also a pupose made xbox app for this as-well, but the name escapes me... "chimps" something or other, maybe a more senior member can remember it.

#12 TheAgedGamer

TheAgedGamer

    X-S X-perience

  • Members
  • PipPip
  • 452 posts
  • Location:Southern Indiana
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 17 April 2006 - 12:57 AM

Yeah you're right it's called chimp26, but I've never used it. I just remember reading about it.

#13 DickE

DickE

    X-S Member

  • Members
  • Pip
  • 81 posts

Posted 18 April 2006 - 05:23 PM

QUOTE(JrracinFan8 @ Apr 17 2006, 12:31 AM) View Post

Try going in there to turn off autodetection.


Nar, its not in there sadly.

I'm 100% sure that the PC does not have this auto detection grr.gif

As for locking the HD with evo X, I didn't know that you could do that, I'll have a look on the forums for info on that and that chimps26 program, if anybody can point me in the right derection that would be great.

Cheers,

DickE

#14 jonels

jonels

    X-S Expert

  • Members
  • PipPipPip
  • 634 posts

Posted 18 April 2006 - 06:24 PM

You might find these links helpful .. http://www.geocities...nonochimpanzee/

and ... http://forums.xbox-s...ic=265319&st=15

Basically I think chimps tools are like using xboxhdm but on you're xbox.




Or you could try the locking option with evox, you just need to "unhash" the option in the evox.ini file (take a look at the file with any old text editior, it's very easy to see). Put evox in as an app if it's not you're present dash. Run it, swap leads ..and lock.


edit... check you're new hard drive is set to "cable select, CS"

Edited by jonels, 18 April 2006 - 06:30 PM.


#15 DickE

DickE

    X-S Member

  • Members
  • Pip
  • 81 posts

Posted 18 April 2006 - 07:57 PM

When reading about the evox locking etc.

It seems that you need to have a mod chip that alows you to swap HD's, and I dont have one of those chips, I have a gen 1 chip.

I'll look at those links that jonels provided and see what they contain

Thanks,

DickE




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users