Jump to content


Photo

Halo 2 Doesn't Work Anymore


  • Please log in to reply
10 replies to this topic

#1 luda06

luda06

    X-S Enthusiast

  • Members
  • 18 posts

Posted 19 April 2006 - 05:32 AM

I had the game saved to my hard disk and would boot up from there using kai from XBMC, but all of a sudden (after kai froze on XBMC a couple of times) Halo 2 gives me the dirty disk error screen. So I tried booting the game from the actual DVD and still no luck. I made sure it wasn't my Xbox because I popped in ESPN College Hoops to test it and the game worked.

WHAT DO I DO!? grr.gif

#2 CamdogXIII

CamdogXIII

    X-S Genius

  • Members
  • PipPipPipPip
  • 841 posts
  • Interests:Modding xbox's, building computers.
  • Xbox Version:v1.4
  • 360 version:unknown

Posted 19 April 2006 - 10:22 PM

try clearing the x y and z drives

#3 Vektor0

Vektor0

    X-S Member

  • Members
  • Pip
  • 107 posts
  • Interests:Your mom.
  • Xbox Version:v1.2
  • 360 version:v1 (xenon)

Posted 19 April 2006 - 11:41 PM

Halo 2 does that automatically, so doing it manually wouldn't help anything.

Re-copy it to your hard drive. It sometimes tells me that I failed to load the map, so what I do is play a different map that does work, exit, and then try again.

#4 luda06

luda06

    X-S Enthusiast

  • Members
  • 18 posts

Posted 20 April 2006 - 03:36 AM

I cleared the Cache, X, Y, & Z drives, as well as removing all of my Halo 2 saves from the Xbox. I also re-copied Halo 2 to the hdd and still no luck. No luck on the game disk working either.

Im wondering if Halo 2 checks for a specific file while starting up. Did I corrupt it?

It would be nice if someone could tell me the files that's supposed to be on the Xbox after soft modding it because I'm completely stumped as to how and why this occured.

Thanks for the help though.

#5 Maertz

Maertz

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,039 posts
  • Location:My Mom
  • Xbox Version:v1.6
  • 360 version:unknown

Posted 21 April 2006 - 02:53 PM

QUOTE(Vektor0 @ Apr 19 2006, 05:48 PM) View Post

Halo 2 does that automatically, so doing it manually wouldn't help anything.


halo does not automatically do that.

#6 Vektor0

Vektor0

    X-S Member

  • Members
  • Pip
  • 107 posts
  • Interests:Your mom.
  • Xbox Version:v1.2
  • 360 version:v1 (xenon)

Posted 21 April 2006 - 03:46 PM

QUOTE(Maertz @ Apr 21 2006, 10:00 AM) View Post

halo does not automatically do that.

That's not what I was talking about. It clears a drive for it's use. If, for instance, you load up Halo 2 and play Outskirts and then Sanctuary, then turn your Xbox off, and then reload Halo 2, then it clears all of the Halo 2 caches. Ask the people at **NO LINKS HERE FROM XS**if you don't believe me.

Edited by Chancer, 24 April 2006 - 05:05 PM.


#7 luda06

luda06

    X-S Enthusiast

  • Members
  • 18 posts

Posted 21 April 2006 - 05:49 PM

Well every time I boot Halo 2, it loads some maps into the X & Y drives. Is it supposed to do that?

#8 Vektor0

Vektor0

    X-S Member

  • Members
  • Pip
  • 107 posts
  • Interests:Your mom.
  • Xbox Version:v1.2
  • 360 version:v1 (xenon)

Posted 22 April 2006 - 11:24 PM

QUOTE(luda06 @ Apr 21 2006, 12:56 PM) View Post

Well every time I boot Halo 2, it loads some maps into the X & Y drives. Is it supposed to do that?

Yes, it decompresses them and stores them on the HDD when you choose to load them'.

#9 luda06

luda06

    X-S Enthusiast

  • Members
  • 18 posts

Posted 23 April 2006 - 07:23 PM

I sorta fixed the problem. I realized I executed dashupdate.xbe by accident and screwed up my dashboard. I assume Halo 2 checks for any changes to the dashboard before loading the actual game. So I tried to reverse the problem by downloading new files for the C partition, but it screwed the dash even more. Now whenever I boot my Xbox I get an Error 21 regardless if I try to go directly to ltools.

Halo 2 now works, but the Xbox is screwed.

#10 Vektor0

Vektor0

    X-S Member

  • Members
  • Pip
  • 107 posts
  • Interests:Your mom.
  • Xbox Version:v1.2
  • 360 version:v1 (xenon)

Posted 23 April 2006 - 09:36 PM

Yeah, you'd wanna take that problem to an Xbox Hardware forum.

#11 luda06

luda06

    X-S Enthusiast

  • Members
  • 18 posts

Posted 24 April 2006 - 10:09 PM

Thanks guys, I've finally restored my Xbox to 100% functionality. beerchug.gif




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users