Jump to content


Photo

Error 21 When Loading Msdash From Evox Driving Me Nuts


  • Please log in to reply
5 replies to this topic

#1 jesuf

jesuf

    X-S Enthusiast

  • Members
  • 9 posts

Posted 30 August 2006 - 06:01 AM

First of all I would just like to say hello to everyone here in the xbox-scene community as this is my first post in your forums.

Here is my sitation: I modded my v.1.6b xbox with the most recent xchanger chip and evox m8 bios. I successfully installed a new HDD with everything operative (evox dash, MS Dash booted from evox, emulators, games, etc.) Once I had my xbox running, my brother wanted his xbox modded as well. He also has a v.1.6b xbox modded with most recent version of xchanger chip. I installed a new HDD into his xbox along with everything I had on my xbox. Before I switched HDD's, I did make backups of both the C and E drives, EEPROM, etc. After I installed everything, his xbox dash would not boot. It gives an error 21 when trying to boot from Evox and I believe it gives an error 13 if he boots the original bios. After spending many hours reading over different solutions on the internet and tutorials found on this site, I have tried many different approaches to fixing this problem. At first, I thought maybe the evox.ini file was corrupt or not properly configured. I copied my evox.ini over and it still had the same problem. I also read that having missing .xip's could also cause an error 21. I checked his dash and it has the exact same files as mine. I also deleted the CACHE files, still recieve an error 21. I got desperate after many failed attempts at remedying this problem, that I decided to install his dashboard onto my xbox just to see if it works. To my surprise, it worked. My xbox will run both my original dash and his dash, while his xbox will not run either one. I thought it may have been a problem where the HDD was unlocked, but I double checked and it's locked. So, I have no idea what may be causing this error. Are there specific files in the TDATA and UDATA folders on the E: that are required to run the msdash? If not, what other system settings could be causing this problem? I'm leaning towards reformatting the HDD and starting from scratch, but I am afraid I will run into the same problem again.

I appreciate any and all help or advice and I would prefer to fix the issue without formatting if at all possible.

#2 grovespaz

grovespaz

    X-S Senior Member

  • Members
  • PipPip
  • 233 posts
  • Location:The Netherlands
  • Xbox Version:v1.6
  • 360 version:none

Posted 30 August 2006 - 09:19 AM

Well, if your box wasn't v1.6 as well, i would say you were using old dash files on a new box (thats a nono wink.gif )

Did you flash with exactly the same bios?

and, since its chipper, could you unlock and exchange drives, to see if that'll work?

#3 Chancer

Chancer

    Don't You Trust me?

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 18,687 posts
  • Gender:Male
  • Xbox Version:v1.6
  • 360 version:v3.0 (falcon)

Posted 30 August 2006 - 12:39 PM

Corrupt files on the C: drive. You need more than just a good xboxdash.xbe.
If it worked before and it doesn't now then it has to be the files (unless you damaged the NIC during all this)
I would just get AID 3 or equivalent and format the drive and re-install using the files from the installer

#4 jesuf

jesuf

    X-S Enthusiast

  • Members
  • 9 posts

Posted 30 August 2006 - 01:54 PM

Grovespaz, yes it is exactly the same bios. Exchanging the HDD could be a good idea, if mine didnt work in his box it would have to be something other than HDD or system config.

Chancer - It's funny that you mention corrupt files on the C:. When I first modded his box, about 1 month ago, it was having this problem. MSDash has never worked on his box. We downloaded an autoinstaller just to rip the xboxdash files out of it because I did not have my laptop with has backup on it at the time (this was probably 3 days ago). I figured it might be corrupt files, so I went to ftp the xbox dash onto his C: with flashfxp and ran into a problem. Instead of just transferring the files over, it decided to erase all of the files on the C:, with the exception of the very last file that we transferred. SO, he has no dashboard because he is evox was gone, and at the time he did not have a copy of it on his computer. I showed him how to fetch a copy of it and I am assuming he got it from the same place I get all my things, however when he installed evox onto his drive he said he saw some weird files on the C: and he couldn't ftp to it. I wasn't sure what to think but i ftp'd into his box and saw probably 20 files a couple of the names I remember were something like this:
#####
##
######
# congratulations
### our forums
# xbox
One of the files had a size of -840MB while the others totalled up to be more than the capacity of the drive. FTP would not allow us to delete the files so we installed evox on his G: and set his bios to boot from there. Once I was in XBMC, I deleted all of the files, hoping to clear up space on his C:. After deleting all the files, evox, XMBC, and flashfxp all say that the C: only has .1kb of free space. I checked the partition tables and they were correct. My brother is backing up all of his games, etc. (about 100GB worth) onto dvd so that we can try just reformatting and reinstalling. I have also consistently had problems on his box as well as mine with the E:. when I transfer the TDATA Folder over via ftp it copies an infinite number of TDATA folders (almost seems like the allocation table is bad) any ideas on that problem?

#5 jesuf

jesuf

    X-S Enthusiast

  • Members
  • 9 posts

Posted 30 August 2006 - 09:48 PM

Ok, so problem is solved. I ftp'd to my brother's xbox. I formatted his HDD and had him run xbpartition on the c:. He copied his files over to the c: from the g: and it started working all of a sudden. It turned out to be a corrupt c:. I appreciate the help and I hope this might help others with similar problems.

#6 ScrYptiK

ScrYptiK

    X-S Young Member

  • Members
  • Pip
  • 35 posts
  • Xbox Version:v1.0
  • 360 version:none

Posted 30 August 2006 - 10:04 PM

glad to see you fixed it on your own and welcome to X-S




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users