Jump to content


Photo

Problems With Background Animation


  • This topic is locked This topic is locked
17 replies to this topic

#1 mbezik

mbezik

    X-S X-perience

  • Members
  • PipPip
  • 340 posts
  • Location:The Cliffe (Durham) UK
  • Xbox Version:v1.0
  • 360 version:none

Posted 21 September 2006 - 12:36 AM

ive had the background animations disabled recently - but tonight i thought id turn them back on, something very odd seems to have happened to them and im not sure why - any ideas??

IPB Image

as you can see it seems as tho the animation is left in the same place (central) and as the blades move the wallpaper moves making the animation fall out of place

im using the latest mc360 and the latest tech - clean install

Edited by mbezik, 21 September 2006 - 12:40 AM.


#2 Jezz_X

Jezz_X

    X-S Knowledgebase

  • Moderator
  • PipPipPipPipPipPipPipPip
  • 4,531 posts
  • Location:Australia
  • Xbox Version:v1.1
  • 360 version:none

Posted 21 September 2006 - 12:46 AM

I take it you have your own custom spidy animation ? but yes thats the way it works the background animation dosn't move

#3 mbezik

mbezik

    X-S X-perience

  • Members
  • PipPip
  • 340 posts
  • Location:The Cliffe (Durham) UK
  • Xbox Version:v1.0
  • 360 version:none

Posted 21 September 2006 - 12:51 AM

ive never noticed this before - is this new to this version of mc360?.....in the past when ive changed blades the animation seemed to stay stuck behind the spidy image - now it doesnt line up in any of the pages

to be honest i havent used this theme for a while - but i know when i made it it didnt do this

ive just checked it on my other xbox running the last last version of mc360 b4 the latest beta and it all lines up perfect....so its defo just the latest beta that suffers from this

if i could find where the screenshots are getting saved on my other xbox i could post a gif to show this - is there a way to find where the save dir for screenshots is?

Edited by mbezik, 21 September 2006 - 01:06 AM.


#4 roormonger

roormonger

    X-S Genius

  • XS-BANNED
  • PipPipPipPip
  • 808 posts
  • Location:New Jersey- America's Asshole
  • Interests:Mind Taking
  • Xbox Version:v1.6
  • 360 version:none

Posted 21 September 2006 - 01:48 AM

I am not at my house so I can't look in my xbox but i'm retty sure you can find it in either the guisettings.xml or the sources.xml files found in XBMC\UserData\

#5 xbot

xbot

    X-S Member

  • Members
  • Pip
  • 78 posts
  • Xbox Version:v1.1
  • 360 version:none

Posted 21 September 2006 - 01:51 AM

I get the same problem with my custom background animation. Prior to latest release the logo was always in the centre no matter what blade was showing. Now logo moves to the left and right of the centre as the blades switch.

Its called mk babes animation and its with roormongers supermod if somebody wants to test it. Only difference is he resized it to 128 x 128 but mines 255 x 240. Dont know whether this has anything to do with it? Mbezik what size are your background animation images?

Edited by xbot, 21 September 2006 - 01:52 AM.


#6 roormonger

roormonger

    X-S Genius

  • XS-BANNED
  • PipPipPipPip
  • 808 posts
  • Location:New Jersey- America's Asshole
  • Interests:Mind Taking
  • Xbox Version:v1.6
  • 360 version:none

Posted 21 September 2006 - 02:03 AM

Mine works fine, I use the animation called Original Ripples. Maybe the fact that I still use the 9\13 t3ch version, but I don't think that xbmc would have anything to do with the background animation.

#7 Jezz_X

Jezz_X

    X-S Knowledgebase

  • Moderator
  • PipPipPipPipPipPipPipPip
  • 4,531 posts
  • Location:Australia
  • Xbox Version:v1.1
  • 360 version:none

Posted 21 September 2006 - 03:15 AM

It got changed in the skin OK to be constant all the way through it helps streamline the skin

#8 roormonger

roormonger

    X-S Genius

  • XS-BANNED
  • PipPipPipPip
  • 808 posts
  • Location:New Jersey- America's Asshole
  • Interests:Mind Taking
  • Xbox Version:v1.6
  • 360 version:none

Posted 21 September 2006 - 03:27 AM

It does work better in this version.

#9 mbezik

mbezik

    X-S X-perience

  • Members
  • PipPip
  • 340 posts
  • Location:The Cliffe (Durham) UK
  • Xbox Version:v1.0
  • 360 version:none

Posted 21 September 2006 - 07:33 AM

sad.gif - doesnt work better for my spidy theme - and i guess this kinda throws a spanner in the works for all themes that use a wallpaper specific animation (at least all the ones that need to match up to the wallpaper - if there are any others apart from my spidy3 one) sad.gif

Edited by mbezik, 21 September 2006 - 07:37 AM.


#10 roormonger

roormonger

    X-S Genius

  • XS-BANNED
  • PipPipPipPip
  • 808 posts
  • Location:New Jersey- America's Asshole
  • Interests:Mind Taking
  • Xbox Version:v1.6
  • 360 version:none

Posted 21 September 2006 - 07:48 AM

I don't have that theme, what does it do, rain on him?

#11 mbezik

mbezik

    X-S X-perience

  • Members
  • PipPip
  • 340 posts
  • Location:The Cliffe (Durham) UK
  • Xbox Version:v1.0
  • 360 version:none

Posted 21 September 2006 - 08:01 AM

the lightening flashes - which shows the rain and shows on him (not now tho) - it was an idea that lixx had

QUOTE(xbot @ Sep 21 2006, 01:58 AM) View Post

I get the same problem with my custom background animation. Prior to latest release the logo was always in the centre no matter what blade was showing. Now logo moves to the left and right of the centre as the blades switch.

Its called mk babes animation and its with roormongers supermod if somebody wants to test it. Only difference is he resized it to 128 x 128 but mines 255 x 240. Dont know whether this has anything to do with it? Mbezik what size are your background animation images?


sorry bout ignoring you there xbot - i was jus overcome with grief!! - when ive checked my animatin frames are 128x141

#12 roormonger

roormonger

    X-S Genius

  • XS-BANNED
  • PipPipPipPip
  • 808 posts
  • Location:New Jersey- America's Asshole
  • Interests:Mind Taking
  • Xbox Version:v1.6
  • 360 version:none

Posted 22 September 2006 - 03:23 AM

QUOTE
Only difference is he resized it to 128 x 128 but mines 255 x 240. Dont know whether this has anything to do with it? Mbezik what size are your background animation images?


sorry bout ignoring you there xbot - i was jus overcome with grief!! - when ive checked my animatin frames are 128x141


That dosen't matter as much as what the skin stretches the image to. You see now the background images takes up the whole screen with the blades and everything else on top of it, before it was just floating behind the wallpapers stretched just big enough to underlap the blades and when you switched blades it would move over to accomodate the blades on the side.

Oh and mbezik you should clean out your inbox or something I can't send you anymore pm's.

Edited by roormonger, 22 September 2006 - 03:26 AM.


#13 xbot

xbot

    X-S Member

  • Members
  • Pip
  • 78 posts
  • Xbox Version:v1.1
  • 360 version:none

Posted 26 September 2006 - 12:00 PM

Im doing this new background anim and got its almost working nicely on the previous version of MC360 but in v0.98748 its not centred properly.

Given all thats been said above is it a waste of time mucking around with the background anims anymore?






#14 Jezz_X

Jezz_X

    X-S Knowledgebase

  • Moderator
  • PipPipPipPipPipPipPipPip
  • 4,531 posts
  • Location:Australia
  • Xbox Version:v1.1
  • 360 version:none

Posted 26 September 2006 - 12:32 PM

QUOTE(xbot @ Sep 26 2006, 09:07 PM) View Post

Im doing this new background anim and got its almost working nicely on the previous version of MC360 but in v0.98748 its not centred properly.

Given all thats been said above is it a waste of time mucking around with the background anims anymore?

no but its a waste of time trying to get them to match the current wallpaper


#15 roormonger

roormonger

    X-S Genius

  • XS-BANNED
  • PipPipPipPip
  • 808 posts
  • Location:New Jersey- America's Asshole
  • Interests:Mind Taking
  • Xbox Version:v1.6
  • 360 version:none

Posted 26 September 2006 - 06:52 PM

Unless you felt like openineg up a few xml's and resizing and reposistioning them.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users