Jump to content


Photo

Mameox Multiple Folders Problem


  • Please log in to reply
4 replies to this topic

#1 psyman

psyman

    X-S Enthusiast

  • Members
  • 19 posts

Posted 07 November 2006 - 09:28 PM

Hi Folks

I have MAMEoX on my xbox harddrive & I'm fetching the roms from my PC over a wireless network using samba.

To get round the file number limit I have split my roms into 3 folders (roms, roms2, roms3) each eith around 2000 files in.

I have pointed MAMEoX to the correct three folders & rescanned & all the roms appear in my roms list. However I can only load in roms from the first (roms) folder.

Trying to read in roms from roms2 or roms3 results in a message saying that these roms have missing files, but if I copy the same rom to the roms folder it works fine.

Any ideas?

Edited by psyman, 07 November 2006 - 09:29 PM.


#2 psyman

psyman

    X-S Enthusiast

  • Members
  • 19 posts

Posted 13 February 2007 - 11:44 PM

I still havent figured this one out - is there anyone that can help?

#3 Thraxen

Thraxen

    X-S Hacker

  • Moderator
  • PipPipPipPipPipPip
  • 2,691 posts
  • Location:72764
  • Xbox Version:v1.0
  • 360 version:v3.0 (falcon)

Posted 13 February 2007 - 11:56 PM

Hmmm... this problem sounds familiar, but I can't remember how/if it was fixed. I use multiple folders too, but not across a samba share.

Edited by Thraxen, 13 February 2007 - 11:57 PM.


#4 TyBO

TyBO

    X-S Enthusiast

  • Members
  • 24 posts

Posted 23 February 2007 - 06:32 AM

*BUMP*

I am having this exact same problem, minus the Samba share part (all the files are on my Xbox HDD). Help would be very much appreciated. smile.gif

#5 hargle

hargle

    X-S X-perience

  • Members
  • PipPip
  • 413 posts

Posted 23 February 2007 - 03:13 PM

The maximum files per folder on a fatx system is 4096. You *should* be able to pare down the MAME collection to under that many and stuff them all into 1 folder, unless you reeeeeallly like mahjong games. tongue.gif
There are also a bunch of them that won't play at speed that you can delete.

Sharing via samba should bypass this limitation entirely. Psyman, have you tried just pushing everything into the 1 folder that works and seeing if mameox will read them all?

I'm running mameox128+ and I have all my roms locally. I started out with > 4096 roms spread across 2 folders (roms and roms2) and it worked as expected for me. I don't recall doing any magic other than copying the files over, configuring it, and hitting the scan for roms button.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users