Jump to content


Photo

Mc360 Scorpius Media Keyboard Locks Up


  • Please log in to reply
2 replies to this topic

#1 officechris

officechris

    X-S Enthusiast

  • Members
  • 2 posts

Posted 02 February 2007 - 12:12 AM

I have been using the Scorpius P20 Media Keyboard with PM3 for a while. I'm not concerened about mouse support just keyboard. When the receiver is plugged in after MC360 has already booted everything works great! but if the receiver is left plugged in when MC360 tries to load it locks up before the blades are displayed.

The reason I'm posting this is the Scorpius P20 Keyboard is stated in the XBMC manual as

ione Scorpius P20 Media Center RF Keyboard with Integrated Mouse (by Itron) (Both keyboard and int. mouse works perfectly)
o This Scorpius P20 keyboard with integrated mouse comes highly recommended by Gamester17 (XBMC Project Manager)

It is an excellent wireless keyboard and it seems like its simply a driver issue on boot that could be fixed, any ideas? If the XBMC Project Manager recommends it don't you think we should support it hehe smile.gif Any help would be appreciated, thanks!


#2 Jezz_X

Jezz_X

    X-S Knowledgebase

  • Moderator
  • PipPipPipPipPipPipPipPip
  • 4,531 posts
  • Location:Australia
  • Xbox Version:v1.1
  • 360 version:none

Posted 02 February 2007 - 01:14 AM

Ok well this purely a guess but it uses a joystick thing as a mouse right ? If so thats the no1 problem, the way mc360 is built is just not super mouse friendly and never will be it causes all sorts of lockups due to how we use ONFOCUS to navigate to things and replace windows (Home Blades side to side) instead of ONCLICK like PM3 does. I don't think PM3 has a single Onfocused for Nav used in it.
So anyway the best we can do is try and get a thing added to xbmc to allow the skin to switch off mouse support in it by adding somthing to the skin.xml file and that might fix it. I will chat with the guy that makes the skin engine for xbmc and ask him

Now I hope that is the problem


#3 officechris

officechris

    X-S Enthusiast

  • Members
  • 2 posts

Posted 02 February 2007 - 06:17 PM

Excellent man! It has something to do with the way the skin boots though, thats the weird thing. If I let the skin boot up THEN plug the receiver into the controller port, it detects it and everything runs great! Mouse moves around and full keyboard support (don't care for the mouse though, just keyboard). If I leave the receiver in the controller port and boot the xbox to the PM3 skin it loads just fine.

Must be something about the way MC360 skin loads USB driver support or something, not to sure, just thought I would let you know it does work fine, just not on boot. Excellent work, thanks for taking the time to look at this!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users