Jump to content


Photo

<onup> In Gamercard Not Working Correctly?


  • Please log in to reply
2 replies to this topic

#1 timdog82001

timdog82001

    X-S Genius

  • Members
  • PipPipPipPip
  • 877 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 19 February 2007 - 10:57 PM

I added a button in the Media menu (home.xml) where the remote control Guide Button usually is, and because of this, I had to increase the ID number for the DVD play button, which involved changing it in 3 spots, two being changing the actual ID's, and two being changing onfocus commands. I have triple checked to make sure the ID is correct, on them, as well as the onups and ondowns and the gamercard I changed the onup to the appropriate ID (13) but no matter what, when I press up, it goes to the button I added immediately above the dvd button. If I press down from the button I added though, it goes right to the dvd tray button, and I can go down from the dvd tray button to the gamercard no problem....Any ideas of what could be wrong? The button it's going to has an ID of 10, which is what the DVD button originally was, but even doing the "find" function looking for "<onup>10" the only ones it finds in the whole file is in the dvd tray, so that you can navigate to the button I added from the DVD tray. Any help would be appreciated smile.gif

Tim

#2 Jezz_X

Jezz_X

    X-S Knowledgebase

  • Moderator
  • PipPipPipPipPipPipPipPip
  • 4,531 posts
  • Location:Australia
  • Xbox Version:v1.1
  • 360 version:none

Posted 20 February 2007 - 12:05 AM

Ok its going to be a little more complicated than that for you
You are going to need to open up Gamercard_Commons.xml and change the <onup> tags in the top 3 buttons included in the xml. Now because you have done this you are going to need to open up all the home blades with a gamercard in them and insert a control with the ID of 11 so the nav still works in those pages ohmy.gif as well as changing the nav points for the groups with the gamercard in them

As a point of interest the <onup> and <ondown> in the gamercard group in home.xml are only there for when the now playing card is visible because it has no nav to it

#3 timdog82001

timdog82001

    X-S Genius

  • Members
  • PipPipPipPip
  • 877 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 20 February 2007 - 12:17 AM

Edit: nevermind, fixed it. Thanks for the help. I ended up just changing the dvd tray back 10 and adjusted the id's of everything else. Things aren't completely sequential now, but at least i don't have to edit 10 different files

Edited by timdog82001, 20 February 2007 - 12:27 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users