Jump to content


Photo

Dropped My Psp


  • Please log in to reply
8 replies to this topic

#1 poo87

poo87

    X-S Expert

  • Members
  • PipPipPip
  • 639 posts
  • Location:Dunedin, Fl
  • Interests:Cutting, sanding, painting, lighting, anything I can get my hands on to. Oh yea, I play bass too.
  • Xbox Version:v1.0
  • 360 version:unknown

Posted 15 March 2007 - 02:54 AM

So I finally started putting videos on it and what do you know I drop the damn thing sad.gif When I try to turn it on the green light comes on for about a sec. then turns off. I've tried hooking up to the charge cable and even put in a new battery but nothing is working. It doesn't sound like theres anything loose inside but I haven't taken it apart to see yet. So I was wondering if anyone has had or heard of a similar problem and might be able to help me before I start unscrewing things. thanks for any help

#2 atomiX

atomiX

    X-S Messiah

  • Members
  • PipPipPipPipPipPipPip
  • 3,225 posts
  • Location:NB, Canada
  • Interests:Doesn't matter...
  • Xbox Version:v1.3
  • 360 version:v1 (xenon)

Posted 15 March 2007 - 03:33 AM

Doesn't sound good that's for sure. Can it do anything with AC power only (no battery)?

#3 poo87

poo87

    X-S Expert

  • Members
  • PipPipPip
  • 639 posts
  • Location:Dunedin, Fl
  • Interests:Cutting, sanding, painting, lighting, anything I can get my hands on to. Oh yea, I play bass too.
  • Xbox Version:v1.0
  • 360 version:unknown

Posted 15 March 2007 - 04:14 AM

i tried that already and it's does the same thing, I've also tried without the mem stick and now I'm letting it sit for awhile with the battery out. If that doesn't work I'm going to go ahead and upon it up to see if theres anything that came loose. Damn I really hope I can get this working again sleep.gif

#4 o The Drizzle o

o The Drizzle o

    X-S X-perience

  • Members
  • PipPip
  • 420 posts
  • Location:Sheetz Country, Pennsylvania
  • Xbox Version:v1.0
  • 360 version:v4.0 (jasper)

Posted 17 March 2007 - 01:41 AM

if it has custom firmware jake, try booting in to the recovery menu

#5 poo87

poo87

    X-S Expert

  • Members
  • PipPipPip
  • 639 posts
  • Location:Dunedin, Fl
  • Interests:Cutting, sanding, painting, lighting, anything I can get my hands on to. Oh yea, I play bass too.
  • Xbox Version:v1.0
  • 360 version:unknown

Posted 18 March 2007 - 03:07 AM

nah, its a stocky dry.gif

#6 o The Drizzle o

o The Drizzle o

    X-S X-perience

  • Members
  • PipPip
  • 420 posts
  • Location:Sheetz Country, Pennsylvania
  • Xbox Version:v1.0
  • 360 version:v4.0 (jasper)

Posted 20 March 2007 - 12:48 AM

stocky? well theres your first problem. lol

#7 Casper1786

Casper1786

    X-S Genius

  • Members
  • PipPipPipPip
  • 915 posts
  • Xbox Version:v1.3
  • 360 version:v1 (xenon)

Posted 21 April 2007 - 11:47 PM

well if you havn't modified it yet and have never opened it before an if ur lucky an it doesn't look like it's been dropped these things do have a 1 year waranty you know, you could see if sony is anyhelp

#8 epsilon72

epsilon72

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,213 posts
  • Location:Arizona
  • Interests:updating my interests section of my profile
  • Xbox Version:v1.6
  • 360 version:none

Posted 30 April 2007 - 07:28 AM

QUOTE(o The Drizzle o @ Mar 19 2007, 05:24 PM) View Post
stocky? well theres your first problem. lol

That needs to be fixed asap. ph34r.gif


#9 gorgs

gorgs

    X-S Enthusiast

  • Members
  • 17 posts

Posted 16 September 2007 - 09:18 AM

I done the same thing(well my son)so i hid it for a week,then it just seemed to work?
psp fairies?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users