Jump to content


Photo

Preparing For First Flash, Couple Problems/questions.


  • Please log in to reply
15 replies to this topic

#1 Aberrix

Aberrix

    X-S Enthusiast

  • XS-BANNED
  • 20 posts
  • Xbox Version:v1.2
  • 360 version:v1 (xenon)

Posted 16 March 2007 - 01:37 PM

Hello, I am preparing to do my first flash. I have been reading over and following the .pdf guide (Textbook) off 360mods.net. I have my 360 open, I found out I have a Samsung m25 drive and am now preparing the firmware. I believe I have all the needed tools, however I have a couple problems and questions;

1) Do I need to have my AV cables hooked up to my 360 while I flash the drive?

2) I am using Xtreme Boot Maker (v0.3.6.142200), I select my (onboard) SATA chipset (Silicon Image SiI 3114 SoftRaid 5 Controller, ASUS A8N-SLI Premium motherboard) then when I try and select "Detect ID/IO" I get an error "Unable to generate MSINFO dump"

I am using Windows Vista Ultimate, Is this incompatible with the Xtreme boot maker? I've tried to do my own export via msinfo32.exe and try and dump that into the Xtreme Boot Maker directory but have had no luck. I have tried to make sure I am running the program with administrator privileges, no luck either... Any assistance as to what I am doing wrong or how to fix this would be highly appreciated!

p.s. I should also mention I am currently running RAID-0

#2 jabroniekilla

jabroniekilla

    X-S Hacker

  • XS-BANNED
  • PipPipPipPipPipPip
  • 2,008 posts
  • Location:VT
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 16 March 2007 - 02:44 PM

You definately need the A/V plugged in or the 360 will turn off at a bad time, like when you are flashing.
silicon chipsets do not work with flashing samsung drives. try getting a card with VIA chipset if you can. And raid needs to be disabled.
try reading the tutorial that is in my sig.

#3 Aberrix

Aberrix

    X-S Enthusiast

  • XS-BANNED
  • 20 posts
  • Xbox Version:v1.2
  • 360 version:v1 (xenon)

Posted 16 March 2007 - 02:49 PM

QUOTE(jabroniekilla @ Mar 16 2007, 08:51 AM) View Post

silicon chipsets do not work with flashing samsung drives. try getting a card with VIA chipset if you can. And raid needs to be disabled.
try reading the tutorial that is in my sig.


That guide is in fact the one I am using.

In the guide it says that the on-board sil 3114 chipset is compatible, it says its the pci sil 3114 card that is not.

----------------------------

Is this not working because RAID is currently on? If I installed say Windows XP on a separate (IDE) drive and then tried would this (most likely) work?

Edited by Aberrix, 16 March 2007 - 02:49 PM.


#4 jabroniekilla

jabroniekilla

    X-S Hacker

  • XS-BANNED
  • PipPipPipPipPipPip
  • 2,008 posts
  • Location:VT
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 16 March 2007 - 02:59 PM

you definately need to disable raid. I thought that none of the silicon chipsets work, sorry if that is not true. I dont think having XP will make any difference because you are dumping and flashing from dos.

#5 Aberrix

Aberrix

    X-S Enthusiast

  • XS-BANNED
  • 20 posts
  • Xbox Version:v1.2
  • 360 version:v1 (xenon)

Posted 16 March 2007 - 03:16 PM

Okay, So I downloaded Xtreme Book Maker version: 0.5.3 (RC1)

I think the anti-virus (Avast!) was detecting a false-positive, as McAfee had no problems with it... (odd...)

So I loaded up the new version, selected my drive (Samsung m25) and then selected the Xtreme52.rar and was able to successfully select my on-board SATA controller, selected 5.2b firmware and it says I successfully flashed my USB drive. So... everything looks good so far now... I hope everything goes well.

#6 jabroniekilla

jabroniekilla

    X-S Hacker

  • XS-BANNED
  • PipPipPipPipPipPip
  • 2,008 posts
  • Location:VT
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 16 March 2007 - 03:37 PM

report back with your progress.

#7 Aberrix

Aberrix

    X-S Enthusiast

  • XS-BANNED
  • 20 posts
  • Xbox Version:v1.2
  • 360 version:v1 (xenon)

Posted 16 March 2007 - 09:09 PM

So I got it to boot and it looks like it 'sees' the drive when I do an "xread 12345467 12345", i get the following

1. XTREME
2. Sil3114

however after choosing either, it just hangs... nothing...

any idea's?

#8 Aberrix

Aberrix

    X-S Enthusiast

  • XS-BANNED
  • 20 posts
  • Xbox Version:v1.2
  • 360 version:v1 (xenon)

Posted 18 March 2007 - 05:05 PM

bump

#9 Aberrix

Aberrix

    X-S Enthusiast

  • XS-BANNED
  • 20 posts
  • Xbox Version:v1.2
  • 360 version:v1 (xenon)

Posted 20 March 2007 - 12:29 PM

Well I did it! I successfully flashed my ms25 drive.

I used the nforce chipset on the motherboard, I used the BIOS settings found here.

Basically I used the newest Xtreme Boot Maker (0.5.3) then just copied over a hacked mtkflash for the nforce chipset, which I found in 'Toshiba-Samsung_360_Auto_Flasher_v3.2.rar'. I booted from my USB drive and the 'xread' command worked just fine, then rebooted the PC & xbox. I ended up having to manually issue the command to flash the drive 'mtkflash w /m /sata Backups/[7-digit serial]/[5-digit serial]/xtremefw.bin' as xflash did not work for me.

tested with a backup (on ridata 2.4x DVD-DL) and it worked great!

Edited by Aberrix, 20 March 2007 - 12:30 PM.


#10 SeMz

SeMz

    X-S Enthusiast

  • Members
  • 16 posts

Posted 20 March 2007 - 01:37 PM

QUOTE(Aberrix @ Mar 20 2007, 12:36 PM) View Post

Well I did it! I successfully flashed my ms25 drive.

I used the nforce chipset on the motherboard, I used the BIOS settings found here.

Basically I used the newest Xtreme Boot Maker (0.5.3) then just copied over a hacked mtkflash for the nforce chipset, which I found in 'Toshiba-Samsung_360_Auto_Flasher_v3.2.rar'. I booted from my USB drive and the 'xread' command worked just fine, then rebooted the PC & xbox. I ended up having to manually issue the command to flash the drive 'mtkflash w /m /sata Backups/[7-digit serial]/[5-digit serial]/xtremefw.bin' as xflash did not work for me.

tested with a backup (on ridata 2.4x DVD-DL) and it worked great!

Congrats buddy!!!

Hopefully I achieve the same success when I do my Hitachi drive tommorow morning! I'm using Vista Ultimate aswell so I was unsure whether it would work for me but it has for you, so it will be fine over here!

When you back up games are you using the WXRipper method?

#11 nightwulf28

nightwulf28

    X-S X-perience

  • Members
  • PipPip
  • 319 posts
  • Location:Duluth, MN
  • Interests:ummmmm Video Games?
  • Xbox Version:v1.2
  • 360 version:v1 (xenon)

Posted 20 March 2007 - 04:17 PM

so my question is. i have the newest version of xtreme bootmaker, the textbook tut. has an older version and i got confused on whcih promts to use in dos as its different then it says. like a prior post i read yoe use xread and xflash, but how did you know to use that as the tut is outdated version of this app? i have follwed it to a tee so far but want to make sure b4 flashing that this is the proper prompts etc. first time here so basically need reassurance and steps on this part and what on that app i choose, it looks simople enough i think, but again its a newer version. is there a tut on useing it somewhere? any help appreciated etc. smile.gif

#12 Aberrix

Aberrix

    X-S Enthusiast

  • XS-BANNED
  • 20 posts
  • Xbox Version:v1.2
  • 360 version:v1 (xenon)

Posted 20 March 2007 - 05:09 PM

QUOTE(nightwulf28 @ Mar 20 2007, 10:24 AM) View Post

so my question is. i have the newest version of xtreme bootmaker, the textbook tut. has an older version and i got confused on whcih promts to use in dos as its different then it says. like a prior post i read yoe use xread and xflash, but how did you know to use that as the tut is outdated version of this app?


I am kind of unsure of where you are going here... as far as I recall there are no difference in dos commands from the older version to the newer version of xtreme boot maker.

If you are referring to where I manually entered the command 'mtkflash w /m /sata Backups/[7-digit serial]/[5-digit serial]/xtremefw.bin', this was because xflash was not working for me and I knew (from reading another tutorial that I can't find right now) that essentially thats all xflash did was issue the above command.


QUOTE(nightwulf28 @ Mar 20 2007, 10:24 AM) View Post

i have follwed it to a tee so far but want to make sure b4 flashing that this is the proper prompts etc. first time here so basically need reassurance and steps on this part and what on that app i choose, it looks simople enough i think, but again its a newer version. is there a tut on useing it somewhere? any help appreciated etc.


just read the tutorial(s) thoroughly and make sure you understand what you're doing and you should be okay.

from my little experience, everything is/was pretty straight forward. however, if you have little hardware conflicts/quirks like I did it may take some more time to figure out.

#13 nightwulf28

nightwulf28

    X-S X-perience

  • Members
  • PipPip
  • 319 posts
  • Location:Duluth, MN
  • Interests:ummmmm Video Games?
  • Xbox Version:v1.2
  • 360 version:v1 (xenon)

Posted 20 March 2007 - 05:19 PM

QUOTE(Aberrix @ Mar 20 2007, 11:16 AM) View Post

I am kind of unsure of where you are going here... as far as I recall there are no difference in dos commands from the older version to the newer version of xtreme boot maker.

If you are referring to where I manually entered the command 'mtkflash w /m /sata Backups/[7-digit serial]/[5-digit serial]/xtremefw.bin', this was because xflash was not working for me and I knew (from reading another tutorial that I can't find right now) that essentially thats all xflash did was issue the above command.
just read the tutorial(s) thoroughly and make sure you understand what you're doing and you should be okay.

from my little experience, everything is/was pretty straight forward. however, if you have little hardware conflicts/quirks like I did it may take some more time to figure out.



See, if you follow the textbook tut. the instructions on the app are saying to use dos prompts that dont work. they have changed from sam hack and sam flash. on that tut the app instructions are slightly diff as the newer version is laid out a bit differnet. does that help?

#14 Aberrix

Aberrix

    X-S Enthusiast

  • XS-BANNED
  • 20 posts
  • Xbox Version:v1.2
  • 360 version:v1 (xenon)

Posted 20 March 2007 - 05:22 PM

QUOTE(nightwulf28 @ Mar 20 2007, 11:26 AM) View Post

See, if you follow the textbook tut. the instructions on the app are saying to use dos prompts that dont work. they have changed from sam hack and sam flash. on that tut the app instructions are slightly diff as the newer version is laid out a bit differnet. does that help?


which guide are you following exactly? try this.

the guide says to use xread and xflash.

#15 nightwulf28

nightwulf28

    X-S X-perience

  • Members
  • PipPip
  • 319 posts
  • Location:Duluth, MN
  • Interests:ummmmm Video Games?
  • Xbox Version:v1.2
  • 360 version:v1 (xenon)

Posted 20 March 2007 - 07:01 PM

QUOTE(Aberrix @ Mar 20 2007, 11:29 AM) View Post

which guide are you following exactly? try this.

the guide says to use xread and xflash.



ok. i now see the instruction set using those prompts. now my other question b4 i go here is the textbook tut. says to put 3 files from sam hack on usb. i assume i can use a cd as instructed in the tut. as well, correct? this app backs up my original firmware , does it not? and am i suing mtk flash here? sorry im a little confused.. doesnt appear i need anything else other than xtremem bootmaker and the x360 sam tools. right?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users