Jump to content


Photo

Sata Compatability Problem


  • This topic is locked This topic is locked
1 reply to this topic

#1 NoIncentive

NoIncentive

    X-S Enthusiast

  • Members
  • 12 posts

Posted 21 March 2007 - 01:49 AM

So every time I use the bootmaker to create my bootfiles on my usb flash drive, I only have the option of selecting "SCSI/Raid Host Controller" for serial ata. If I select this, then I get the error stating that mtkflash is incompatible. I figured that my problem was the lack of the proper sata controller. So, I tried to install Intel Application Accelerator, which is my sata's (ICH5R) controller. However, I get an error saying that my chipset is incompatible. So, I updated my Intel chipset and I still get the same error, disallowing me to install the ICH5R controller.

I believe that the problem is that when I installed Windows, I slipstreamed some windows sata drivers (as opposed to using F6 and installing the intel drivers off a floppy - mainly because I had no floppy drive at the time), now my chipset is not read properly by Intel Application Accelerator. I know that the ICH5R is compatible with mtkflash/bootmaker, though.

A few questions:
1.) Is there a way around this to install a compatible SATA controller (or a way to get "SCSI/RAID Host Controller" working with bootmaker)?

2.) Does anyone know a way where I can reinstall the proper SATA drivers/controller/chipset.

3.) Do I lose all hope, and try a fresh install of windows on another HDD?

4.) I used my roommate's computer for a bit and almost successfully flashed my 360's dvd drive, but his Shuttle Motherboard won't boot from the usb device, properly. Any advice on getting my usb to work (I may go out and buy a usb floppy disk for this)?

5.) Am I just wayyy off?

My computer's info:
Asus P4P800 SE Motherboard, 3.00Ghz P4, 1GB RAM
Intel 865PE chipset
Intel ICH5R Serial control

#2 NoIncentive

NoIncentive

    X-S Enthusiast

  • Members
  • 12 posts

Posted 21 March 2007 - 02:24 AM

I also had another thought. Could I also just load mtkflash onto my usb pen along with the 5.2c firmware and use the "mtkflash r m/ backup.bin" and "mtkflash w m/ xtrem52c.bin" commands, respectively (as opposed to "samread" and "samhack")? I have used mtkflash like this in the past, but never for flashing a SATA DVD drive, So I would need to be told the appropriate steps. Any comments?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users