Jump to content


Photo

Mandatory Firmware 1.50 Upgrade Coming With European Titles


  • Please log in to reply
2 replies to this topic

#1 openxdkman

openxdkman

    X-S Genius

  • Moderator
  • PipPipPipPip
  • 823 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 22 March 2007 - 03:39 PM

So... if you got a ps3 title at european launch and you have a jap or us ps3 with a sweet ancient firmware version, try to resist the envy and wait for infos about both ferrox and paradox exploits.

If 1.50 is ok for exploits, it will be a nice trick for older firmware owner to raise a bit their version but still stay in the correct range.

Edited by openxdkman, 22 March 2007 - 03:41 PM.


#2 seanzi

seanzi

    X-S Enthusiast

  • Members
  • 12 posts

Posted 22 March 2007 - 08:32 PM

from what i have read is it only virtua fighter 5 which has a firmware upgrade or is it all launch titles?

#3 openxdkman

openxdkman

    X-S Genius

  • Moderator
  • PipPipPipPip
  • 823 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 23 March 2007 - 07:27 AM

No it's all titles.
I've tested myself european version of resistance fall of the man.
It asks you to upgrade to 1.50 when you insert disk.

By all means, do not update until exploits are revealed. You may miss something big!
(1.60 is definitely not good to have for now, it seems)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users