Jump to content


Photo

Youtube Doesn't Work


  • Please log in to reply
11 replies to this topic

#1 yashijoe

yashijoe

    X-S Enthusiast

  • Members
  • 20 posts

Posted 22 June 2007 - 10:45 AM

I've tried the YouTube script that you can find in the Live Place.

I can load the list of videos,
I can search a video using keywords

but when I play it, it seems to connect and then it come back to the list view.

After that I can move inside the list view but I cannot select any other list or come back to the
Live Place or to the main menu.

So I've to reboot the console.

I've already updated the YouTube script to the last one: YouTube v1.8b. Nothing has changed

I'm using a router (d-link), should I've to open some ports?

Just for knowing:
- the meteo works well
- I can download new theme
- I can download the new xbmc releases
- I can use the internet time updating
- I can download music/video info
- I can download new scripts

Thanks in advance.
Y.

T3CH XBMC 2007-06-17 SVN rev9336
MC360 XBMC Skin Version 1.05 Rev 804
CLEAN INSTALL

Edited by yashijoe, 22 June 2007 - 10:50 AM.


#2 weinerschnitzel

weinerschnitzel

    X-S Senior Member

  • Dev/Contributor
  • PipPip
  • 277 posts
  • Xbox Version:v1.0
  • 360 version:v4.0 (jasper)

Posted 01 July 2007 - 07:02 PM

I've gotten the same problem too. Here is the fix. Take your new YouTube script that works, then rename it to "yt.py"
Then you move that folder to MC360/extras/XBMCLivePlace/ and replace the existing yt.py script. Then put the MC360 YouTube skin in the script's subdirectory

#3 yashijoe

yashijoe

    X-S Enthusiast

  • Members
  • 20 posts

Posted 01 July 2007 - 09:22 PM

Tomorrow I'll try.
Meanwhile thank you v.m.!
y.

#4 weinerschnitzel

weinerschnitzel

    X-S Senior Member

  • Dev/Contributor
  • PipPip
  • 277 posts
  • Xbox Version:v1.0
  • 360 version:v4.0 (jasper)

Posted 02 July 2007 - 09:41 PM

Jezz_X fixed this in rev 816. It now looks for the script in (XBMC) /scripts/youtube/default.py This way it stays up to date easily and it is better organized. Thanks Jezz. So you wont need to bother with it anymore. Ill post back in a minute if that MC360 skin for the youtube script is needed.

#5 xjc

xjc

    X-S Enthusiast

  • Members
  • 10 posts

Posted 02 July 2007 - 09:56 PM

With the latest revision MC360 818, Youtube still doesn't work. The behavior is exactly as described in the top post. Maybe this is a bug in the Youtube script itself?

#6 weinerschnitzel

weinerschnitzel

    X-S Senior Member

  • Dev/Contributor
  • PipPip
  • 277 posts
  • Xbox Version:v1.0
  • 360 version:v4.0 (jasper)

Posted 02 July 2007 - 10:27 PM

No it is not MC360. I just compiled a new set of XBMC binaries and put together rev 818. Right now I have the latest SVN version of the youtube script running and it works fine. The only thing though is you'll need youtube in Q:\scripts\youtube\default.py and you will need the MC360 skin for youtube (was on BlackBolt's site before) in Q:\scripts\youtube\skins\MC360\. Maybe the youtube on SVN will eventually include the mc360 skin or what not.

#7 xjc

xjc

    X-S Enthusiast

  • Members
  • 10 posts

Posted 02 July 2007 - 10:34 PM

I tried a different build of youtube script and it worked with new MC360 revision:

Download youtube 2.0.93 from xbmcscripts.com, extract to <xbmc>/scripts, rename YouTube2 to YouTube.

#8 yashijoe

yashijoe

    X-S Enthusiast

  • Members
  • 20 posts

Posted 03 July 2007 - 10:37 AM

Hi weinerschnitzel,

now I've update the xbmc to the last version: 9489
and the MC360 to the 818

I've installed the youtube script 1.8b without changing the file name (as you wrote me)
It seems to have the same problem.
I've also tried the youtube2 scripts and it works.

My only matter is to use the beautiful MC360 skin for the youtube scrip. This afternoon I will try again

Another problem: since I've installed the new xbmc/mc360 releases the xboxscripts download doesn't work anymore, I've to manually upload them.


Note: I always delete all the xbmc folder and all the savegames directory
Thank you
y.

Edited by yashijoe, 03 July 2007 - 10:39 AM.


#9 Jezz_X

Jezz_X

    X-S Knowledgebase

  • Moderator
  • PipPipPipPipPipPipPipPip
  • 4,531 posts
  • Location:Australia
  • Xbox Version:v1.1
  • 360 version:none

Posted 03 July 2007 - 01:33 PM

The old script version with the mc360 is broken
the new version does not have a mc360 skin and I'm not makign one for it feel free anyone else who wants too

The current Youtube script I think also has a problem since youtube changed layout (but this could be me mis understanding)

#10 weinerschnitzel

weinerschnitzel

    X-S Senior Member

  • Dev/Contributor
  • PipPip
  • 277 posts
  • Xbox Version:v1.0
  • 360 version:v4.0 (jasper)

Posted 03 July 2007 - 06:29 PM

Jezz_X, I remember that the blackbolt website hosted an mc360 skin for the youtube script. Have I been hallucinating or is there any bit of the youtube mc360 skin that you or BB have and wouldn't mind releasing so someone else could make the script skin with some base work?

#11 NML

NML

    X-S Enthusiast

  • Members
  • 2 posts

Posted 03 July 2007 - 11:10 PM

QUOTE(xjc @ Jul 2 2007, 06:10 PM) View Post

I tried a different build of youtube script and it worked with new MC360 revision:

Download youtube 2.0.93 from xbmcscripts.com, extract to <xbmc>/scripts, rename YouTube2 to YouTube.



YouTube is now working for me but the audio and video is running too fast and jerky. blink.gif


#12 Jezz_X

Jezz_X

    X-S Knowledgebase

  • Moderator
  • PipPipPipPipPipPipPipPip
  • 4,531 posts
  • Location:Australia
  • Xbox Version:v1.1
  • 360 version:none

Posted 04 July 2007 - 01:11 AM

QUOTE(NML @ Jul 4 2007, 08:46 AM) View Post

YouTube is now working for me but the audio and video is running too fast and jerky. blink.gif

You need to update xbmc it was a bug about 2 t3ch ago

QUOTE(weinerschnitzel @ Jul 4 2007, 04:05 AM) View Post

Jezz_X, I remember that the blackbolt website hosted an mc360 skin for the youtube script. Have I been hallucinating or is there any bit of the youtube mc360 skin that you or BB have and wouldn't mind releasing so someone else could make the script skin with some base work?

There was never any skin for youtube script as far as I know what we had was a rewrite of the original youtube script to make the graphics look like mc360.
Since then that script has been retired and replaced by a better youtube2 script that uses GUIBUILDER to skin it and since I don't use it (mc360 or the script) I have no intention of doing it personally If anyone else wants to do it and it looks good then maybe we can put it up on the site

The only skins that I did was for AMT, Accuweather, and XBMC_Lyrics and AMT will be way out of date now because it just keeps changing




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users