Jump to content


Photo

Share Wireless Connection


  • Please log in to reply
5 replies to this topic

#1 titancore

titancore

    X-S Enthusiast

  • Members
  • 8 posts

Posted 23 July 2007 - 12:19 AM

Anyone hav any luck sharing an internet connection with an xbox?

The setup i want is

my laptop connected to the xbox
my laptop also wirelessly connected to my router

to allow my desktop to ftp into my xbox. so far all the settings with no luck.
could this be a router issue? must i forward some ports? i've been racking my brain trying to figure this out.

#2 exraid

exraid

    X-S Member

  • Members
  • Pip
  • 149 posts

Posted 23 July 2007 - 05:20 AM

Why not run a ethernet cable from the xbox to the router?

#3 titancore

titancore

    X-S Enthusiast

  • Members
  • 8 posts

Posted 23 July 2007 - 05:29 AM

its downstairs biggrin.gif . and all my laptops are usually down there so itll be easier that way, but most of my surfing and files are on my computer in my room up stairs.

#4 obcd

obcd

    X-S Hacker

  • Moderator
  • PipPipPipPipPipPip
  • 2,737 posts
  • Xbox Version:v1.0
  • 360 version:none

Posted 23 July 2007 - 08:43 AM

Hi,

A couple of things to check.


Since your xbox is directly connected to your laptop, you will need to give it a static ip adress. (Like 192.168.1.xxx) You will need to give your laptop a static ip adress on it's ethernet adapter as well. The first 3 numbers must be the same, and the fourth must be different. Make sure you change the network settings of the ethernet adapter and not those of the wireless network adapter.

You will need a crossover cable to connect the 2. A normal straight UTP cable will not work.

Disable your laptop firewall settings until it works. After it works, you can turn it on again. It will probably stop working. You can than Tune your firewall settings until it works again.

The Subnet mask should be set to 255.255.255.0. You can add the laptop ip adress as default gateway adress for your xbox.

Try to ping your xbox ip adress to see if you have network connectivity with it. If you don't have that, ftp can't work either.

(Open a command prompt and enter the command ping 192.168.1.xxx) The xxx should match the ip number of the xbox.

Check the lights around the ethernet connector. At least one should be one when the xbox is connected to the laptop. The other one should flash when there is network activity.

regards.

#5 titancore

titancore

    X-S Enthusiast

  • Members
  • 8 posts

Posted 24 July 2007 - 03:58 AM

thanks for the reply obcd.

I did all of the things you suggested, crossover wire is a yes. But i still can't figure out the settings to have the xbox connected to the network. It seems it's only connected to the laptop and that's it. I enabled ICS, am i suppose to do this? yes no? help is appreciated thanks guys.

#6 obcd

obcd

    X-S Hacker

  • Moderator
  • PipPipPipPipPipPip
  • 2,737 posts
  • Xbox Version:v1.0
  • 360 version:none

Posted 24 July 2007 - 08:13 AM

Hi,

yes, you should enable internet connection sharing on the laptop. I thought you only needed ftp transfer between the laptop and the xbox. I hadn't noticed the need for intenet connectivity.

I have never done such connection myself. According to a tutorial I read on the Internet, The Local IP adresses are all in the range 192.168.0.XXX. The difference with your setup is the third number which should be 0 instead of 1. Your pc should have the IP adress 192.168.0.1. In your xbox network setup, you should give that number as gateway and also as DNS server. Give the xbox the ip adress 192.168.0.254.

According to the tutorial, you can use DHCP. (The xbox setting obtain a ip adress automatically). The PC will give DHCP clients the adresses starting from 192.168.0.2 and going up. You are not sure with this method that your xbox will always have the same IP adress. If you ftp to the Ip adress, you might need to change that every time. For that reason, I would give it a static IP adress.


regards.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users