Jump to content


Photo

Easy Mkv To Mp4 For Xbox 360


  • Please log in to reply
217 replies to this topic

#46 Kerath

Kerath

    X-S Enthusiast

  • Members
  • 4 posts

Posted 28 November 2007 - 03:21 AM

I'd looked for a way to do this a few months ago, but didn't find anything, so I was happy to see this...but I'm having some trouble.

MP4Box crashes at 99%. The created mp4 file looks fine on my computer but on my 360 there are weird blocks on the picture, especially for moving areas. Other people are having this problem but I see no solutions.

Any ideas? I streamed it with TVersity. I'll also try burning it soon.

Edited by Kerath, 28 November 2007 - 03:22 AM.


#47 Kerath

Kerath

    X-S Enthusiast

  • Members
  • 4 posts

Posted 28 November 2007 - 05:33 AM

Burning doesn't work either. I'm going to try mp4creator and GOTSend and report back.

Edited by Kerath, 28 November 2007 - 05:33 AM.


#48 kevroman

kevroman

    X-S Enthusiast

  • Members
  • 21 posts

Posted 28 November 2007 - 07:11 AM

yea I'm having the same problem. I read somewhere that Dimension releases have this type of problem, but I have had this problem with other releases as well. It might be the way that these people are encoding the video... does anyone know how to fix this or what is making it to this?

#49 Kerath

Kerath

    X-S Enthusiast

  • Members
  • 4 posts

Posted 28 November 2007 - 09:13 AM

I've only tried it with the latest Heroes episode, 720p.

#50 J^^

J^^

    X-S Enthusiast

  • Members
  • 26 posts

Posted 30 November 2007 - 03:02 AM

QUOTE(Kerath @ Nov 27 2007, 10:57 PM) View Post

I'd looked for a way to do this a few months ago, but didn't find anything, so I was happy to see this...but I'm having some trouble.

MP4Box crashes at 99%. The created mp4 file looks fine on my computer but on my 360 there are weird blocks on the picture, especially for moving areas. Other people are having this problem but I see no solutions.

Any ideas? I streamed it with TVersity. I'll also try burning it soon.


MP4Box will do that but the file is still playable and complete.

#51 Chanman

Chanman

    X-S Enthusiast

  • Members
  • 3 posts

Posted 30 November 2007 - 06:40 AM

I have a bunch of questions about this.

I was able to successfully do the conversion using the GotSent tool at http://sentry23.googlepages.com/. The only problem is that while I get perfectly synchronized audio/video, sometimes the video is blocky. Has anyone seen this problem and resolved it?

Second, I'm able to share this mp4 video, see it, and play it directly in the X360 using WMP11's Library sharing. However, if I go into Media Center from the X360 menu and try to view it that way, I get a "codec not supported" error message. Is there any way to get this thing to play in Media Center Extender? (Note: it does work if I use Transcode360, but that seems kind of stupid.. convert to mp4 and then transcode to view.)



#52 Kerath

Kerath

    X-S Enthusiast

  • Members
  • 4 posts

Posted 30 November 2007 - 10:42 PM

QUOTE(J^^ @ Nov 29 2007, 09:38 PM) View Post

MP4Box will do that but the file is still playable and complete.


Yes, it was complete and playable, it just had a huge amount of weird artifacts when playing on my 360.


#53 J^^

J^^

    X-S Enthusiast

  • Members
  • 26 posts

Posted 01 December 2007 - 02:25 PM

QUOTE(Chanman @ Nov 30 2007, 02:16 AM) View Post

I have a bunch of questions about this.

I was able to successfully do the conversion using the GotSent tool at http://sentry23.googlepages.com/. The only problem is that while I get perfectly synchronized audio/video, sometimes the video is blocky. Has anyone seen this problem and resolved it?

Second, I'm able to share this mp4 video, see it, and play it directly in the X360 using WMP11's Library sharing. However, if I go into Media Center from the X360 menu and try to view it that way, I get a "codec not supported" error message. Is there any way to get this thing to play in Media Center Extender? (Note: it does work if I use Transcode360, but that seems kind of stupid.. convert to mp4 and then transcode to view.)



If you read the Xbox 360 Video FAQ you'll see that mp4 is not spported in Media Center.... they only videos supported through MC are wmv and mpeg-2.

QUOTE(Kerath @ Nov 30 2007, 06:18 PM) View Post

Yes, it was complete and playable, it just had a huge amount of weird artifacts when playing on my 360.


Don't know what to tell you. If I get artifiacts.... it is only for a second or two and only happens once throughout the entire video. Sorry!

Edited by J^^, 01 December 2007 - 02:23 PM.


#54 thomazff

thomazff

    X-S Enthusiast

  • Members
  • 8 posts

Posted 03 December 2007 - 12:33 AM

How about subtitles?

Is there a way to use this way and have subtitles working with xbox 360?

#55 budmanv24

budmanv24

    X-S Enthusiast

  • Members
  • 11 posts

Posted 05 December 2007 - 07:23 PM

QUOTE(impimpin206 @ Sep 4 2007, 03:28 AM) View Post

Only WMV-HD can do 5.1 audio; mp4 is limited to 2ch.


So wmv-hd supports 5.1 and p4 doesn't? So far I've been playing mostly 720p mp4 content converted by other people. Although the 2.1 audio is a bummer the picture kinda makes up for it. I tried encode 360 some myself and haven;t been happy with the results or the time it takes. When it comes to streaming hd content what do I need to keep in mind for encoding or modifying files and which of these methods seems to be working best? My tv is 1080p and I have an elite, but most movies encoded in 1080p seem to be fairly pixelated by encoders...is there anyway around this?

#56 gunzdiesel

gunzdiesel

    X-S Young Member

  • Members
  • Pip
  • 45 posts

Posted 05 December 2007 - 11:11 PM

How are sync issues going for everyone once converted? That's one of my biggest gripes about encoding stuff myself, I'm usually left with a video that's out of sync half way through or near the end. I can't stand it when shit's outta sync, it's like I have OCD and constantly check to see if the movie's in sync... unsure.gif

#57 Goodgsheppard

Goodgsheppard

    X-S Enthusiast

  • Members
  • 12 posts

Posted 06 December 2007 - 01:15 PM

QUOTE(gunzdiesel @ Dec 5 2007, 11:47 PM) View Post

How are sync issues going for everyone once converted? That's one of my biggest gripes about encoding stuff myself, I'm usually left with a video that's out of sync half way through or near the end. I can't stand it when shit's outta sync, it's like I have OCD and constantly check to see if the movie's in sync... unsure.gif



The Threadstarter just forgot to mention the Framerate. Youll have to set the Framerate of the movie at the last step in Yamb (under properties). In most Cases 23.976 (i think). If you dont know it, you could use Gspot to get the correct number. After that everthing should be synchron.

Sorry for my english.

Is there anyone else whos tested the Steps? Is it really working finally? I have to wait for my update

#58 Nature_1

Nature_1

    X-S Enthusiast

  • Members
  • 8 posts

Posted 06 December 2007 - 04:51 PM

Tried a couple of files, usually works fine. MeGui is a little hard to use at first with that confusing "input video path" error. Auto-encode didn't work for me, needed to use the enqueue function before converting the aac file manually.

I'd recommend GOTsent though. MKV conversion on the fly. Don't forget to download the right codecs!

#59 Goodgsheppard

Goodgsheppard

    X-S Enthusiast

  • Members
  • 12 posts

Posted 06 December 2007 - 04:56 PM

QUOTE(Nature_1 @ Dec 6 2007, 05:27 PM) View Post

Tried a couple of files, usually works fine. MeGui is a little hard to use at first with that confusing "input video path" error. Auto-encode didn't work for me, needed to use the enqueue function before converting the aac file manually.

I'd recommend GOTsent though. MKV conversion on the fly. Don't forget to download the right codecs!

where can i see which are needed? Having couple Problems with gotsend. It crashes a lot.

#60 Nature_1

Nature_1

    X-S Enthusiast

  • Members
  • 8 posts

Posted 06 December 2007 - 05:08 PM

QUOTE(Goodgsheppard @ Dec 6 2007, 05:32 PM) View Post

where can i see which are needed? Having couple Problems with gotsend. It crashes a lot.


Gotsent needs AC3Filter and Haali Media Splitter as told on http://sentry23.googlepages.com/.

You could download the Combined Community Codec Pack which has all the latest codecs needed for proper playback and converting. This also includes AC3filter and Haali Media Splitter.

Edit: My bad, AC3Filter is NOT included. You could also try downloading the neroaacenc (http://www.nero.com/eng/nero-aac-codec.html) and putting it in the Gotsent dir.

Edited by Nature_1, 06 December 2007 - 05:21 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users