Jump to content


Photo

Applications Source


  • Please log in to reply
17 replies to this topic

#1 modifiedbears

modifiedbears

    X-S Young Member

  • Members
  • Pip
  • 42 posts

Posted 09 September 2007 - 07:12 AM

The applications option in the games blade doesn't remember the last source I was viewing, but Xbox Arcade and Games do. I've even tried using the "Make Default" option, but it still does not work.

#2 HardwareTaco

HardwareTaco

    X-S Young Member

  • Members
  • Pip
  • 44 posts
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 01 February 2008 - 01:44 AM

I'm having the same issue, looked in the xml and couldn't find anything to do to it.

#3 Jezz_X

Jezz_X

    X-S Knowledgebase

  • Moderator
  • PipPipPipPipPipPipPipPip
  • 4,531 posts
  • Location:Australia
  • Xbox Version:v1.1
  • 360 version:none

Posted 01 February 2008 - 02:03 AM

you need to call (name) your programs sources Not the actual dirs on the hdd
Games
Emulators
Programs

#4 1hotjob

1hotjob

    X-S Knowledgebase

  • Head Moderators
  • PipPipPipPipPipPipPipPip
  • 4,761 posts
  • Gender:Male
  • Xbox Version:unk
  • 360 version:unknown

Posted 09 February 2008 - 06:44 AM

QUOTE(Jezz_X @ Feb 1 2008, 02:39 AM) View Post

you need to call (name) your programs sources Not the actual dirs on the hdd
Games
Emulators
Programs

I'm sorry, I still don't quite understand what you mean. I have looked in the Custom1112_Gameshome and many of the other files in the PAL folder, but still don't get it.

When I add games to the Games menu they come up in the Programs menu too. I don't understand what I am doing wrong to cause this. My games are in the F:\Games folder and my programs are in the E:\Apps folder.

#5 Movax

Movax

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,520 posts
  • Xbox Version:v1.4
  • 360 version:none

Posted 09 February 2008 - 07:55 AM

Don't ask me why, but recent builds of XBMC don't seem to come with a proper sources.xml

CODE

<sources>
    <myprograms>
        <default>Games</default>
        <source>
            <name>Games</name>
            <path>E:\Games\</path>
            <path>F:\Games\</path>
            <path>G:\Games\</path>
        </source>
        <source>
            <name>Emulators</name>
            <path>E:\Emulators\</path>
            <path>F:\Emulators\</path>
            <path>G:\Emulators\</path>
        </source>
        <source>
            <name>Programs</name>
            <path>E:\Apps\</path>
            <path>F:\Apps\</path>
            <path>G:\Apps\</path>
        </source>
        <source>
            <name>DVD-Game</name>
            <path>D:\</path>
        </source>
    </myprograms>
    <video>
        <default>Videos</default>
        <source>
            <name>Videos</name>
            <path>C:\Junk\</path>
            <path>F:\Videos\</path>
            <path>G:\Videos\</path>
        </source>
        <source>
            <name>DVD-ROM Drive</name>
            <path>D:\</path>
        </source>
        <source>
            <name>Playlists</name>
            <path>special://videoplaylists/</path>
        </source>
        <source>
            <name>XBMSP Network Share</name>
            <path>xbms://192.168.1.109:1400/</path>
        </source>
        <source>
            <name>XBMSP Network Servers (Auto-Discover)</name>
            <path>xbms://</path>
        </source>
        <source>
            <name>SMB Network Share</name>
            <path>smb://DOMAIN;username:pwd@MyWindowsServer/movies/</path>
        </source>
        <source>
            <name>TuxBox Client</name>
            <path>tuxbox://root:dreambox@192.168.0.110:80/</path>
        </source>
        <source>
            <name>WORKGROUP (SMB) Network</name>
            <path>smb://</path>
        </source>
        <source>
            <name>ReplayTV</name>
            <path>rtv://*/</path>
        </source>
        <source>
            <name>UPnP Media Servers (Auto-Discover)</name>
            <path>upnp://</path>
        </source>
    </video>
    <music>
        <default>Music</default>
        <source>
            <name>Music</name>
            <path>C:\Junk\Music\</path>
            <path>E:\Music\</path>
            <path>F:\Music\</path>
            <path>G:\Music\</path>
        </source>
        <source>
            <name>DVD-ROM Drive</name>
            <path>D:\</path>
        </source>
        <source>
            <name>Playlists</name>
            <path>special://musicplaylists/</path>
        </source>
        <source>
            <name>XBMSP Network Share</name>
            <path>xbms://192.168.0.1:1400/</path>
        </source>
        <source>
            <name>XBMSP Network Servers (Auto-Discover)</name>
            <path>xbms://</path>
        </source>
        <source>
            <name>SMB Network Share</name>
            <path>smb://DOMAIN;username:pwd@MyWindowsServer/music/</path>
        </source>
        <source>
            <name>WORKGROUP (SMB) Network</name>
            <path>smb://</path>
        </source>
        <source>
            <name>iTunes Network Share (DAAP)</name>
            <path>daap://192.168.1.100/</path>
        </source>
        <source>
            <name>UPnP Media Servers (Auto-Discover)</name>
            <path>upnp://</path>
        </source>
        <source>
            <name>shoutcast</name>
            <path>shout://www.shoutcast.com/sbin/newxml.phtml/</path>
        </source>
    </music>
    <pictures>
        <default>Pictures</default>
        <source>
            <name>Pictures</name>
            <path>C:\Pictures\</path>
            <path>E:\Pictures\</path>
            <path>F:\Pictures\</path>
            <path>G:\Pictures\</path>
        </source>
        <source>
            <name>DVD-ROM Drive</name>
            <path>D:\</path>
        </source>
        <source>
            <name>XBMSP Network Share</name>
            <path>xbms://192.168.0.1:1400/</path>
        </source>
        <source>
            <name>XBMSP Network Servers (Auto-Discover)</name>
            <path>xbms://</path>
        </source>
        <source>
            <name>SMB Network Share</name>
            <path>smb://DOMAIN;username:pwd@MyWindowsServer/pictures/</path>
        </source>
        <source>
            <name>WORKGROUP (SMB) Network</name>
            <path>smb://</path>
        </source>
        <source>
            <name>UPnP Media Servers (Auto-Discover)</name>
            <path>upnp://</path>
        </source>
    </pictures>
    <files>
        <default></default>
        <source>
            <name>C Drive</name>
            <path>C:\</path>
        </source>
        <source>
            <name>E Drive</name>
            <path>E:\</path>
        </source>
        <source>
            <name>F Drive</name>
            <path>F:\</path>
        </source>
        <source>
            <name>Q Drive</name>
            <path>Q:\</path>
        </source>
        <source>
            <name>DVD-ROM Drive</name>
            <path>D:\</path>
        </source>
        <source>
            <name>XBMSP Network Share</name>
            <path>xbms://192.168.0.1:1400/</path>
        </source>
        <source>
            <name>XBMSP Network Servers (Auto-Discover)</name>
            <path>xbms://</path>
        </source>
        <source>
            <name>SMB Network Share</name>
            <path>smb://DOMAIN;username:pwd@MyWindowsServer/files/</path>
        </source>
        <source>
            <name>FTP Network Share</name>
            <path>ftp://username:password@ip:port/folder/</path>
        </source>
        <source>
            <name>WORKGROUP (SMB) Network</name>
            <path>smb://</path>
        </source>
    </files>
<Videos>


Copy and paste that to sources.xml and save in XBMC/Userdata

#6 1hotjob

1hotjob

    X-S Knowledgebase

  • Head Moderators
  • PipPipPipPipPipPipPipPip
  • 4,761 posts
  • Gender:Male
  • Xbox Version:unk
  • 360 version:unknown

Posted 09 February 2008 - 08:16 PM

Thank you very much.

#7 Movax

Movax

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,520 posts
  • Xbox Version:v1.4
  • 360 version:none

Posted 10 February 2008 - 12:40 AM

Oh.. I think that very last line should be </sources> not <Videos>

Not sure how that got there, though it may still work..

Edited by Movax, 10 February 2008 - 12:41 AM.


#8 1hotjob

1hotjob

    X-S Knowledgebase

  • Head Moderators
  • PipPipPipPipPipPipPipPip
  • 4,761 posts
  • Gender:Male
  • Xbox Version:unk
  • 360 version:unknown

Posted 10 February 2008 - 04:28 AM

Tried it, but it still isn't working. The apps don't show up. They are listed in the E:\Apps folder and should be there.

When I add a source it shows up in both places still.

I will keep working on it now that I know what file to edit.

#9 Jezz_X

Jezz_X

    X-S Knowledgebase

  • Moderator
  • PipPipPipPipPipPipPipPip
  • 4,531 posts
  • Location:Australia
  • Xbox Version:v1.1
  • 360 version:none

Posted 10 February 2008 - 05:05 AM

this bit here is what you need Notice the bold bit
QUOTE
<source>
<name>Games</name>
<path>E:\Games\</path>
<path>F:\Games\</path>
<path>G:\Games\</path>
</source>
<source>
<name>Emulators</name>
<path>E:\Emulators\</path>
<path>F:\Emulators\</path>
<path>G:\Emulators\</path>
</source>
<source>
<name>Programs</name>
<path>E:\Apps\</path>
<path>F:\Apps\</path>
<path>G:\Apps\</path>
</source>


mc360 looks for those names when it tries to open the myprograms window and goes directly to them if they exist other wise it will go to the root of myprograms which will show all your shares the actual paths don't matter its the <name> bit

#10 1hotjob

1hotjob

    X-S Knowledgebase

  • Head Moderators
  • PipPipPipPipPipPipPipPip
  • 4,761 posts
  • Gender:Male
  • Xbox Version:unk
  • 360 version:unknown

Posted 17 February 2008 - 08:19 PM

I went to the \PAL\Myprograms file and looked. There is only a line:

<description>GAMES label</description>

There isn't a line like that for Emulators or for Programs. Do I need to replace the MyPrograms.xml file?

I apologize for being so slow on this. I usually pick stuff up fairly quickly, but this is stumping me.

I have added the souces.xml file you provided.

#11 Movax

Movax

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,520 posts
  • Xbox Version:v1.4
  • 360 version:none

Posted 19 February 2008 - 08:20 PM

Not sure why it wouldn't work now. I added sources.xml as listed to e:\apps\XBMC\Userdata and everything worked as expected. Try upgrading the skin as well if you aren't already using the latest version.

#12 1hotjob

1hotjob

    X-S Knowledgebase

  • Head Moderators
  • PipPipPipPipPipPipPipPip
  • 4,761 posts
  • Gender:Male
  • Xbox Version:unk
  • 360 version:unknown

Posted 20 February 2008 - 11:15 PM

I got the skin a week or two ago. I will FTP it over and make sure it is there.

I have the latest release of XBMC also.

Thanks.

Still doesn't work. When I add anything to the Games section, it shows up in Xbox Arcade and Applications.

At the top of all sections it has Games. I reinstalled everything, booted so that a sources.xml file was created by XBMC. Rebooted the Xbox with CASH so it wouldn't be in XBMC and transfered the new sources.xml over.

It is frustrating, as I know it should be working. It is probably some noob mistake I am making, but it shouldn't be that difficult.

Edited by 1hotjob, 20 February 2008 - 11:51 PM.


#13 Jezz_X

Jezz_X

    X-S Knowledgebase

  • Moderator
  • PipPipPipPipPipPipPipPip
  • 4,531 posts
  • Location:Australia
  • Xbox Version:v1.1
  • 360 version:none

Posted 21 February 2008 - 01:00 AM

1hotjob post your sources.xml to pastebin.com and link it here or in a PM to me if you have super secret passwords in it

#14 1hotjob

1hotjob

    X-S Knowledgebase

  • Head Moderators
  • PipPipPipPipPipPipPipPip
  • 4,761 posts
  • Gender:Male
  • Xbox Version:unk
  • 360 version:unknown

Posted 21 February 2008 - 06:25 PM

QUOTE
<sources>
<programs>
<default></default>
<source>
<name>dvd2xbox</name>
<path>E:\Apps\dvd2xbox\</path>
</source>
<source>
<name>Action</name>
<path>F:\Action\</path>
</source>
<source>
<name>Driving</name>
<path>F:\Driving\</path>
</source>
<source>
<name>FPS</name>
<path>F:\FPS\</path>
</source>
<source>
<name>Kids</name>
<path>F:\Kids\</path>
</source>
<source>
<name>Sports</name>
<path>F:\Sports\</path>
</source>
<source>
<name>Other Games</name>
<path>F:\Others\</path>
</source>
</programs>
<video>
<default></default>
<source>
<name>How It&apos;s Made</name>
<path>F:\Movies\How It&apos;s Made\</path>
</source>
<source>
<name>The Universe</name>
<path>F:\Movies\The Universe\</path>
</source>
</video>
<music>
<default></default>
</music>
<pictures>
<default></default>
</pictures>
<files>
<default></default>
</files>
</sources>


What is strange about this is I saved the sources.xml posted above. I booted into the Xbox with CASH so that XBMC wouldn't be running. I replaced the 1k file with the new 6k file. Added my shortcuts and now am back to the 1k file with the new shortcuts added.

I don't know why I can't get the new souces.xml file to save on the Xbox.

OK. I reverted back to Evox. FTP'd the new sources.xml file. Rebooted the Xbox to make sure the new 6k file was still there. Reverted to XBMC as the dash. The 6k sources file was still there. I went to the Games blade and looked under Games and Applications. Nothing was there. I went to Applications and added a source, E:\Apps. This is what happened to the 6k sources.xml file.

QUOTE
<sources>
<programs>
<default></default>
<source>
<name>Apps</name>
<path>E:\Apps\</path>
</source>
</programs>
<video>
<default></default>
</video>
<music>
<default></default>
</music>
<pictures>
<default></default>
</pictures>
<files>
<default></default>
</files>
</sources>


For some reason it isn't allowing the new sources.xml file to be used. I copy and pasted it into wordpad which should be able to save it as a valid xml file. If you don't have any other suggestions I will paste the text into a different program and try saving it as an xml file to see if that makes a difference.

Edited by 1hotjob, 21 February 2008 - 06:50 PM.


#15 1hotjob

1hotjob

    X-S Knowledgebase

  • Head Moderators
  • PipPipPipPipPipPipPipPip
  • 4,761 posts
  • Gender:Male
  • Xbox Version:unk
  • 360 version:unknown

Posted 21 February 2008 - 07:59 PM

OK, I found a problem with Movax's sources.xml text he posted. If you look at the last line it is:

<Video>
it should be
</sources>

I loaded the text into a real xml editor and it found that. Now I have Games in Games and Apps in Applications, but I have lost the "add shortcut" button to add anything else. Using the white button doesn't bring it up either.

I am half way there. When I go into games, it has Emulators and Programs listed with the games. I have all the games listed into their separate categories. I find it makes loading the game you are looking for a lot easier.

When I select music, it goes to a folder (unknown) and I select the up arrow to go to the main screen. When I select Applications, it takes me to the E:\Apps folder and when I select the up arrow it takes me to the root of the games menu, (not the games blade).

Here is my new sources.xml file. Maybe someone can find a couple of errors to help me fine tune it.

QUOTE
<sources>
<myprograms>
<default>Games</default>
<source>
<name>Action</name>
<path>F:\Action\</path>
</source>
<source>
<name>Driving</name>
<path>F:\Driving\</path>
</source>
<source>
<name>FPS</name>
<path>F:\FPS\</path>
</source>
<source>
<name>Kids</name>
<path>F:\Kids\</path>
</source>
<source>
<name>Sports</name>
<path>F:\Sports\</path>
</source>
<source>
<name>Other Games</name>
<path>F:\Others\</path>
</source>
<source>
<name>Emulators</name>
<path>E:\Emulators\</path>
<path>F:\Emulators\</path>
<path>G:\Emulators\</path>
</source>
<source>
<name>Programs</name>
<path>E:\Apps\</path>
<path>F:\Apps\</path>
<path>G:\Apps\</path>
</source>
<source>
<name>DVD-Game</name>
<path>D:\</path>
</source>
</myprograms>
<video>
<default>Videos</default>
<source>
<name>Videos</name>
<path>F:\Movies\</path>
<path>F:\Videos\</path>
<path>G:\Videos\</path>
</source>
<source>
<name>DVD-ROM Drive</name>
<path>D:\</path>
</source>
<source>
<name>Playlists</name>
<path>special://videoplaylists/</path>
</source>
<source>
<name>XBMSP Network Share</name>
<path>xbms://192.168.1.109:1400/</path>
</source>
<source>
<name>XBMSP Network Servers (Auto-Discover)</name>
<path>xbms://</path>
</source>
<source>
<name>SMB Network Share</name>
<path>smb://DOMAIN;username:pwd@MyWindowsServer/movies/</path>
</source>
<source>
<name>TuxBox Client</name>
<path>tuxbox://root:dreambox@192.168.0.110:80/</path>
</source>
<source>
<name>WORKGROUP (SMB) Network</name>
<path>smb://</path>
</source>
<source>
<name>ReplayTV</name>
<path>rtv://*/</path>
</source>
<source>
<name>UPnP Media Servers (Auto-Discover)</name>
<path>upnp://</path>
</source>
</video>
<music>
<default>Music</default>
<source>
<name>Music</name>
<path>C:\Junk\Music\</path>
<path>E:\Music\</path>
<path>F:\Music\</path>
<path>G:\Music\</path>
</source>
<source>
<name>DVD-ROM Drive</name>
<path>D:\</path>
</source>
<source>
<name>Playlists</name>
<path>special://musicplaylists/</path>
</source>
<source>
<name>XBMSP Network Share</name>
<path>xbms://192.168.0.1:1400/</path>
</source>
<source>
<name>XBMSP Network Servers (Auto-Discover)</name>
<path>xbms://</path>
</source>
<source>
<name>SMB Network Share</name>
<path>smb://DOMAIN;username:pwd@MyWindowsServer/music/</path>
</source>
<source>
<name>WORKGROUP (SMB) Network</name>
<path>smb://</path>
</source>
<source>
<name>iTunes Network Share (DAAP)</name>
<path>daap://192.168.1.100/</path>
</source>
<source>
<name>UPnP Media Servers (Auto-Discover)</name>
<path>upnp://</path>
</source>
<source>
<name>shoutcast</name>
<path>shout://www.shoutcast.com/sbin/newxml.phtml/</path>
</source>
</music>
<pictures>
<default>Pictures</default>
<source>
<name>Pictures</name>
<path>C:\Pictures\</path>
<path>E:\Pictures\</path>
<path>F:\Pictures\</path>
<path>G:\Pictures\</path>
</source>
<source>
<name>DVD-ROM Drive</name>
<path>D:\</path>
</source>
<source>
<name>XBMSP Network Share</name>
<path>xbms://192.168.0.1:1400/</path>
</source>
<source>
<name>XBMSP Network Servers (Auto-Discover)</name>
<path>xbms://</path>
</source>
<source>
<name>SMB Network Share</name>
<path>smb://DOMAIN;username:pwd@MyWindowsServer/pictures/</path>
</source>
<source>
<name>WORKGROUP (SMB) Network</name>
<path>smb://</path>
</source>
<source>
<name>UPnP Media Servers (Auto-Discover)</name>
<path>upnp://</path>
</source>
</pictures>
<files>
<default></default>
<source>
<name>C Drive</name>
<path>C:\</path>
</source>
<source>
<name>E Drive</name>
<path>E:\</path>
</source>
<source>
<name>F Drive</name>
<path>F:\</path>
</source>
<source>
<name>Q Drive</name>
<path>Q:\</path>
</source>
<source>
<name>DVD-ROM Drive</name>
<path>D:\</path>
</source>
<source>
<name>XBMSP Network Share</name>
<path>xbms://192.168.0.1:1400/</path>
</source>
<source>
<name>XBMSP Network Servers (Auto-Discover)</name>
<path>xbms://</path>
</source>
<source>
<name>SMB Network Share</name>
<path>smb://DOMAIN;username:pwd@MyWindowsServer/files/</path>
</source>
<source>
<name>FTP Network Share</name>
<path>ftp://username:password@ip:port/folder/</path>
</source>
<source>
<name>WORKGROUP (SMB) Network</name>
<path>smb://</path>
</source>
</files>
</sources>





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users