Jump to content


Photo

Sources For Pictures, Music And Videos


  • Please log in to reply
4 replies to this topic

#1 Keypel

Keypel

    X-S Member

  • Members
  • Pip
  • 63 posts

Posted 01 October 2007 - 02:37 PM

I use the MC360 skin with XBMC pre 2.1 compiled 9/13/07

This is hard for me to explain but as an example,

On the Game Blade you have

Games
Xbox Arcade
Applications

and each one of those menu items are linked to a specially named folder

Games is linked to Games
Xbox Arcade is linked to Emulators
Applications is linked to Programs

When Games is pressed it takes you "inside" the Games folder
When Xbox Arcade is pressed it takes you "inside" the Emulators folder
When Applications is pressed it takes you "inside" the Programs folder

If you add a source named "Emulator" it won't link you "inside" that folder, It will only take you to the root of Games and then you have to manually enter the emulator folder but if the source is properly named "Emulators", pressing the xbox arcade takes you directly into the Emulators folder.

Ok, Now for my question

On the Media Blade,

What do I have to do to make the Music, Pictures, and Videos behave in the same manor.

I asked over at xbmc fourms but they said this was a MC360 team black bolt question.


#2 FourTwentySmiles

FourTwentySmiles

    X-S Expert

  • Members
  • PipPipPip
  • 616 posts
  • Location:In N. Carolina
  • Xbox Version:v1.6
  • 360 version:none

Posted 11 October 2007 - 04:54 AM

Create a shortcut. You could try editing the sources.xml to make sure it's looking in the specified directory. Like <default>F:videos<default>. At least I think thats right. Sources.xml is in XBMC/user data/sources.xml

#3 Keypel

Keypel

    X-S Member

  • Members
  • Pip
  • 63 posts

Posted 11 October 2007 - 04:03 PM

Thanks for the reply, I really appreciate it.

I was looking for the sources.xml a couple weeks ago and I was thinking at the time that the new ver of XBMC didn't use a sources.xml because I could never find one to edit.

IPB Image

However after reading your post, I thought, maybe there isn't a sources.xml until after xbmc generates one. and sure enough, that's what was going on.

So, I finally found the sources.xml ...

CODE
<sources>
    <myprograms>
        <default></default>
        <source>
            <name>Games</name>
            <path>G:\Guest\Games\</path>
            <path>G:\Administrator\Games\</path>
        </source>
        <source>
            <name>Emulators</name>
            <path>G:\Guest\Emulators\</path>
            <path>G:\Administrator\Emulators\</path>
        </source>
    </myprograms>
    <video>
        <default></default>
        <source>
            <name>Videos</name>
            <path>G:\Guest\Videos\</path>
            <path>G:\Administrator\Videos\</path>
        </source>
    </video>
    <music>
        <default></default>
        <source>
            <name>Music</name>
            <path>G:\Guest\Music\</path>
            <path>G:\Administrator\Music\</path>
        </source>
    </music>
    <pictures>
        <default></default>
        <source>
            <name>Pictures</name>
            <path>G:\Guest\Pictures\</path>
            <path>G:\Administrator\Pictures\</path>
        </source>
    </pictures>
    <files>
        <default></default>
    </files>
</sources>


However, I can now see, I already had my media sources properly named. So, I guess what I'm asking is not possible with the media blade. I wish the media blade behaved as the game blade does <sigh>

Well, thanks for the reply again, it was the only one I got. sad.gif



#4 remedee

remedee

    X-S Senior Member

  • Members
  • PipPip
  • 265 posts

Posted 11 October 2007 - 11:59 PM

If you have a source already set up for your videos, just go into Videos from the main menu. Then bring up the context menu (white button) on the folder you want it to automatically go into and select "Make Default". Restart XBMC and go into Videos.

Remedee

#5 Keypel

Keypel

    X-S Member

  • Members
  • Pip
  • 63 posts

Posted 14 October 2007 - 01:16 AM

Thank You Remedee!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users