Jump to content


Photo

Samsung Ts-h943a


  • Please log in to reply
2 replies to this topic

#1 wagonburner

wagonburner

    X-S Enthusiast

  • Members
  • 7 posts

Posted 23 October 2007 - 05:22 AM

I have had my xbox for 2 yrs no problems until Halo3. I really am asking for opinions on what would be the easiest fix for my problem. Keep in mind its unmodded. The drive is starting to get disk read errors 3 times sometimes to load, and it makes a buzzing grinding noise reading disks, I havent had any scratched either.

Its a Samsung TS-H943A drive not sure which version as I havent taken it apart.

1st option
Should I buy a new H943A and Rip my keys from original and install to new drive? I have been reading the readmes and it seems easy enough.

2nd option
can I just pull the laser out of another and install in mine (will there be any pcbs that need to come out as well)? Are there any other drives that work I read a post on the forums here that said a Samsung SD-816 drive had the same optics as the XBOX 360 Samsung drive (He didnt specify what version though).

The SD-816 drive is like 38clams and H943A is 50?

Thanks for reading my posts and all opinions appreciated.

#2 Hoyt

Hoyt

    X-S Member

  • Members
  • Pip
  • 111 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 24 October 2007 - 02:29 AM

I fixed a drive like this a couple of days ago by just replacing the laser lens. If you have been playing it for two years straight it wouldn't surprise me that the laser is getting weak.

I see no reason why you would need to replace the drive or mess with the firmware. You just unscrew the rods that the laser rides on, unplug the cable, and remove the worm gear assembly. Put the worm gear assembly on the new laser lens, put the rods back through it and screw them back in. Re-insert the cable and possibly re-grease the rods (I use Lubriplate; it is commonly used on dot matrix printers).

#3 wagonburner

wagonburner

    X-S Enthusiast

  • Members
  • 7 posts

Posted 27 October 2007 - 04:31 PM

I just bought a new samsung off ebay, I removed the new board and installed my board into the new drive and am back and running. Thanks for your advice though.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users