Jump to content


Photo

New Versions Of All Emulators And Source Release


  • Please log in to reply
117 replies to this topic

#76 molto

molto

    X-S Enthusiast

  • Members
  • 10 posts
  • Interests:peace
  • Xbox Version:v1.1
  • 360 version:none

Posted 17 November 2007 - 10:26 AM

QUOTE(Wormboy @ Nov 16 2007, 04:02 PM) View Post

Yapp. There's a black screen when selecting a software filter...



Yes i agree Snes9xbox its a very good emulator i have tried many game and cool...NICE XPORT biggrin.gif ....but just a black screen when you selecting a software filter^^

#77 kimota2004

kimota2004

    X-S X-perience

  • Members
  • PipPip
  • 368 posts
  • Location:UK
  • Xbox Version:v1.6
  • 360 version:none

Posted 18 November 2007 - 12:17 AM

XPort it's sad to see you wind down like this but wow what a ride it's been! We here at the scene owe you so much for the work you've done, don't forget that you alone have turned a pretty good console into the greatest console to ever grace the face of this planet. I wish you all the best in whatever you do in this life, you've brought a lot of happiness to hell a lot of people. I am so grateful mate.

XPort I salute you! beerchug.gif beerchug.gif

Take care

kimota

Edited by kimota2004, 18 November 2007 - 12:18 AM.


#78 turner3d

turner3d

    X-S Young Member

  • Members
  • Pip
  • 37 posts
  • Xbox Version:v1.0
  • 360 version:unknown

Posted 19 November 2007 - 12:45 PM

I couldn't agree more with all of the praise posts in here - awesome contribution you've made to the community, and now an even bigger one by releasing all the sources.

BTW, I had a little trouble getting the DosXBox source to compile - seemed to be complaining about a single missing file, sdlnetx.lib. Anyway, there's more on the problem and my hacked up solution in the dosxbox thread - it'd be cool if somebody could tell me if i'm just missing something. smile.gif

#79 deathx88

deathx88

    X-S Hacker

  • Dev/Contributor
  • PipPipPipPipPipPip
  • 2,338 posts
  • Location:Florida
  • Interests:xbox stuff, guitar stuff, pc stuff, and hacking stuff
  • Xbox Version:v1.6
  • 360 version:none

Posted 20 November 2007 - 06:01 PM

there seems to be a couple of things that don't work with a couple of these emulators

in xboyadvance when toggling the rewind on the entire the game seems like its in slow motion

anyone else have this problem because it would be cool to have rewind in this emulator


and in fceultra the rewind altogether doesn't work
i know i should use the other nes emulator but this one plays kung fu and paper boy 2 and also has a smoother throttle.


whether these are going to get fixed who knows, but i just thought i should throw it out there

#80 Antiriad

Antiriad

    X-S Senior Member

  • Members
  • PipPip
  • 175 posts

Posted 20 November 2007 - 11:15 PM

"Kol ha kavod" as they say in Hebrew. In other words: respect. cool.gif

Thank you XPort for all your acts of love in working on these emulators - you will probably never know how many people's lives you have brought some happiness into. smile.gif

#81 rubbercarp

rubbercarp

    X-S Member

  • Members
  • Pip
  • 95 posts

Posted 21 November 2007 - 12:45 AM

Can't thank you enough Xport.

Everyone else has already said it better that I ever could!
Cheers!

#82 althena

althena

    X-S Senior Member

  • Validating
  • PipPip
  • 264 posts
  • Location:Germany
  • Interests:Videogames (from the good old 8Bit-Times up to now), Mangas, Animes, Cinema, meeting friends, sports
  • Xbox Version:v1.1
  • 360 version:v4.0 (jasper)

Posted 21 November 2007 - 06:27 AM

It seems that PAL games are not running properly with Snes9xBox, also if you change the settings for a game to "Force PAL" they run too fast. Otherwise after testing a playing a few dozens of games with this one I think it is a pretty good emulator and if one game shouldn't be playable with this one you can just choose another emulator like you can play with Snes9xBox games that they on the other hand can't wink.gif
Just these few basic functions (PAL compatibility, BGM of the GUI stopping when starting a game, software filters) would be great to see fixed someday in the future smile.gif

#83 hobojoe44

hobojoe44

    X-S Enthusiast

  • Members
  • 9 posts

Posted 23 November 2007 - 11:33 AM

I have a audio problem with Mednafenx after playing any game for 3-5 minutes the in game audio lowers by it self then mutes. but the emulator menu still plays music and sounds. the only way to fix it is to restart the emulator, but it will just happen again.


#84 deathx88

deathx88

    X-S Hacker

  • Dev/Contributor
  • PipPipPipPipPipPip
  • 2,338 posts
  • Location:Florida
  • Interests:xbox stuff, guitar stuff, pc stuff, and hacking stuff
  • Xbox Version:v1.6
  • 360 version:none

Posted 24 November 2007 - 09:32 PM

anyone else have problems with neogenesis
it seems if you have the rewind on, certain games crash the xbox like sonic
and also i had save state problems, sometimes when i enter a game a load a save state it will load the game spot with music but it won't play. if i exit the game and reload it it will work again

#85 kimota2004

kimota2004

    X-S X-perience

  • Members
  • PipPip
  • 368 posts
  • Location:UK
  • Xbox Version:v1.6
  • 360 version:none

Posted 25 November 2007 - 04:07 PM

Yeah I noticed the same problems with neogenesis and the rewind feature, I just turned it off in the end as it's not something I'd use anyway (just how cheap do u wanna get? tongue.gif ), noticed the slow motion works ok though.

#86 Moonkeeper

Moonkeeper

    X-S Young Member

  • Members
  • Pip
  • 55 posts

Posted 27 November 2007 - 07:17 AM

Quick question.

You know how with NES games, they have a tendency to slow down when there is a lot of action happening at once?

Is there a way to fix this in mednafenx?

The game keeps slowing down horribly in my fight with Mother Brain!

On a side note, Xport, you're the man!

#87 madmab

madmab

    X-S Hacker

  • Dev/Contributor
  • PipPipPipPipPipPip
  • 2,394 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 28 November 2007 - 03:53 AM

Sounds like rewind causes some issues with some of these emulators.


#88 madmab

madmab

    X-S Hacker

  • Dev/Contributor
  • PipPipPipPipPipPip
  • 2,394 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 28 November 2007 - 07:41 AM

ok well I snooped around the atari800xl code and it looks like for the "old" pokey emulation clipping is turned off. My guess is it would need to be turned on. Looking at the GP32 port they have clipping turned on. Chances are that's what causing sound issues with the "old" emulation.

As for "new" emulation it does not have a "clipping" option so either it is doing it automatically or it doesn't need it for some reason. I'm not sure why the sound frequency is double on it though.

My head hurts. laugh.gif


#89 Dai_UK

Dai_UK

    X-S Senior Member

  • Members
  • PipPip
  • 189 posts

Posted 30 November 2007 - 01:23 AM

Xport - thanks for all your work - My xbox is so much more than MS ever intended thanks to your hard work!

#90 jheydude1

jheydude1

    X-S Enthusiast

  • Members
  • 4 posts

Posted 01 December 2007 - 10:11 AM

I would also like to give a big thank you for the incredible amount of time you've taken from your personal life to give the xbox scene something that we would of other wise never of had! smile.gif I would be honored to help continue your projects! I just require a small push in the right direction. What do I need to learn in order to understand source code, improve/upgrade emulators, different program tools I would need, etc. I'm a super quick learner when it comes to this kind of thing. I just don't know where to go to or what I need in order to be able to understand everything I would need to know. Your advice on this would be the best I could of ever hoped for! smile.gif I have been wanting to learn about this subject for some time now. With the release of your source codes, what better way to sharpen and improve my skills! happy.gif Everyday the xbox scene is getting closer and closer to its end. Its up to us as a community to help maintain, and continue, these homebrew programs that we have all come to love and enjoy! Great work xport! I wish you the best!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users