Jump to content


Photo

Help Recovering From Botched Ndure Install. Ran Out Of Space.


  • Please log in to reply
4 replies to this topic

#1 ColKurtz

ColKurtz

    X-S Expert

  • Members
  • PipPipPip
  • 676 posts

Posted 30 December 2007 - 06:24 AM

So I just got done attempting the ndure/xboxhdm install. It did not go well. I have been awarded with an error 13. I have a guess as to what went wrong but would appreciate the input of more experienced here (i'm familiar with mochips but not softmods), and any advice on how I might fix it. I have 2 other stock xbox HDDs and a modchip, if that opens up different options.

The gist of the problem is that ndure ran out of space during the install, leading to several cascading errors. the first thing I did when I booted xboxHDM was do a backup, and it appears those files are still there. However, I executed the restore fucntion (anfter the below events) and still get error 13. Here are hte details:

I did the hotswap... Reading daddyj's advice on how to ensure the drive is unlocked before swapping, I saw these instructions, and --sort of -- followed them**

QUOTE
- put an audio cd in the xbox
- copy one track to the hd
- play the track from the HD, let play for a few seconds
- pause the song
- you HDD is now ready for hotswap!


**It turns out there were 2 (crappy) albums already ripped on the HDD (it's v1.0 refurb purchased recently, apparently they were left over for the previous owner). I played and paused these existing songs beforee hotswapping, rather than copying one over from CD. I assumed it was the same thing. Anway, it took and I got access to the drive. I chose option 1 to install ndure and got the following errors:
QUOTE


(parts 1 and 2 proceeded without error)

cp: /CD/ndure/E/NP11/*: No such file or directory
write error: no space left on device
copying c drive backup
to shadowc

mkdir: cannot create directory 'xbox/c/shadowc/resc": no space left on device
cp 'unable to open 'xbox/C/shadowc/resc/default.xbe: No such file or directory
cp unable to open 'xbox/C/shadowc/resc/evox.ini'. No such file or directory"

Part 3 of 3

Done.. now exiting


I reboot to error 13. So I'm thinking these 2 crappy albums on my HDD (and maybe savegames and other stuff?) took up too much space is what hosed the install?

I guess my questions are:
1) General advice. Is there an easy way to recover or start over? I went back into xbrowser and have listed below the files as they exist now. Is there a manual way of getting the files back into bootable shape?
2) I have 2 other unmodified, stock xbox HDDs from other mods that I have done. Can I just plop one of those in and start over?

Sorry for the lenght of the post but I wanted to include as much info as possible. Thanks for any advice.




Here is my disk structure now as reported by xplorer

under /C/
/Audio
/fonts
/xbosdshdashdata185ea19
/xodash
*Xbox Book.xtf
*Xbox.xtf
*settings_adoc.xip
*xboxdash.xbe

under /E/Cache/
localcachce00.bin
localcache05.bin
localcach08.bin

E/NKP11 is empty

/E/Backup
/Audio
/fonts
/xboxdashdata.185.ead00
/xodash
*Xbox Boo.xtf
*settings_adoc.xip
*xboxdash.xbe

/E/Dash
*config.xml
*English.xml
*Defualt.xbe

/E/NDTS
*Config.xml
*English.xml
*bios.bin
*boot.cfg
*confige.xml
*default.xbe
*unleashx.xbe

/E/NDTS/files
/bios
/epbk
/ksf
*boot1.bin
*corec.rar
*fludd.rar
*setad.rar
*shadowc.rar
*xbox.rar
*xdata.rar

Edited by ColKurtz, 30 December 2007 - 06:29 AM.


#2 kingroach

kingroach

    X-S Hacker

  • Dev/Contributor
  • PipPipPipPipPipPip
  • 2,741 posts
  • Xbox Version:v1.4
  • 360 version:v5.0 (360S - trinity)

Posted 30 December 2007 - 07:16 AM

Something really messed up in the C drive. Old music wasnt the problem..Use the softmod installers option "2".. This should erase everything from C drive and install the softmod only.. If softmod was successful then you can copy rest of the files later.

#3 ColKurtz

ColKurtz

    X-S Expert

  • Members
  • PipPipPip
  • 676 posts

Posted 30 December 2007 - 05:54 PM

Thanks. When I choose option 2, my screen fills up with "MainAudio/Audio/MainAudio/Audio/MainAudio/Audio/...". I let it run for a while but it seemed stuck in a loop.

You're certainly correct about /C being messed up. I went into the /PriMas/C/ directory, which contained:

/Audio (16k, the other directories reporting 0k)
/Fonts
/xboxdashdata.185ead00
/xodash

Inside each of those directories were the same 4 directories -- it's in some recursive loop. So if I go to to /PriMas/C/Fonts/, or /PriMas/C/xodash, they all contain the above 4 directories. It's the same if you drill deeper. I went probably 50 subdirectories deep in ../audio/audio/audio/audio.." and it was the same.

I tried using xbrowser to delete the audio directory, but it didn't do anything (no errors, just didn't appear to do anything at all). I ran "rm -R audio" from the command line within xbrowser and my screen filled up again with the "MainAudio/Audio/MainAudio/Audio/MainAudio/Audio/..." I let it run for about 10 mins and it's still scrolling.

It sounds like my ndure install is fubar'd for now - unless someone feels otherwise. I guess my next question is about how to proceed. I guess I have 2 questions, actually:

1) Can I use one of my other 2 stock xbox HDDs and try ndure again, or is the xbox tied to a specific drive (ignoring any Live considerations -- it's for xbmc)?

2) Can I put the fubar'd drive in my chipped xbox and boot to an evox CD to extract the eeprom? If I can get my eeprom, I can rebuild on a larger drive with xboxhdm, right? That's my eventual goal here anyway. Where should I look for the eeprom.bin? I'm confused about the virtual eeprom so I want to make sure I get the right one (if I can at all).

Thanks again for any advice.

Edited by ColKurtz, 30 December 2007 - 06:00 PM.


#4 celltoolz

celltoolz

    X-S Member

  • Members
  • Pip
  • 68 posts

Posted 03 January 2008 - 08:49 AM

You should look in E:\Backup\ there should be a file called eeprom.bin if you backed everything up correctly. If not you dont have to worry because you have a modchip. It would be a lot eaiser if you got the eeprom though. Post back if you are successful in getting that file. Also im wondering if it still plays games if it does you can boot into the softmod menu and ftp to the console and save the eeprom.bin file.

#5 ColKurtz

ColKurtz

    X-S Expert

  • Members
  • PipPipPip
  • 676 posts

Posted 03 January 2008 - 07:34 PM

Thanks for the reply. I ended up trying to copy original dash files back over to C ended up with an error 21, which prevented me from further hot-swapping. I couldn't boot off of an original game at that point, either. Seems the filesystem was hosed since I couldn't add to or delete anything under C:\Audio.

I ended up putting my modchip in the failing box here, and softmodded the box the chip came out of -- no problems on the 2nd one. I've gotten the eeprom off of both of them now... I was under the impression that eeprom.bin was a unique file to the stock hard drive, and served as an encryption key to be paired with the onboard eeprom. I understand now that eeprom.bin is just a copy of the physical eeprom itself.

Thanks again.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users