Jump to content


Photo

Problem Starting X On Debian Etch


  • Please log in to reply
4 replies to this topic

#1 Morninglight

Morninglight

    X-S Member

  • Members
  • Pip
  • 106 posts
  • Location:The Netherlands
  • Xbox Version:v1.0
  • 360 version:v3.0 (falcon)

Posted 14 January 2008 - 10:51 AM

I installed Debian Etch on my 20GB yesterday evening, from what I followed everything went ok, I booted this morning with the sda2 bootdisc, but it refused to start X up.

Xenon:~# startx
xauth: creating new autority file /root/.serverauth.2433
xauth: (argv):1: bad display name "Xenon:0" in "list" command
xauth: (stdin):1: bad display name "Xenon:0" in "add" command

X cannot stat /etc/X11/X (No such file or directory), aborting
XX11TransocketINETConnect() can get address for localhost:6000: Name or service not known
giving up.

I added localhost to the resolv.conf but that didn't solve the problem, any idea's?

#2 Icekiller2k6

Icekiller2k6

    X-S Senior Member

  • Members
  • PipPip
  • 180 posts

Posted 14 January 2008 - 11:04 AM

QUOTE(Morninglight @ Jan 14 2008, 11:27 AM) View Post

I installed Debian Etch on my 20GB yesterday evening, from what I followed everything went ok, I booted this morning with the sda2 bootdisc, but it refused to start X up.

Xenon:~# startx
xauth: creating new autority file /root/.serverauth.2433
xauth: (argv):1: bad display name "Xenon:0" in "list" command
xauth: (stdin):1: bad display name "Xenon:0" in "add" command

X cannot stat /etc/X11/X (No such file or directory), aborting
XX11TransocketINETConnect() can get address for localhost:6000: Name or service not known
giving up.

I added localhost to the resolv.conf but that didn't solve the problem, any idea's?



may i ask how you installed it? which script etc? did it work yesterday?

#3 Morninglight

Morninglight

    X-S Member

  • Members
  • Pip
  • 106 posts
  • Location:The Netherlands
  • Xbox Version:v1.0
  • 360 version:v3.0 (falcon)

Posted 14 January 2008 - 11:15 AM

I used this how-to:

http://www.free60.org/wiki/Debian-etch

I didn't reboot after install yesterday because it was late, so I turned the xbox off when it asked me to reboot and booted for the first time this morning.

I think it has something to to with startx not finding the hostname, I can ping 127.0.0.1 and 192.168.0.18 (DHCP) but I cannot ping localhost or Xenon huh.gif



#4 Scan-C

Scan-C

    X-S Hacker

  • Members
  • PipPipPipPipPipPip
  • 2,569 posts
  • Location:Germany
  • Xbox Version:v1.4
  • 360 version:v3.0 (falcon)

Posted 14 January 2008 - 01:27 PM

Looks like X isn't installed properly. If you look at the messages you see that /etc/X11/X is missing and the X-Server can't work without it.
Try reinstalling the x-window-system package but do an "apt-get update" before reinstalling to ensure your package database is as new as possible

#5 Morninglight

Morninglight

    X-S Member

  • Members
  • Pip
  • 106 posts
  • Location:The Netherlands
  • Xbox Version:v1.0
  • 360 version:v3.0 (falcon)

Posted 14 January 2008 - 06:15 PM

reinstalling x-window made things even worse, I think more packages failed on installation. Did a complete reinstall and it booted right into X afterwards...

Pengiun to the 360 muhaha.gif




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users