Jump to content


Photo

1 TB SATA Hard Drive Upgrade


  • Please log in to reply
289 replies to this topic

#16 ozreplicator

ozreplicator

    X-S Enthusiast

  • Members
  • 3 posts

Posted 24 May 2008 - 11:30 AM

Hey all,
I installed a WD10EACS 1TB drive into a 1.0 xbox a little while ago, along with one of those Sabrent type IDE -SATA converters I found on ebay:
http://cgi.ebay.com....em=250229080622

My problem seems to be the same as others are reporting, it seems to work ok most of the time, but sometimes hangs when booting, or boots very slowly.
When it does boot, sometimes it works ok, other times, after booting to the slayers menu, if you try and load xbmc or a game, it starts to load then goes back to the slayers menu. Rebooting it usually makes it work.
Other times I was able to ftp around 500GB to it without any problems.
Does anyone whow what the jumpers on the converter board are for ? Mine came with the holes on the board, but no pins. I soldered in the 4 pins and tried a jumper in the 2 positions but doesn't seem to have helped. It must be some sort of timing issue ?
I bought 2 of these converters at the same, I'll try the other one with the 1TB drive in a 1.6 xbox and see what happens...

#17 ozreplicator

ozreplicator

    X-S Enthusiast

  • Members
  • 3 posts

Posted 24 May 2008 - 11:43 AM

I forgot to mention that just after switch on before slayers boots, the occasional MS error 7 or 13 pops up on screen. again, a reboot fixes it.

#18 Chronusdark

Chronusdark

    X-S Young Member

  • Members
  • Pip
  • 31 posts
  • Xbox Version:v1.4
  • 360 version:v1 (xenon)

Posted 25 May 2008 - 03:37 AM

taking all the lockups into account how is the data? im thinking about doing this but i dont want to worry about data loss very much. with 1 tb i hope to xfer all my media to the drive and dont want to worry about it. lockups i can handle

#19 FourTwentySmiles

FourTwentySmiles

    X-S Expert

  • Members
  • PipPipPip
  • 616 posts
  • Location:In N. Carolina
  • Xbox Version:v1.6
  • 360 version:none

Posted 25 May 2008 - 09:37 AM

Why not use a 1Tb drive as a SMB avalible drive instead of installing it to your xbox. this way no corruption cause its on your PC....and all the media is watched via XBMC. This would work for music, video, and pictures.....but not games (not sure about the games, but I know other media works great that way.)

OR

Is this thread just to see if the 1Tb can be successfully used INSIDE the xbox with no corruption.

#20 zx6r6

zx6r6

    X-S Young Member

  • Members
  • Pip
  • 44 posts

Posted 26 May 2008 - 07:31 PM

Hello.
I noticed the adapter is listed as ATA 100/133, I take it you guys are using an 80 wire IDE cable? I've had similar problems on some older pc's with using 100/133 drives with 40 wire (ata 66) cables. Maybe the adapter is picky......

Hope this helps and I'm not just pointing out the obvious smile.gif

Edited by zx6r6, 26 May 2008 - 07:32 PM.


#21 capboy210

capboy210

    X-S Genius

  • Members
  • PipPipPipPip
  • 827 posts
  • Location:Colorado
  • Interests:Xbox modification, computers, games, live, friends, girls, eating pasta.
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 26 May 2008 - 09:17 PM

Seagate makes IDE models of there 750GB hard drive... As far as the hardware goes in the xbox it works just fine, it never hangs etc... I also think Hitachi offers a IDE 1TB HDD. Although i have never seen one in a xbox.

But beware that the xbox is not fully compatable with a nearly full 750GB hdd. I have around 200 gigs free on my 750gb HDD but folders and files float around the F & G drive mysteriously. One day something will be on your F drive, and the next day it appeared on the G drive~!!

Its not exactly that dramatic but just beware, the partitioning acts goofy sometimes. But in all reality i have not lost any data yet on my xbox so you should be alright.

Just make sure that:

Your bios supports custom partitions
You split F & G evenly in space
Set the entire hard drive to 32k clusters!



#22 BigPotty

BigPotty

    X-S Young Member

  • Members
  • Pip
  • 34 posts

Posted 29 May 2008 - 03:09 AM

A bit of an update...

So I've been working on this for a few weeks when I get some time away from work and the social life.
This is what I've tried thus far (in no particular order):

- Variety of jumper settings on the Sabrent Adapter, including using 2 jumpers! (currently have the jumper completely removed)

- Fully disassembled and cleaned the MB and all components of my Xbox.

- Re-soldered the 2 main pins for the power connector on my PSU (I have a 1.0 and it needed to be done anyhow)

- Checked over all of my mod chip soldering work and cleaned it up a bit (I've gained some soldering skills in the last year or so!)

- Checked all cable connections

- Tried a variety of settings:

-Tried all of the Acoustic Management options for my HD (Samsung 750gig)
-Tried different power management settings in XBMC for the HD
-Set the HD's link speed to 1.5 rather than 3.0 using Samsung's Speed Switcher Utility

- Turned off the DVD check in the X3 bios

- Tried (re)booting in a variety of ways:
-CD/DVD in or out
-Cold Boot/Reboot
-Warm Boot/Reboot
-IR Remote Dongle in/out
-Wired/Wireless controllers in/out

-Others I'm probably forgetting

So, none of this stuff seems to make a bit of difference. Very frustrating! And today I noticed another peculiar problem. It seems that I can copy files from my SMB share with no problem, but when I tried to move a folder with files in it from my G to my F, I kept getting file copy errors! XBMC would stop the copy and give some error message about failing to copy. I tried quite a few times before giving up and just using the SMB file transfer instead.

And here's something else I noticed today. This Sabrent adapter seems to me to be the exact same adapter as this Rosewill one:
Rosewill Adapter

And, after reading all of the reviews for both the Sabrent and Rosewill models, it seems that people have had a variety of problems with both. From them not working at all, to the same slow boot / no boot problem, even on a pc.

So, since I've sorta hit a wall with all this, I broke down and have ordered another adapter. I had to search high and low for another model and supplier that seemed like it would do the job. I will report back with any success/failures after I've had a chance to fully test it.

capboy210: Is it necessary to set ALL partitions to 32k clusters? I've been under the impression that only the large partitions need it?

#23 Bomb Bloke

Bomb Bloke

    X-S Transcendental

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPip
  • 6,568 posts
  • Gender:Male
  • Location:Tasmania (AU)
  • Xbox Version:v1.0
  • 360 version:none

Posted 29 May 2008 - 03:50 AM

QUOTE(BigPotty @ May 29 2008, 02:45 PM) View Post
capboy210: Is it necessary to set ALL partitions to 32k clusters? I've been under the impression that only the large partitions need it?

Only partitions larger then 256gb need to use larger clusters. I'm not even sure if the console would function if you did the entire drive that way.

#24 BigPotty

BigPotty

    X-S Young Member

  • Members
  • Pip
  • 34 posts

Posted 03 June 2008 - 03:57 AM

Here we go again...

SO, a couple days ago my month old 750 gig SATA Samsung HD started the good ole "click of death". Of course, it's hard to say what exactly caused this. Heat? The SATA adapter? Samsung's new substandard HD's?

I read over the reviews for this particular model a little more closely than when I had impulsively bought the drive a month ago. It seems at least a few people have had the same problem or a DOA drive. I even read one review that said "I used to have great luck with Samsung" (paraphrasing). I've come to the same conclusion. I have Samsung drives that are a few years old running 24/7 and have never had a problem (SATA too). THANK GOD that Newegg is so freakin awesome. I was just past the 30 day mark, but I emailed them and they emailed me a prepaid UPS label and authorized the RMA!

Luckily, I hadn't reformated my old 300 gig Xbox HD, so I only lost a few things added over the last month.

Aside from all this, I intended to order a new SATA adapter from some no-name Yahoo shop, but they canceled the order and notified me they were out of stock. It "looked" like a higher quality adapter from the pictures. It has a JMicron JM20330 chipset and the store is kind enough to have a lot of info about the product:
http://cooldrives.st...hadradtoid.html

BUT, no stock, so I ordered a similar looking one from an Ebay Store:
http://cgi.ebay.com/...I...N:IT&ih=004

Paid $7.98 WITH shipping!! Which is great, but I looked over it real close and noticed some horrible soldering work. And as usual, it's made in freakin China. Also, it has a 2X2 set of jumper pins, but no jumper included or any indication of how they would work. And the packaging RAPES the english language. Which is as funny as always, but I'm sure my heart will stop for a second the first time I try to use it.

So now I have a new Samsung HD on the way and 2 SATA adapters to experiment with.

Of course I will report back here with the results...

#25 galvanash

galvanash

    X-S Enthusiast

  • Members
  • 8 posts

Posted 12 June 2008 - 03:04 AM

Hadn't looked at this thread since I posted it... Sorry to hear some people are having problems. Ive been up since day one (almost 2 months), and this is on an xbox I use as a uPnP server (it is on 24/7)... No issues with the hardware at all, runs like a clock.

I wouldn't at all be surprised that these little SATA adapters are hit and miss though, they don't exactly look like top notch engineering... But my particular one is solid so far.

ps. Im using the standard 40 pin IDE cable btw, but from my past experiences with xboxen 40/80 pin doesnt matter, as long as the cable is sound.

#26 galvanash

galvanash

    X-S Enthusiast

  • Members
  • 8 posts

Posted 12 June 2008 - 03:18 AM

BigPotty - I also have a 1.0 (although the 1TB is a 1.6). My 1.0 has a 320GB IDE and has always been a bit moody... I dont know what the issue is with mine. I dont exactly have the symptoms as you - mine will (maybe once a month, sometimes 2 months go by) just freeze up solid, and when this happens it refuses to boot (no xbox logo - nothing - nada).

Sometimes when it does this, if I wait a while (10 - 15 minutes) with it powered on it will actually start up (its kinda spooky, no idea what it is doing during all that time as there is no activity at all). Other times it just wont boot, even when I let it sit for hours. I generally open it up, look at everything, find nothing wrong, and then when I plug it back in everything is fine again... Im only posting this because I have spoke to friends with 1.0s and quite a few of them have dodgy ones as well. Id love to fix it though, as that is why I didn't put the 1TB in it. If I thought I could trust it Id put a 1TB in it as well. As it is now, Ill probably just buy another 1.6, they are like $60 or so on ebay...

#27 stogiesam88

stogiesam88

    X-S Member

  • Members
  • Pip
  • 63 posts
  • Xbox Version:v1.0
  • 360 version:v3.0 (falcon)

Posted 12 June 2008 - 05:21 AM

QUOTE(BigPotty @ Jun 3 2008, 04:33 AM) View Post

BUT, no stock, so I ordered a similar looking one from an Ebay Store:
http://cgi.ebay.com/...I...N:IT&ih=004

I'm also using that adapter for my 2.5" 320gb samsung spinpoint. I can't test it out now as I am waiting on a new power supply, but I will let you know how it turns out.


#28 galvanash

galvanash

    X-S Enthusiast

  • Members
  • 8 posts

Posted 13 June 2008 - 08:57 PM

Well this whole issue that BigPotty brought up about his 1.0 got me itching to finally fix mine. I did alot of research and it appears that mine (probably not BigPotty's problem though) is suffering from degraded traces... I pulled it apart and went over it with a magnifying glass and sure enough quite a few of the signal traces on the bottom outside edge of my board look pretty pitted and corroded. It still worked intermittently, but the problem appears to be getting worse. I could probably fix it, but Id rather just replace it with a v1.1, as the 1.0s run hot and I hate having the extra cooling fan (which I have had to change 3 times so far).

I'm posting this because someone else mentioned they ran out of willing testers for 64Kb clusters. Well you definitely have one now. I just ordered a new v1.1 board to replace my 1.0. I'm going to TSOP flash it with x2 5035 and am going to buy the same 1TB driver/adapter for it as well. I would REALLY like to try and get it working with 1 F partition (or a small F and a > 512GB G), because from my understanding unlike a softmod the X2 bios wont let you do an even split of the free space between F and G for very large drives (please correct me if I'm wrong on this). Even if it is possible to split though, my preference is to have one of the partitions be > 512GB. I store nothing large media files (nothing smaller than 500MB or so) on it so I don't much care about slack.

When I get everything in order I will post again, but if anyone has info on how I can get my hands on the version of xbpartitioner that supports 64KB clusters please let me know. I know there has been alot of activity on a patch set for it lately, but I havent seen it on xbins or anything.

#29 BigPotty

BigPotty

    X-S Young Member

  • Members
  • Pip
  • 34 posts

Posted 19 June 2008 - 08:38 PM

AHHH CRAP!!

Well, I got the replacement Samsung HD. As soon as I started to transfer my stuff from my old HD I started having problems! Freezing during transfers and slow/no boots.

I'm pretty sure that it is only a problem with the HD's themselves. I cannot return the drive for another Brand/Model so I am stuck getting it exchanged AGAIN.

Well at least Newegg makes this painless for me with free shipping and friendly service.

So now I have to wait for another replacement drive and hope that it won't crap out on me right away. Then I get to worry about it crashing some time over the next year and losing all my stuff. GREAT!!

This whole upgrade has gone so well!! Screw you Samsung!! I used to trust you!

BTW, I was running this replacement drive on the new SATA adapter I bought from Ebay.

#30 ozreplicator

ozreplicator

    X-S Enthusiast

  • Members
  • 3 posts

Posted 22 June 2008 - 01:53 PM

Well, I moved the adapter and 1TB drive from the 1.0 unit to a 1.6 xbox - same result with slow boots and hangs.
I then tried an identical adapter I bought with the other one as a spare - this time both xboxes worked perfectly every time.
I checked the faulty adapter with a magnifying glass and found a solder bridge between 2 of the legs on the main chip on the board. This isn't present on the good one. I haven't been able to remove it yet to test, but the seller on ebay has offered to send a replacement anyway. due to the gap between the legs, the short is barely visible to the naked eye.
The soldering on these boards (even the one that works) is quite dodgy, and wouldn't be surprised if there are many more out there with similar faults. They are probably all made in the same Chinese factory no matter what brand name is on them.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users