Jump to content


Photo

Compiling Skins In Linux


  • Please log in to reply
3 replies to this topic

#1 QuiescentWonder

QuiescentWonder

    X-S Enthusiast

  • Members
  • 21 posts

Posted 12 July 2008 - 07:14 PM

I'm running Linux, is there any way to compile the skins from SVN on linux? I tried running through Wine using this method:

CODE
travis@HappyComputer:~/mc360$ wine cmd
CMD Version 1.1.1

Z:\home\travis\mc360>build


I get all sorts of errors during the build process. I have the latest version of Wine at 1.1.1. I was going to just redo that batch files as bash scripts but then I noticed XBMCTex.exe. Does this run properly under Wine? Is there a Linux equivalent?

#2 Jezz_X

Jezz_X

    X-S Knowledgebase

  • Moderator
  • PipPipPipPipPipPipPipPip
  • 4,531 posts
  • Location:Australia
  • Xbox Version:v1.1
  • 360 version:none

Posted 13 July 2008 - 08:50 AM

There is a linux version of xbmctex now you can find the source in the xbmc svn here
CODE
https://xbmc.svn.sourceforge.net/svnroot/xbmc/branches/linuxport/XBMC/tools/XBMCTex

it has its own make file as well and accepts input path and output path

Edited by Jezz_X, 13 July 2008 - 08:50 AM.


#3 Horscht

Horscht

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,412 posts
  • Location:Germany
  • Xbox Version:v1.6
  • 360 version:v4.0 (jasper)

Posted 13 July 2008 - 07:27 PM

So, could a compiled linux xbmctex binrary be included in all the skins in the skin svn? or are there any issues preventing this? if there's no problem with an added linux version of xbmctex, there should be linux build scripts included

Edited by Horscht, 13 July 2008 - 07:47 PM.


#4 Jezz_X

Jezz_X

    X-S Knowledgebase

  • Moderator
  • PipPipPipPipPipPipPipPip
  • 4,531 posts
  • Location:Australia
  • Xbox Version:v1.1
  • 360 version:none

Posted 14 July 2008 - 12:45 AM

There are issues its not as simple as win32 where its just windows and thats it there are 500 different types of linux out there all with their own specific libraries and such so one compiled on ubuntu 8.10 will not work on ubuntu 7.04 and don't even think about somthign non ubuntu.

It needs to be compiled for each specific machine its used on

It just doesn't work that way :\




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users