Jump to content


Photo

Flashing The Samsung Ms25


  • Please log in to reply
22 replies to this topic

#1 Omega740

Omega740

    X-S Enthusiast

  • Members
  • 21 posts

Posted 19 October 2008 - 05:46 PM

Hey guys,
I tired my first flash attempt last night w/ no avail. I followed the textbook verbatim but when I tried to load up the newly flashed 360 it yeilded the e66 error (firmware mismatch). Here are the conditions that were used.

USB Flash drive iPrep method (dsam & fsam w/ my serial #)(in dsam: after drive was scaned I choose the XTREME Pri Master)
iXtreme 1.4 Toshiba/Samsung Flash bios
MS25 Samsung Drive
Xeno connectvity kit

Ok, it is my understanding that when you flash a ms25 in the firmtool phase it states:

Origional Firmware Version: ms25
Hacked Firmware Version: ms28 [iXtreme 1.4-5x]


On which I flashed the drive w/ no problems (you know 100% 4 banks etc.)]

which then led me to the e66 error. Now I am wondering what is going on b/c I can't get back into the drive. Or at least how I normally did before. First off I am a little bit scepticle that there is was not a ms25[iXtreme..] option available when flashing the drive in the firmtool phase. Hence, that is probably why the 360 does not recognize my drive's firmware anymore?

If that is the case then I am probably going to have to buy a via chipset card for my computer to recognize this newly flashed ms28/orionally 25 hybrid drive? Because when I try to get back into reflashing the drive the normal way using dsam, My options of choosing the XTREME Pri Master are gone.

Now it has changed to XTREME Sec Master; after I choose this option it leads to this and gets stuck.

Port: fd00, Master/Slave a0


and checkmate.

There is a few questions to draw from this:
1. Why would, in the firmtool phase, the hacked firmware not be ms25 [iXtreme..]?
2. Did I in fact flash it correctly changing it to ms28? But now the 360 doesn't recognize it.
3. How can I get back to the normal method of ms25 flash w/out getting stuck on XTREME Sec Master w/ dsam?





#2 oxide32

oxide32

    X-S Young Member

  • Members
  • Pip
  • 41 posts

Posted 19 October 2008 - 09:15 PM

hi m8, the ixtreme firmware you flashed to the drive (ms28) will be fine on an ms25, the reason you cannot get back into the drive firmware reading etc is because any ms28 firmware hacked or not usually has the firmguard protection installed that requires a slightly different way to read and write compared to the original ms25 or hacked ms25.
the ms28 firmware will work fine on an ms25 drive and vice versa (they are basically the same drive and will work with each others firmware).
to re access the firmware m8 make sure you use the bad flash method 10 second trick.
if you hunt around the forum or google it it will show you how, id personally make sure you copy and paste your key safe and download any ixtreme samsung firmware off the net and add your key to it then write it to the drive in a dos box with mtkflash w /m orig.bin.


#3 oxide32

oxide32

    X-S Young Member

  • Members
  • Pip
  • 41 posts

Posted 19 October 2008 - 09:34 PM

sorry forgot to mention that if you are gonna apply the hacked ms28 ixteme firmware to the ms25 drive to spoof the hacked firmware to an ms25.
this will stop the incompatiable problem your getting.


#4 Omega740

Omega740

    X-S Enthusiast

  • Members
  • 21 posts

Posted 20 October 2008 - 12:55 AM

I just tried the bad flash method unto no avail. Here is my process.

after answering yes to the intial questions:

dsam 1234567 12345 (my numbers obviously)
:connected my drive so that it can recognize the XTREME Sec Master
Drive Scanned:
1: IDE Pri Master
2: XTREME Sec Master
:unpluged the power and sata from the drive

selected the "2" option

waited 10-15 sec pluged the drive back in.

then ERR:fail to initial IDE port, please reboot PC!

then firmware tool pops up

ERROR: File BACKUPS\1234567\12345\Sam-OFW.bin does not exist! Program aborted!
C:\>


What strikes me odd here is that when I did the intial flash of the ms25, the dsam worked and made a backup file on my usb drive. here it did not bother to make it this time; probably b/c this is the bad flash method.?

Do I need to preload my own bios in the BACKUPS\1234567\12345 folder on my usb drive? If so, which one? Like I said before. The file for the Toshiba/Samsung from xbins only gives me 1 specific bios to use. Would I possibly need to find my modified MS25 or 28 bios somewhere else?

#5 ILikeMeat

ILikeMeat

    X-S Member

  • Members
  • Pip
  • 149 posts

Posted 20 October 2008 - 01:13 AM

Here is what I do for the bad flash method. Do the mtkflash and get up where it says hit 1 or 2 for Xtreme or w/e.

Turn off drive, wait 15 seconds, click on 1 or 2 or whatever it is, then wait another 15 seconds, power on drive.

If that doesn't work you are goingto need a VIA SATA 6421 pci card or you can use DosFlash to read and dump the drive, it works with firmguard on non VIA cards. I don't know exactly how to, like what the commands are, but 1.6 is decently intuitive so you should get it pretty easily. Also, a VIA card shipping within the US is 12 dollars shipped on ebay, might be worth the money.

#6 Omega740

Omega740

    X-S Enthusiast

  • Members
  • 21 posts

Posted 20 October 2008 - 01:30 AM

that is pretty much exactly what I did. I believe the question arose in my first post that whether I would need the VIA card or not b/c the drive was possibly flashed w/ the ms28 xtreme firmware; this is probably why I got the e66 error when I tried to run the drive on the 360.

#7 Omega740

Omega740

    X-S Enthusiast

  • Members
  • 21 posts

Posted 20 October 2008 - 03:54 AM

I also attempted the bad flash method and ran into my previous problem but also another one where I entered:

Drive Scanned:
1: IDE Pri Master
2: XTREME Sec Master
:unpluged the power and sata from the drive

selected the "2" option

but this time is says so jumble about IDE channel not initialized as so as I dc power from the drive to wait 10 sec later to reconnect. Then it goes into red letter abort mode and I'm back to square one.

#8 oxide32

oxide32

    X-S Young Member

  • Members
  • Pip
  • 41 posts

Posted 20 October 2008 - 09:24 AM

i think your best bet might be to purchase a 6421 card from ebay, they work flawless and i personally always use one myself, have you tried setting the ide to legacy in your bios.
id try that first mate, and you dont need to unplug the sata cable from drive just the power m8.
try the legacy thing first and if no go then get yourself a pci-sata 6421 card and end those problems.


#9 narcan

narcan

    X-S Enthusiast

  • Members
  • 12 posts

Posted 20 October 2008 - 09:34 AM

QUOTE(Omega740 @ Oct 20 2008, 05:30 AM) View Post

I also attempted the bad flash method and ran into my previous problem but also another one where I entered:

Drive Scanned:
1: IDE Pri Master
2: XTREME Sec Master
:unpluged the power and sata from the drive

selected the "2" option

but this time is says so jumble about IDE channel not initialized as so as I dc power from the drive to wait 10 sec later to reconnect. Then it goes into red letter abort mode and I'm back to square one.


Hiya, are you using the 0800 disc to unlock the firmguard and have you tried editing mtkflash by hand and flash your drive manually?

#10 Omega740

Omega740

    X-S Enthusiast

  • Members
  • 21 posts

Posted 20 October 2008 - 09:17 PM

QUOTE(oxide32 @ Oct 20 2008, 04:00 AM) View Post

i think your best bet might be to purchase a 6421 card from ebay, they work flawless and i personally always use one myself, have you tried setting the ide to legacy in your bios.
id try that first mate, and you dont need to unplug the sata cable from drive just the power m8.
try the legacy thing first and if no go then get yourself a pci-sata 6421 card and end those problems.

thanks man I will give that a try.

QUOTE(narcan @ Oct 20 2008, 04:10 AM) View Post

Hiya, are you using the 0800 disc to unlock the firmguard and have you tried editing mtkflash by hand and flash your drive manually?

I'm sorry that I'm new to this but im not sure what your talking about with the 0800 or the manually loading the mtkflash.

#11 Omega740

Omega740

    X-S Enthusiast

  • Members
  • 21 posts

Posted 21 October 2008 - 05:08 AM

I tried looking for a legacy portion in my bios. no go except for something that would allow legacy usb support, which was already enabled. I ordered the 6421 off of ebay. But I'm wondering if the same thing happened to you guys? Do you have an ms25 that made you have to get a 6421 b/c the firmware on it was a ms28?

#12 oxide32

oxide32

    X-S Young Member

  • Members
  • Pip
  • 41 posts

Posted 21 October 2008 - 08:28 AM

to tell you the truth i did start trying to flash with an on board sata but had lots of trouble reading and writing with this, i didnt have the same troubles as yourself but once i swapped to a 6421 then i found problems just went away.
the hitachi/lg worked fine with the onboard sata but for some reason i couldnt work with the samsung with onboard sata, this was what made me swap to the 6421 and it worked great.
dont forget to let us know how you get on with your new 6421 card.


#13 Omega740

Omega740

    X-S Enthusiast

  • Members
  • 21 posts

Posted 21 October 2008 - 07:26 PM

QUOTE(ILikeMeat @ Oct 19 2008, 07:49 PM) View Post

Here is what I do for the bad flash method. Do the mtkflash and get up where it says hit 1 or 2 for Xtreme or w/e.

Turn off drive, wait 15 seconds, click on 1 or 2 or whatever it is, then wait another 15 seconds, power on drive.

If that doesn't work you are goingto need a VIA SATA 6421 pci card or you can use DosFlash to read and dump the drive, it works with firmguard on non VIA cards. I don't know exactly how to, like what the commands are, but 1.6 is decently intuitive so you should get it pretty easily. Also, a VIA card shipping within the US is 12 dollars shipped on ebay, might be worth the money.

Does anyone know where to find a dosflash guide? Just so I can make sure I'm not doing anything wrong while the 6421 is being shipped here right now. Oh yea, I read somewhere that the dosflash is more risky than the iprep method, is this true?

Edited by Omega740, 21 October 2008 - 07:31 PM.


#14 Omega740

Omega740

    X-S Enthusiast

  • Members
  • 21 posts

Posted 24 October 2008 - 05:11 AM

anyone?


#15 sosotiit

sosotiit

    X-S Transcendental

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPip
  • 6,034 posts
  • Gender:Male
  • Location:Canada
  • Interests:Techno gadgets and espresso coffee
  • Xbox Version:v1.6
  • 360 version:v3.0 (falcon)

Posted 24 October 2008 - 05:24 AM

after your ms25 drive is flashed with one of the newer firmware, there is a feature called firmguard protecting it.

with the 6421 and the 10 second trick you will bypass that.

or with the same chipset you flash the first time, you can first use the 0800 disk to deactivate the firmguard
you can get the 0800 disk from one of the older xtreme firmware package, and you put it in your ms25 for about 20 second that will deactivate the firmguard,
then same method as you used the fisrt time (no 10 second)


-soso




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users