Jump to content


Photo

Alx2+ R3 / Dashboard Problems


  • Please log in to reply
No replies to this topic

#1 hyperjase

hyperjase

    X-S Enthusiast

  • Members
  • 6 posts

Posted 19 November 2008 - 12:02 PM

Hey all,

I've had my XBOX now for quite a few years, never really messed with it, it's worked quite well but I wanted to see what upgrade options were available to me. I have the ALX2+ chip and it was flashed with Xecuter 2 bios, I wasn't too sure what version with but it was done around 2003. I've updated it to X2 4981.67 but now the dashboard fails to load, I've tried using Avalaunch, EvoX and a few others but each time the same happens, it fails to load, just reboot and show the X2 logo.

When I try using an older disc to boot from and install that dash it works fine, I'm just confused as to why a new version won't remotely work but an older one is fine .... I know that that's ultimately the solution, but I hate having problems I can't figure out.

Just out of total interest too, when I do a bios check it shows 6 lots of bios, 2 x 512k and 4 x 256k, I've only ever been able to flash 256k bioses though ... is this correct?

Thanks in advance.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users