Jump to content


Photo

Hitachi 59dj


  • Please log in to reply
10 replies to this topic

#1 Default_002

Default_002

    X-S Young Member

  • Members
  • Pip
  • 49 posts
  • Location:Montana
  • Xbox Version:v1.6
  • 360 version:v3.0 (falcon)

Posted 24 February 2009 - 06:58 PM

I'll try and make this short and sweet.

Using Syba Sil3112A SATA card to flash my Hitachi 59DJ drive. Was able to get the drive into modeb using Slax boot cd. Loaded into windows and everything is recognized just fine. Run FLASHIX.bat and choose drive letter E speed 12x and folder 1987. Everything looks great until it stops at:

"Flashing 01/11 Sector 90003000 (Xtreme Custom Code)"

After searching, i read that it would be fine to reboot my pc. Most posts say that after a reboot everything works fine. For some reason it is still not working. I've rebooted 8 or 9 times with the same result. Tried safe mode. Was able to dump 'classic' in fw toolbox. Did a read and detect differences based on the very first was.bin file. The firmware seems to match so nothing was changed. Any ideas? Any help would be appreciated. Thanks

Default_002

UPDATE:

After a few more long hours of research, i may have narrowed it down. It seems that my SATA card may be flashed with the raid version of the bios. So i went straight to silicon image to the the base version. But when trying to flash the card i get a "selected bios image is too large" error. The bios file is 128k and the card flash memory is only 64k. For the absolute life of me I cannot find a 64k sil3112a bios. Just a thought...

Edited by Default_002, 24 February 2009 - 07:04 PM.


#2 Martinchris23

Martinchris23

    X-S Messiah

  • Members
  • PipPipPipPipPipPipPip
  • 3,900 posts
  • Location:Scotland, UK
  • Xbox Version:v1.6
  • 360 version:v4.0 (jasper)

Posted 24 February 2009 - 07:15 PM

Is the drive working at all?

If so, why are you not using DVD Firmware Toolbox to flash it? It's far better than the method you're currently using.



#3 Default_002

Default_002

    X-S Young Member

  • Members
  • Pip
  • 49 posts
  • Location:Montana
  • Xbox Version:v1.6
  • 360 version:v3.0 (falcon)

Posted 24 February 2009 - 07:41 PM

The drive works fine for original games, as the firmware has not technically been edited at all. The only reason i'm using this particular method is, from everything that i have read it sounds much easier to use the Flashix.bat method on 59 drives. I was also under the impression that FW Toolbox was for the 78 and 79 drives?

Anyway, at this point i would definitely be willing to give that a try. Do i just load the iXtreme 1.4 firmware into FW toolbox and then copy my drive key in and flash? I really haven't had any luck tracking down a guide for 59DJ using FW Toolbox, so i'm a little reluctant.

EDIT:

Is this a decent guide?

http://forums.xbox-s...howtopic=674032

Edited by Default_002, 24 February 2009 - 07:49 PM.


#4 Default_002

Default_002

    X-S Young Member

  • Members
  • Pip
  • 49 posts
  • Location:Montana
  • Xbox Version:v1.6
  • 360 version:v3.0 (falcon)

Posted 24 February 2009 - 08:48 PM

Just one clarification on the guide I posted above. Does the DVD movie need to actually be playing in the background while all of the steps are performed? When attempting to perform the Raw Dump in FW toolbox after i name the file, it keeps giving me an error and spits out a 8k file. It doesn't seem to be woking. Can i used the classic dump or does it have to be raw?

#5 wantin2mod

wantin2mod

    X-S Senior Member

  • Members
  • PipPip
  • 281 posts
  • Location:The North American Continent
  • Xbox Version:v1.6
  • 360 version:unknown

Posted 24 February 2009 - 09:08 PM

Well, sounds like you're having no problem getting your drive detected, that's good. With that being the case, it is not necessary getting an Xecuter CK3 but HERE is a tutorial from Xecuter that always seems to help me when I step into the realm of Hitachi drives. You might want to read it through just to see if it can jog your brain into finding a method that will work.

#6 Default_002

Default_002

    X-S Young Member

  • Members
  • Pip
  • 49 posts
  • Location:Montana
  • Xbox Version:v1.6
  • 360 version:v3.0 (falcon)

Posted 24 February 2009 - 11:01 PM

@wantin2mod Thanks for the guide.

I've been at this again for a few hours. One part I keep getting stuck at in the Raw dump in FW Toolbox. I put Oceans Eleven in the drive and the drive spins up like crazy. Then i select "Tools" - "direct drive dump" - "raw dump firmware as" and choose file name "original". but when i press "OK" i get a "Cannot read from drive" error message and the drive stops spinning at the exact same time. weird...

EDIT:

I guess my real question at this point would be can i go ahead and continue with the classic dump that i was able to create? What are the advantages of using a Raw dump? I'm still convinced i need to figure out a way to flash the bios of my sata pci card so that it functions in a non-raid mode, but we'll see...

Edited by Default_002, 24 February 2009 - 11:11 PM.


#7 Martinchris23

Martinchris23

    X-S Messiah

  • Members
  • PipPipPipPipPipPipPip
  • 3,900 posts
  • Location:Scotland, UK
  • Xbox Version:v1.6
  • 360 version:v4.0 (jasper)

Posted 25 February 2009 - 01:04 AM

Try using an original game instead of a DVD movie, but insert it BEFORE starting DVD Firmware Toolbox. Windows should detect the disc and ask if you want to open it etc (choose no).

From here try a raw dump.

#8 kurrrrt

kurrrrt

    X-S Member

  • Members
  • Pip
  • 92 posts
  • Xbox Version:unk
  • 360 version:v3.0 (falcon)

Posted 25 February 2009 - 04:20 AM

Did Slax work fine? Like got to the end where it says "Spinning up disc..." I had problems with my Hitachi drive where it would go into mode b but it would detect too many sectors and wouldnt flash. If you still get problems try using a different SATA port.

#9 Default_002

Default_002

    X-S Young Member

  • Members
  • Pip
  • 49 posts
  • Location:Montana
  • Xbox Version:v1.6
  • 360 version:v3.0 (falcon)

Posted 26 February 2009 - 12:24 AM

@kurrrrt Slax worked perfect. Saw the modeb message... got to the spinning disc... then went to the login. Modeb was a piece of cake.

At this point after struggling for so long i finally broke down i bought a VIA chipset sata card on newegg and will give this another try once i receive it. There were jumper holes soldered in on my current card for ide vs. raid mode. i soldered in a jumper and tried it both ways (jumped or not jumped) with the same result. It must be the bios that was flashed when i bought it, and with little to no documentation on this particular card, i gave up. Better luck in round 2! Thanks to everyone for the help so far. Hopefully i can get this done next week sometime.

PS - Here's the link to the card i bought:

http://www.newegg.co...N82E16815124022

#10 wantin2mod

wantin2mod

    X-S Senior Member

  • Members
  • PipPip
  • 281 posts
  • Location:The North American Continent
  • Xbox Version:v1.6
  • 360 version:unknown

Posted 26 February 2009 - 04:25 AM

I sure hope that this $15 item (plus S+H) gets you going! biggrin.gif

#11 Default_002

Default_002

    X-S Young Member

  • Members
  • Pip
  • 49 posts
  • Location:Montana
  • Xbox Version:v1.6
  • 360 version:v3.0 (falcon)

Posted 02 March 2009 - 10:32 PM

Got my new SATA card in today.

Installed it and tested it with a SATA DVD drive. All seemed to be working well. Tried to boot my Hitachi 59 into modeb using slax like I did previously, but for whatever reason I could not get the spinning... message part. No biggie, grabbed a 1k resistor and performed the 2 wire trick. Now with the drive in modeb, I booted to windows only to find my VT6421 in error code 10 and the drive not recognized at all. Anyone have any ideas here?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users