Jump to content


Photo

Help Me.


  • Please log in to reply
No replies to this topic

#1 FutbolChampione

FutbolChampione

    X-S Enthusiast

  • Members
  • 5 posts
  • Location:Pittsburgh
  • Xbox Version:unk
  • 360 version:unknown

Posted 06 March 2009 - 05:28 AM

Alright...
I fixed this Xbox that had RROD. It worked fine and everything. I try to give it back to my brother, and as soon as he plugged it in it RROD again. So I decided to tear it apart again. After doing that successfully, I re-did the heat sink and put it back together. Then I tried powering it on and it RROD again, so I turn it off and walked away from it. About 10 minutes later I came back and tried turning on again, and nothing would happen. I sat the power brick right next to me, and tried it again... Nothing happens, but one thing.
When I try to turn it on, the brick light goes from orange to red instantly. I tried the brick with the other 360, and no problem what so ever. Anyone have any ideas?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users