Jump to content


Photo

Python Script Failed


  • Please log in to reply
2 replies to this topic

#1 Donkeypuncher

Donkeypuncher

    X-S Member

  • Members
  • Pip
  • 106 posts

Posted 18 March 2009 - 01:28 AM

My plugins worked fine on the older t3ch builds, but now every plugin I try always gives the "python script failed". I spent 4 hours reading through posts on here and the xbmc boards, but I never could find a real answer. I think the last build I tried it on was in december, and it worked fine. Just thought I would ask here since you guys always give some straight forward answers and are very helpful.

I'm going to revert back to an older build where it worked just fine, just to see if it's a problem on my end.

#2 KInstinct2

KInstinct2

    X-S Enthusiast

  • Members
  • 12 posts

Posted 18 March 2009 - 04:00 AM

Newer builds changed the way plugins work as different syntax and procedures are used so unless the authors update the plugin its not gonna work. So use 2 builds one for plugins one for stabiity thats what I do.

#3 Temhil

Temhil

    X-S Enthusiast

  • Members
  • 17 posts

Posted 01 April 2009 - 04:29 AM

Yes, the problem those day is there are a lot of change in the python API of XBMC. Consequently old script/plugin using the old API won't run on recent XBMC et new script/plugins won't run on old XBMC unledd developers made it in order to insure backward compatibility (but usually they don't bother).
So it is a shame, but infortunatelly we don't have too much choice, the best we can do is to ask for fix of broken script/plugin on xbmc.org forum.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users