Jump to content


Photo

Xbpartitioner On A 1tb Hd


  • Please log in to reply
6 replies to this topic

#1 cb3dard

cb3dard

    X-S Member

  • Members
  • Pip
  • 76 posts
  • Location:Ontario
  • Xbox Version:v1.6
  • 360 version:v5.0 (360S - trinity)

Posted 06 April 2009 - 05:08 PM

Hi,

I've upgraded my HD to a 1TB Seagate with a SATA to IDE adapter. All works well, except when the HD is about half full, I can't transfer anymore. This happened to me a couple of years ago when I upgraded to a 400GB hard drive and didn't know I had to use bigger clusters. This time I used XBpartitioner 1.1 and it chose 64KB as the cluster size (doesn't seem to be adjustable). But now, I'm getting the same problem as before. Is 64KB an appropriate size for a TB HD? The actual size is about 928GB on my F drive. Thanks in advance for the help.

Chris

Edited by cb3dard, 06 April 2009 - 05:16 PM.


#2 lordvader129

lordvader129

    He Who Posts Alot...

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 17,735 posts
  • Location:Chicago, USA
  • Interests:#lordvader129
  • Xbox Version:v1.1
  • 360 version:v5.0 (360S - trinity)

Posted 06 April 2009 - 05:41 PM

xbpartitioner 1.1 will automaticallty choose an appropriate cluster size, 64k is correct

what bios are you using? some x2 49xx bios dont always work right with xbpartitioner

#3 cb3dard

cb3dard

    X-S Member

  • Members
  • Pip
  • 76 posts
  • Location:Ontario
  • Xbox Version:v1.6
  • 360 version:v5.0 (360S - trinity)

Posted 06 April 2009 - 05:51 PM

I have the X3 installed with the most current bios. Maybe I'll try allocating equal amounts of space to F and G. I can't understand then why this won't work.

#4 zx6r6

zx6r6

    X-S Young Member

  • Members
  • Pip
  • 44 posts

Posted 06 April 2009 - 09:29 PM

Eeeek! thats not good news, I've got the same setup as you bar a Maxtor 1tb drive. Hoping I don't have the same problem in 100gigs time.......

#5 cb3dard

cb3dard

    X-S Member

  • Members
  • Pip
  • 76 posts
  • Location:Ontario
  • Xbox Version:v1.6
  • 360 version:v5.0 (360S - trinity)

Posted 07 April 2009 - 12:29 AM

Can you do me a favor and let me know what happens when you get there? Would be greatly appreciated. I've reformatted and I'm trying again, we'll see what happens.

#6 Bomb Bloke

Bomb Bloke

    X-S Transcendental

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 6,567 posts
  • Location:Tasmania (AU)
  • Xbox Version:v1.0
  • 360 version:none

Posted 07 April 2009 - 05:26 AM

There's no need to wait - you can check that the drive is formatted correctly right now, and save yourself the future hassle and doubt.

Stick a copy of the EvoX dash somewhere on your console (anywhere will do, you don't actually have to set it up as your primary dash) and run that. You'll get a display of your disk free space in bytes.

Stick a small file (less then 1kb) on the relevant partitions and note the difference in free space. Divide this figure by 1024, and you have the cluster size in kilobytes.

Partitions under 256gb should use 16kb clusters.

Between 256gb and 512gb is 32kb clusters.

512gb to 1tb is 64kb clusters, and you can't partition anything larger then that because 128kb clusters don't work.

If you have a mismatch, check your BIOS, backup the drive contents, re-format and repeat the check.

I hear some versions of the X3 BIOS don't support XBP's custom partitioning scheme (which is required for this sort of thing in addition to LBA48 support), but to my understanding the "latest" one in that line should work.

X2 4983 is worthy of note because it doesn't (though 4981 does).

Edited by Bomb Bloke, 07 April 2009 - 05:27 AM.


#7 zx6r6

zx6r6

    X-S Young Member

  • Members
  • Pip
  • 44 posts

Posted 08 April 2009 - 11:12 PM

@cb3dard

I've got just over 420g free space left on the drive now and don't seem to be having any problems. Should I have had the problem show up by now? I'll fill it further if needs be.

One thing I'd better mention, although I'm not sure if this is of any relevance. I partitioned and formatted the drive on another xbox with the Ind 5003 bios, then put it in one with the x3 3294.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users