Jump to content


Photo

Working Gutsy 7.10 Mirror


  • Please log in to reply
16 replies to this topic

#1 dervboy

dervboy

    X-S Enthusiast

  • Members
  • 17 posts

Posted 18 May 2009 - 10:50 PM

since ubuntu have released their new version of ubuntu, they have done some housekeeping therefore our script or install method for installing gutsy 7.10 on our xbox-360's no longer works.

i have found a mirror in south africa but it doesnt contain the "release" file, and therefore still does not work.

does anyone know where we can get that gutsy from? were pretty much screwed now.

Edited by dervboy, 18 May 2009 - 10:52 PM.


#2 dervboy

dervboy

    X-S Enthusiast

  • Members
  • 17 posts

Posted 19 May 2009 - 12:15 AM

ok i found a mirror that appears to have everything i need. i have also found a site in brazil that is hosting the debootstrap package we need. i edited the script that stonersmurf made, and i have attached it below. for some reason this doesnt seem to work for me, could someone check it over?

CODE

#!/bin/bash
dd if=/dev/zero of=/dev/sda bs=512 count=1
sfdisk /dev/sda << EOF
,124,S
,,L
EOF
mkfs.ext3 /dev/sda2
mkswap /dev/sda1
sync; sync; sync
swapon /dev/sda1
mkdir /mnt/ubuntu
mount /dev/sda2 /mnt/ubuntu
cd /mnt/ubuntu
mkdir /mnt/ubuntu/work
cd /mnt/ubuntu/work
wget http://ubuntu.interlegis.gov.br/ubuntu/pool/main/d/debootstrap/debootstrap_1.0.3build1_all.deb
ar -xf debootstrap_1.0.3build1_all.deb
cd /mnt/ubuntu
zcat < /mnt/ubuntu/work/data.tar.gz | tar xv
export DEBOOTSTRAP_DIR=/mnt/ubuntu/usr/lib/debootstrap
export PATH=$PATH:/mnt/ubuntu/usr/sbin
debootstrap --arch powerpc gutsy /mnt/ubuntu http://pub.vse.cz/OS/Linux/Ubuntu/
echo Xenon > /mnt/ubuntu/etc/hostname
cat > /mnt/ubuntu/etc/fstab << EOF
/dev/sda2     /          ext3     defaults   0   0
/dev/sda1     none    swap    sw           0   0
EOF
cat > /mnt/ubuntu/etc/network/interfaces << EOF
iface lo inet loopback
auto lo
auto eth0
iface eth0 inet dhcp
EOF
cat > /mnt/ubuntu/etc/apt/sources.list << EOF
deb http://pub.vse.cz/OS/Linux/Ubuntu/ gutsy main restricted universe multiverse
EOF
cp /mnt/ubuntu/root/.bashrc /mnt/ubuntu/root/.bashrc.orginal
cat >> /mnt/ubuntu/root/.bashrc << EOF
passwd
mkdir /lib/modules/2.6.21.1
touch /lib/modules/2.6.21.1/modules.dep
apt-get update
apt-get install ntp wget -y --force-yes
aptitude install ubuntu-desktop -y
echo "AVAHI_DAEMON_START=0" > /etc/default/avahi-daemon
/etc/init.d/networking restart
cd /usr/lib/xorg/modules/drivers/
wget http://home.comcast.net/~ssmurf/xenosfb_drv.so
cd /etc/X11/
wget http://home.comcast.net/~ssmurf/ubuntu.conf
mv ubuntu.conf xorg.conf
cd /usr/lib/xorg/modules/linux/
mv libfbdevhw.so libfbdevhw.so.bk
wget http://home.comcast.net/~ssmurf/libfbdevhw.so
rm -r -f /work/
echo "" > /etc/gdm/gdm.conf-custom
sed -i 's/AllowRoot=false/AllowRoot=true/' /etc/gdm/gdm.conf
rm /root/.bashrc
mv /root/.bashrc.orginal /root/.bashrc
/etc/init.d/gdm start
EOF
echo "Base installation completed."
echo "To finish the installation. Reboot then load the sda2 bootloader CD."



#3 dervboy

dervboy

    X-S Enthusiast

  • Members
  • 17 posts

Posted 19 May 2009 - 12:54 AM

ok, this appears to be working. its currently booted from the hard disk on sda2, and its now fetching the packages / files from the mirror i found.

i'll post back if it works or not.

#4 dervboy

dervboy

    X-S Enthusiast

  • Members
  • 17 posts

Posted 19 May 2009 - 11:34 AM

this is all good.

i will image my hard disk now with acronis so i can re-image from home.

#5 thebigduk

thebigduk

    X-S Enthusiast

  • Members
  • 3 posts

Posted 06 September 2009 - 09:36 PM

QUOTE(dervboy @ May 19 2009, 12:54 AM) View Post

ok, this appears to be working. its currently booted from the hard disk on sda2, and its now fetching the packages / files from the mirror i found.

i'll post back if it works or not.



Looks like that mirror has gone down too sad.gif

Ive searched around but cannot find another. Does anyonehave any ideas how to install without the gutsy mirror?

TIA

Dan

#6 thc013

thc013

    X-S Enthusiast

  • Members
  • 10 posts

Posted 08 September 2009 - 04:09 PM

scripts still working

change the url's to

ftp://old-releases.ubuntu.com/old-images/


so

wget http://ubuntu.interl...3build1_all.deb

wget ftp://old-releases.ubuntu.com/old-images/...3build1_all.deb

and
debootstrap --arch powerpc gutsy /mnt/ubuntu http://pub.vse.cz/OS/Linux/Ubuntu/

debootstrap --arch powerpc gutsy /mnt/ubuntu ftp://old-releases.ubuntu.com/old-images/Ubuntu/

last one
deb http://pub.vse.cz/OS/Linux/Ubuntu/ gutsy main restricted universe multiverse

deb ftp://old-releases.ubuntu.com/old-images/Ubuntu/ gutsy main restricted universe multiverse

you could upgrade tot newer releases

i try'd and got to the ubuntu 9.04 but lost the graphical interface the free60-xorg-video-xenosfb-0.0.5 fb driver doesn't work anymore try'd to recompile the driver but till now no succes

old driver is complaining over ABI changes

my next try will be gentoo with a 2.6.24.3 kernel the old xorg and the rest updated but not with gnome but with a xfce4 desktop and from there look futher for kernel and fb-driver upgrade










#7 geoffmac

geoffmac

    X-S Member

  • Members
  • Pip
  • 84 posts
  • Location:UK
  • Interests:xbox/360/applemac/beer/women/games etc etc
  • Xbox Version:v1.6
  • 360 version:v1 (xenon)

Posted 14 September 2009 - 10:54 AM

thx for that thc013.

Gonna try this later, when you said you got to 9.04 but no graphical interface could we go to version 8 without a problem??

If so how lol Im not a linux guru like some. Maybe another script wink.gif

#8 geoffmac

geoffmac

    X-S Member

  • Members
  • Pip
  • 84 posts
  • Location:UK
  • Interests:xbox/360/applemac/beer/women/games etc etc
  • Xbox Version:v1.6
  • 360 version:v1 (xenon)

Posted 14 September 2009 - 02:01 PM

Try this one guys http://www.free60.or...ki/Debian-lenny

#9 geoffmac

geoffmac

    X-S Member

  • Members
  • Pip
  • 84 posts
  • Location:UK
  • Interests:xbox/360/applemac/beer/women/games etc etc
  • Xbox Version:v1.6
  • 360 version:v1 (xenon)

Posted 14 September 2009 - 10:22 PM

xenosfb error after install we need an updated display driver!!

#10 geoffmac

geoffmac

    X-S Member

  • Members
  • Pip
  • 84 posts
  • Location:UK
  • Interests:xbox/360/applemac/beer/women/games etc etc
  • Xbox Version:v1.6
  • 360 version:v1 (xenon)

Posted 15 September 2009 - 09:02 PM

This one works http://www.free60.org/wiki/Debian-etch smile.gif

#11 masterluke

masterluke

    X-S Enthusiast

  • Members
  • 15 posts

Posted 11 October 2009 - 09:10 AM

QUOTE(thc013 @ Sep 8 2009, 04:09 PM) View Post

<snip>

debootstrap --arch powerpc gutsy /mnt/ubuntu http://pub.vse.cz/OS/Linux/Ubuntu/

debootstrap --arch powerpc gutsy /mnt/ubuntu ftp://old-releases.ubuntu.com/old-images/Ubuntu/

last one
deb http://pub.vse.cz/OS/Linux/Ubuntu/ gutsy main restricted universe multiverse

deb ftp://old-releases.ubuntu.com/old-images/Ubuntu/ gutsy main restricted universe multiverse



thanks that nearly works but the directory structure is case sensitive and Ubuntu has a lower case "u" so links should be...

debootstrap --arch powerpc gutsy /mnt/ubuntu ftp://old-releases.ubuntu.com/old-images/ubuntu/

deb ftp://old-releases.ubuntu.com/old-images/ubuntu/ gutsy main restricted universe multiverse


..that seems to work



#12 masterluke

masterluke

    X-S Enthusiast

  • Members
  • 15 posts

Posted 11 October 2009 - 03:22 PM

something like this...

#!/bin/bash
dd if=/dev/zero of=/dev/sda bs=512 count=1
sfdisk /dev/sda << EOF
,124,S
,,L
EOF
mkfs.ext3 /dev/sda2
mkswap /dev/sda1
sync; sync; sync
swapon /dev/sda1
mkdir /mnt/ubuntu
mount /dev/sda2 /mnt/ubuntu
cd /mnt/ubuntu
mkdir /mnt/ubuntu/work
cd /mnt/ubuntu/work
wget ftp://old-releases.ubuntu.com/old-images/...3build1_all.deb
ar -xf debootstrap_1.0.3build1_all.deb
cd /mnt/ubuntu
zcat < /mnt/ubuntu/work/data.tar.gz | tar xv
export DEBOOTSTRAP_DIR=/mnt/ubuntu/usr/lib/debootstrap
export PATH=$PATH:/mnt/ubuntu/usr/sbin
debootstrap --arch powerpc gutsy /mnt/ubuntu ftp://old-releases.ubuntu.com/old-images/ubuntu/
echo Xenon > /mnt/ubuntu/etc/hostname
cat > /mnt/ubuntu/etc/fstab << EOF
/dev/sda2 / ext3 defaults 0 0
/dev/sda1 none swap sw 0 0
EOF
cat > /mnt/ubuntu/etc/network/interfaces << EOF
iface lo inet loopback
auto lo
auto eth0
iface eth0 inet dhcp
EOF
cat > /mnt/ubuntu/etc/apt/sources.list << EOF
deb ftp://old-releases.ubuntu.com/old-images/ubuntu/ gutsy main restricted universe multiverse
EOF
cp /mnt/ubuntu/root/.bashrc /mnt/ubuntu/root/.bashrc.orginal
cat >> /mnt/ubuntu/root/.bashrc << EOF
passwd
mkdir /lib/modules/2.6.21.1
touch /lib/modules/2.6.21.1/modules.dep
apt-get update
apt-get install ntp wget -y --force-yes
aptitude install ubuntu-desktop -y
echo "AVAHI_DAEMON_START=0" > /etc/default/avahi-daemon
/etc/init.d/networking restart
cd /usr/lib/xorg/modules/drivers/
wget http://home.comcast..../xenosfb_drv.so
cd /etc/X11/
wget http://home.comcast....urf/ubuntu.conf
mv ubuntu.conf xorg.conf
cd /usr/lib/xorg/modules/linux/
mv libfbdevhw.so libfbdevhw.so.bk
wget http://home.comcast....f/libfbdevhw.so
rm -r -f /work/
echo "" > /etc/gdm/gdm.conf-custom
sed -i 's/AllowRoot=false/AllowRoot=true/' /etc/gdm/gdm.conf
rm /root/.bashrc
mv /root/.bashrc.orginal /root/.bashrc
/etc/init.d/gdm start
EOF
echo "Base installation completed."
echo "To finish the installation. Reboot then load the sda2 bootloader CD."


#13 masterluke

masterluke

    X-S Enthusiast

  • Members
  • 15 posts

Posted 11 October 2009 - 07:53 PM

ok - just tested the above script and it appears ok. the only issue is during configuration the xorg.conf from stonersmurf's site got overwritten somehow and i had to download it again.. all appears OK apart from the resolution.. im stuck in 640 x 480 (same as i was in gentoo). Any ideas? Is this because im using a component connection?

#14 thc013

thc013

    X-S Enthusiast

  • Members
  • 10 posts

Posted 13 November 2009 - 07:35 PM

there is now the xenosfb in git so if we gonna play with that

the problem with that that there are changes in xorg like abi changes etc

and that's I think a street to far for me but trial and error is also fun

#15 DaemoniZ

DaemoniZ

    X-S Enthusiast

  • Members
  • 24 posts

Posted 24 November 2009 - 09:56 PM

[del]

Edited by DaemoniZ, 24 November 2009 - 09:58 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users