Jump to content


Photo

Multi-step Problem Regarding Flashing Of Samsung Ms-25 Drive.


  • Please log in to reply
8 replies to this topic

#1 SaviorsHand

SaviorsHand

    X-S Enthusiast

  • Members
  • 9 posts

Posted 02 June 2009 - 01:00 AM

I need some help on flashing my Samsung drive, it's driving me nuts and I'd really like to get this fixed. Please allow me to explain my issue, as it's kinda long and complicated so if you can bear with me that would be great.

About 1 year ago I decided to mod my Samsung drive to the iXtreme 1.4 firmware. I did this through iPrep to load the firmware and dos files onto my flash drive, and the HPbootdisk to create the boot disk. I then went in and used the MTKFlash method, in DOS, and was able to successfully read and write the iXtreme firmware. I don't believe I remember any issues with this problem. I backed up the original firmware and the hacked to my backup hard drive and a Disk.

A month and a half ago I noticed my drive was no longer reading disks properly, and I would get a disc unreadable message. I used it all the time and after some reading on the internet and some personal work on my own behalf I could tell the drive was essentially dead. I purchased a replacement online through Ebay and I received an MS-28. Now I've read, watched and been told that the differences between and MS-25 and Ms-28 are purely on the board itself. So if I replace the board from the MS-28 with the one of my old drive, I would have, essentially, an MS-25 drive with new motor parts. I replaced the board and my system works... for the most part, without error.

A few days ago I decided I should upgrade to the latest firmware. I do use XboxLive and play newer games that I want to backup. The problems I'm running into are as follows:

I prepared my flash drive, which is really just the flash memory on my PSP... isn't technology werid? Anyways, I've preped the device using Iprep 101 v008.9. I'm not used to the new interface they have, however I tried to use the Samsung 1.6 firmware and it seems no matter where I downloaded it from, xbins or torrent websites, I'm unable to get it to load. I made sure this wasn't 0800 firmware that was designed for the ripping drive. I found a version of 1.51, which should work I guess, and it loaded in iprep. I copied over the information to my flash device and attempted to start.

I connected the Sata cable from my computer to the PC. For future reference I have tested this cable by using the cable I have connected to my secondary drive and this does not make a difference. I power on the Xbox 360 from the get go, before my PC is turned on. The PC is set to boot from the PSP and that loads fine.

After I load the main program it asks me for the usual stuff, enter dSam and the serial number. Tells me to follow the screen instructions and power cycle and so forth. HERES THE ISSUE: When I get to this portion, and tell it to keep retrying to read the drive, I am in a status of 0x51. I turn off my 360 and turn it back on after about 10 seconds. Either my machine locks up and my motherboard beeps a long beep at me, or it doesn't but it just sits there and there's no screen text saying it's reading the drive. I cannot get past this step whatsoever. I've tried waiting a long time for the device to change status, I've tried powering up the 360 after my computer is on, I've tried everything I can think of. No dice.


My next attempt was trying Jungle Flasher. I've tried all known versions from .24 up to 1.61 beta, and I'm having the same issue. I've manually installed the PortIO32 drivers into my windows xp machine and they show up as correct under the Device Manager. I've also made sure to update to the Net framework of 3.5. Both of these are confirmed using What.net.exe and the port check exe. The firmware of 1.51 and 1.6 are both loaded into the firmware folder. But everytime I click on Jungle Flasher or tell what.net to launch it I just get this long script error about crashing and it shows my process and thread id. I'd give an exact error but I'm at work and don't have that info.

I apologize for the length of this post, but I just want to really put into detail my problem. I would try another method but I honestly can't think of another method to do so, whether in windows or dos.



Some useful notes:
1. My Bios shows up as correct for the DVD drive, TSScorp Toshiba Samsung TS- and stuff.
2. The MTKflash method does show as a device on one of my ports before hitting yes to repeatedly ping the device.
3. I can't, well not easily (150gb of storage would need to be done), reinstall windows so a method that doesnt require a full reinstall is prefered.
4. I used this same psp to flash my drive beforehand
5. I've tried removing the 1.6, or 1.51 or both firmware from the Jungle Flasher folder and loading it, still no dice.


If I can think of anything else that's actually useful to know, I'll post it. In the meantime thank you in advance for anyone that can help me today, it really is appreciated =)

#2 vb_encryption_vb

vb_encryption_vb

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,943 posts
  • Location:Acworth,GA
  • Xbox Version:v1.6
  • 360 version:v4.0 (jasper)

Posted 02 June 2009 - 02:14 AM

to much to read lol is the tray half open?

#3 SaviorsHand

SaviorsHand

    X-S Enthusiast

  • Members
  • 9 posts

Posted 02 June 2009 - 02:18 AM

No, no the tray is resting inside closed. I remember reading about that tray half open business, I thought it was for Hitachi drives. Does that mean I need to do something funky with my tray?

#4 darko619

darko619

    X-S Young Member

  • Members
  • Pip
  • 31 posts

Posted 02 June 2009 - 03:40 AM

my guess is you will still have to bad flash it (which it sounds like you are trying)
it isnt always 10 seconds exactly, that is the rule of thumb. try it at 3s, then 5, then 8, ten you can probably skip (grin), 15 etc.
i had a sammy m28 that i tried forever at the 10 second mark. then i got distracted, hit the button late (closer to 20 seconds) and the SOB switched over and dumped.
drive timing will vary, so change your timing and hopefully that port error will switch over and dump.

actually the TEXTBOOK says something to that point on pg 105

i swear, just about every question in this forum is answered in hacking the 360 for noobs (the 2008 textbook pdf(

#5 SaviorsHand

SaviorsHand

    X-S Enthusiast

  • Members
  • 9 posts

Posted 02 June 2009 - 04:12 AM

Yeah I have the Textbook and I read on page 106, found what you were talking about. Tried doing immediately with no waiting period, I tried 2 seconds, 5, 8, 20 seconds and even a minute. No go, just stuck on 0x51 status.

One thing I did do was, since my system wasn't hanging up, I just tried 5 seconds.. when it didn't work I'd turn back off the 360 and so forth. My definitive turn off point was after the green rings would circle I'd give it about 10 seconds then turn it off if the status didn't change. Starting to drive me kinda nuts, hehe. Um, I do know I'm disconnecting all my other devices and such. Should I turn off the 360, or should I unplug the power of the DVD drive, that little cable?

#6 alwaysonjohn

alwaysonjohn

    X-S X-perience

  • Members
  • PipPip
  • 392 posts
  • Location:Clarksville, TN
  • Xbox Version:none
  • 360 version:v5.0 (360S - trinity)

Posted 02 June 2009 - 04:31 AM

it's easy with the via card and the power adapter, i just hit intro and turn it off/on quickly and that works... it doesn't matter if it has ixtreme 1.4, or its new, or what... it works.

#7 SaviorsHand

SaviorsHand

    X-S Enthusiast

  • Members
  • 9 posts

Posted 02 June 2009 - 04:38 AM

Well honestly I don't really plan on making it a habit to mod other peoples consoles, and I only change my firmware every now and then when it's very neccesary. That and I'm broke as shizen. So I'd like to avoid buying hardware. Especially when it used to work just fine, I mean last time the transition was very smooth.

I use an Intel motherboard built on SATA chipset, ICH6, which used to be covered in the 1.4 days. Not so sure now, but I don't see why not.

#8 SaviorsHand

SaviorsHand

    X-S Enthusiast

  • Members
  • 9 posts

Posted 03 June 2009 - 01:09 AM

I played around with it all night, using the MTK flash method and attempting to use Jungleflasher and still no luck. I've hooked it all back up just to verify that the 360 still works, and I didn't break it somewhere along the way. It definately still does, and backup games play just fine.


Any other things you guys can reccomend? Honestly I'm completely clueless as to what I can do to solve this problem, which is something I'm not used to .. heh blink.gif

Edited by SaviorsHand, 03 June 2009 - 01:10 AM.


#9 darko619

darko619

    X-S Young Member

  • Members
  • Pip
  • 31 posts

Posted 03 June 2009 - 03:15 AM

well something basic has gotta be wrong then. this should be an ez one.
uninstall/reinstall VIA card with NEW drivers
unistall ALL versions of iprep (check program forlder for iprep and xprojects folders)
grab from the usual places....
new iprep
ixdef for 1.6
ixtreme 1.6
the new toolbox

redo everything from step 0!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users