Jump to content


Photo

Ftp Using Internet Explorer


  • Please log in to reply
62 replies to this topic

#1 trob

trob

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,327 posts

Posted 25 June 2003 - 01:09 PM

Let me start off by saying I am only posting this because it is an easy way for some people to start ftping to the xbox without downloading additional software. Windows FTP is slower than most software that has been written to do ftp only. However it does resemble the regular Windows Explorer and you can copy, cut, and paste like you normally do to move files around in Windows.

Ok, with that out of the way lets get things going. First I will define how to setup a PC and xbox to directly connect to each other using a crossover cable. Make sure you have a crossover cable as defined below.

Crossover Cable Pin-out (abbreviated colors)
Connector 1:
O/W O G/W BL BL/W GR BR/W BR
Connector 2:
G/W G O/W BL BL/W O BR/W BR

Next you will have to setup IP addresses on your PC and Xbox. On your pc go into your network properties and select TCP/IP properties for your ethernet adapter (I did not mention you had to have this but I hope you can figure it out on your own.) Now change select Use the following IP address: and enter the settings below.

IP address: 192.168.0.2
Subnet mask: 255.255.255.0
Default Gateway: 0.0.0.0 (leave blank or enter 1.1.1.1)

Now save theses setting, if your using broadband or something and your PC is pre-configured please document what you are changing.

On your pc go to start->run and type "command" and press enter.
A command window should open and you will have a command prompt.
Type "ipconfig" and press enter to verify your ip setting. You should see the static setting your your ethernet adapter, if not you may get 0.0.0.0 or cable disconnected. If so, make sure your crossover cable is plugged in. Second if you get 0.0.0.0 you may have to disable the enable your nic. If that is too confusing just reboot. If you made any of these changes issue the ipconfig command again and check results.

Next we need to verify the ip settings in evox. Usually by default the ip settings are preset. But we need to verify them. In your evox.ini go to the [Network] section. Verify the following:

SetupNetwork = Yes
StaticIP = Yes
IP = 192.168.0.3
Subnetmask = 255.255.255.0
Defaultgateway = 0.0.0.0

You can also make these changes going into evox settings just make sure after you change them scroll down the screen and select SAVE AND EXIT. Also some people want to monkey around with the gateway. Your devices are on the same subnet and they are connected to each other, you do not need a gateway because your not leaving your subnet.

Now make sure you have plugged in your crossover cable to your xbox and pc. Reboot evox and you should be connected. Try and ping your xbox to see if you have a connection.

Start->Run->Command (enter)
Type "ping 192.168.0.3" (enter)
You should get about 4 replies from 192.168.0.3. If so you are ready to ftp.

To ftp using Internet Explorer is quite easy. Begin by opening up Internet Explorer. In the address bar type the following: "ftp://xbox:xbox@192.168.0.3" press go or enter. the xbox:xbox is username:password if you have change them in the evox.ini. Also you can just but the username and it will prompt you for the password. You should now see all your drives in your window. Cut, copy and paste as you please.

Edited by trob, 01 July 2003 - 02:15 PM.


#2 Xeero

Xeero

    Welcome Back!

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 8,413 posts
  • Location:Massachusetts
  • Xbox Version:v1.0

Posted 25 June 2003 - 01:40 PM

Don't you have to disable PASV in the IE settings as well? I would think you'd have to.

#3 trob

trob

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,327 posts

Posted 25 June 2003 - 01:54 PM

By default in IE passive is usually turned off. If you want to check go into your internet options and it is in the browser settings section. Make sure it is unchecked.

Passive FTP which is sometimes referred to as PASV FTP is an additional ftp command used instead of a PORT command. It is a more secure form of data transfer which is requested by the client (pc) and must be enabled on the server (xbox). From my knowledge I don't think that evox's ftp server is setup to use passive ftp connections so you will need to turn off passive on any ftp client.

#4 choogler23

choogler23

    X-S Young Member

  • Members
  • Pip
  • 36 posts

Posted 25 June 2003 - 07:04 PM

I followed your instucktions and sent 4 and recieved 0. When I try to ftp I get connection failed(no route host). Please help.

#5 trob

trob

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,327 posts

Posted 26 June 2003 - 01:39 AM

Are you direct connecting via crossover cable or patch cable and hub/switch?

#6 flying_monkey

flying_monkey

    X-S Young Member

  • Members
  • Pip
  • 30 posts

Posted 26 June 2003 - 07:45 PM

direct through a crossover cable

#7 trob

trob

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,327 posts

Posted 26 June 2003 - 07:51 PM

If you need help on this topic PM or email me.

#8 beecham

beecham

    X-S Enthusiast

  • Members
  • 9 posts

Posted 27 June 2003 - 07:25 AM

I followed the instructions as stated and it still times out. No error message it just simply times out.


#9 flying_monkey

flying_monkey

    X-S Young Member

  • Members
  • Pip
  • 30 posts

Posted 27 June 2003 - 06:25 PM

do you need diferent ip address's as in your tutorial, or is it a typo.


#10 trob

trob

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,327 posts

Posted 27 June 2003 - 06:35 PM

xbox and pc must have different ip addresses. Any two or more networking devices on the same network have different addresses.

Many people are having issues with XP as well. Make sure firewall is turned off. I hope to isolate any additional problems with XP's networking properties.

#11 BenJeremy

BenJeremy

    X-S Elysian

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,690 posts
  • Gender:Male
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 27 June 2003 - 07:21 PM

MXM works through FTP with IE, PASV on or off.

#12 trob

trob

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,327 posts

Posted 01 July 2003 - 02:10 PM

Thanks BenJereremy, sorry I forgot to mention that. I know that mostly noobs look at this thread, and most noobs start with evox.

I would like to mention that BenJeremy has done some great work to provide us with his MXM Dash. I will say it is a step up from evox.

Also I have modified the tutorial by adding a step after setting up your nic ip. This step is to verify the static setting on your nic.

#13 Withinside

Withinside

    X-S Young Member

  • Members
  • Pip
  • 56 posts
  • Location:Nova Scotia
  • Interests:Mechanics, Scripting, Computers, video games
  • Xbox Version:v1.0

Posted 18 July 2003 - 03:07 AM

I have followed all the instructions you stated above. I pinged the box, 4 times 4 replys. Using 2 NIC's; 1 to high-speed modem, the other to the box. Connected via crossover. Explorer won't connect me (a connection with the server could not be established). First tried using FlashFxp and it kept timing out, so I rechecked the IP/TCP settings according to a tutorial, basically same as what you stated above, now FlashFXP gets connection refused. I think it may be the box. X-box 1.0, Evox, matrix, blue-color mod

#14 trob

trob

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,327 posts

Posted 18 July 2003 - 03:16 AM

In FlashFXP you must disable passive ftp for evox, MXM and XBMP is ok for passive. Also I am guessing your on Windows XP. There are all kind of issues getting this to work. First make sure you do not have the M$ Firewall active in the network settings and try disabling any other firewall software your running if appliciable.

#15 Withinside

Withinside

    X-S Young Member

  • Members
  • Pip
  • 56 posts
  • Location:Nova Scotia
  • Interests:Mechanics, Scripting, Computers, video games
  • Xbox Version:v1.0

Posted 18 July 2003 - 03:32 AM

no firewall, win98se, and passive mode disabled. (Use passive mode box completely unchecked) in site manager options
Connecting to My X-Box
Connection failed (Connection refused)
Delaying for 60 seconds before reconnect attempt #1
anything else that I might try?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users