Jump to content


Photo

Mag Beta, What I Thought About Game.


  • Please log in to reply
2 replies to this topic

#1 guruthe

guruthe

    X-S Enthusiast

  • Members
  • 22 posts

Posted 23 September 2009 - 10:52 AM

Hi All,

I gotten MAG beta code, after 4 hours downloading (on 10Mb connect), EA servers seem to of been overloaded cause it was SLOW to download but worth it.

I thought was good game, graphics are fine, about 7/10 much be because so many online.
Map are BIG and layout good. Has Perks system, sort of like COD

My only problem with it (maybe because its a beta) but searching and loading the level can take 5-6 mins (it builds up 128/2556 players) and even then you might get an error and kicks you out.

Would buy it if they fixed the searching for a game thing.

Anyone else get the beta?

G

Forgot to say.

When you 1st load it, it says create player and you have to choice a region, Neitherland, Austria or USA. If you want to change to a different region, you have to delete this player and lost your points/perks and create a new one, which is a bit of a pain.

#2 guruthe

guruthe

    X-S Enthusiast

  • Members
  • 22 posts

Posted 23 September 2009 - 12:32 PM

Its also good can have different levels of Armour which the player image changes, different helmets or face masks. Might seem stupid, but good can change them and a little of the colour ie grey and red

#3 guruthe

guruthe

    X-S Enthusiast

  • Members
  • 22 posts

Posted 25 September 2009 - 02:05 PM

MY PROBLEM:After I join a queue, this takes 2 mins, the graphic comes up with loading, the 5 loading arrows at the bottom, mine will stop at the 2nd then 'Lost connection', Ports are open on router with static IP, Other games work 100%. My friend got MAG code, were on the same ISP his works fine. Loads inside 2 TOPS.

Anyone any ideas? or have the same issue? NTL digial line, Speed test is also fine.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users