Jump to content


Photo

Need Proper Script


  • Please log in to reply
4 replies to this topic

#1 crash_2012

crash_2012

    X-S Senior Member

  • Members
  • PipPip
  • 193 posts
  • Location:stuck in the matrix. trinity wont get off the phone, damn busy signal.
  • Interests:computers, and almost anything technical
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 09 October 2009 - 07:49 PM

i really feel like a noob for this. but im trying to get ubuntu running on my 360, ive dled the script from stonersmurf's comcast page, and edited it with proper active links. if im reading the terminal properly, it seems to crap out and says the directory isnt there, or something, around this line
CODE
debootstrap --arch powerpc edgy /mnt/ubuntu http://archive.ubuntulinux.org/ubuntu

using the stickied tutoral on here, and trying everything that people suggest doesnt seem to do anything different for me. any links or advice would be great. thnx.


this has been wracking my brain for the past 20 something hours. i need help!! LOL

#2 masterluke

masterluke

    X-S Enthusiast

  • Members
  • 15 posts

Posted 10 October 2009 - 10:41 PM

same boat here - ive spent most of the day today getting a debian lenny install working.. the script at the top of the free60 wiki page which you wget from ssmurfs page is different to the code presented below it.. took me a while to work out why the debootstrap file wasnt downloading but after updating the link it all kicked off. The install unfortunately bummed out immediately after debootstrap finished. Luckily the script is easy to follow so i did the rest manually taking a lead from the script.

What i didnt know if that the xorg version that comes with lenny is incompatible with the xenosfb driver so there is no way i can see to get a gui up and running.

Gonna try the debian etch script later.





aargh - using the etch script i get an "unable to mount root FS" after rebooting from the livecd.

#3 coreire

coreire

    X-S Young Member

  • Members
  • Pip
  • 45 posts

Posted 11 October 2009 - 01:26 AM

I was in the same situation, tried ubuntu, then lenny, then etch.

The xserver also did not work in etch, but I've just got it work a few mins ago.

I didn't download the script on the free60 site, I pasted the quoted text for the script into a new file and ran that.

After it installs, xserver won't work.
To get it working type:

aptitude install xorg

cd /usr/lib/xorg/modules/drivers/

rm -r -f *
wget http://home.comcast..../xenosfb_drv.so

cd /etc/X11/

rm -r -f xorg.conf

wget http://home.comcast....smurf/xorg.conf

dpkg-reconfigure xserver-xorg

Now, go through the setup that pops up and when its finished you'll have a working xserver.



#4 coreire

coreire

    X-S Young Member

  • Members
  • Pip
  • 45 posts

Posted 11 October 2009 - 01:58 AM

Spoke too soon.

Xserver not working again after reboot.

I'll post back if I get it sorted out.

#5 masterluke

masterluke

    X-S Enthusiast

  • Members
  • 15 posts

Posted 11 October 2009 - 09:05 AM

QUOTE(coreire @ Oct 11 2009, 01:26 AM) View Post

To get it working type:
<snip>


im sure i tried that - this is under lenny right? I used that xenosfb and that xorg.conf and got the ABI version mismatch error. Im guessing downgrading to an earlier xorg would work but I couldnt work it out.

Trying an ubuntu gutsy install today - the missus isnt happy biggrin.gif

What we REALLY need is an updated xenos display driver.. that would bring more modern distribution into scope. Its beyond what my feeble mind can manage unfortunately.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users