Jump to content


Photo

Windows 7 And Smb Shares


  • Please log in to reply
21 replies to this topic

#1 xboxbox451

xboxbox451

    X-S Freak

  • Moderator
  • PipPipPipPipPip
  • 1,015 posts
  • Xbox Version:v1.6
  • 360 version:none

Posted 06 November 2009 - 11:25 AM

Some things to check.
  • Check and see if Windows built-in firewall is blocking access.
  • Check and see if any third party firewall you have installed is blocking access.
  • Check and see if you have Windows Live Sign-in Assistant installed. If so, see below solution.
=====================================================================

If you have a Microsoft Live application installed titled Windows Live Sign-in Assistant, that could be your conflict.

There are two workarounds that should resolve your problem.

WORKAROUND 1
In Windows 7 go to "Control Panel" then "Installed Programs and Features". Look for the program titled Windows Live Sign-in Assistant.

Uninstall it, reboot PC, reboot XBOX, try your shares again.

Note: Uninstalling the Windows Live Sign-in Assistant program will not affect the way Windows Live Messenger works. However, it will remove the functionality whereby if you have multiple Live/Hotmail accounts, you no longer will see all your accounts listed at one time on the Live sign in page.

WORKAROUND 2
Use your computers local IP address to create a network share in XBMC rather than using the computer name. This workaround should resolve the sharing conflict even if you have the Windows Live Sign-in Assistant installed.

When creating a network share in XBMC, choose "Add network location" from the "Browse for new share" window. Enter your computers local IP address in the "Server name" field. If your Windows 7 user account is password protected, then add your username and password too. Confiigure the rest of the share as usual.

For those unfamiliar, below is a brief walk-thru on creating a share using your PC's IP address.

NOTE: Walk through performed using the PM3 skin, and a PC that has all user acounts password protected.

If you want to share without the need of entering a username and password, then you may need to remove any password set on your Windows 7 Guest account, and turn off "Password protected sharing", which setting can be changed in Windows 7 by going to Control Panel>Network and Sharing Center>Change Advanced Sharing settings>Home or Work. Keep in mind, having PC user accounts enabled without password protection compromises the security of your computer.

CONTROLLER TIP WHEN USING XBMC ON-SCREEN KEYBOARD:
X button > switches between letters and symbols
Y button > swithces from uppercase to lower
B button is backspace

KNOWING YOUR PC'S LOCAL IP ADDRESS
If your unfamiliar on what your computers local IP address is, follow this:

> In Windows 7
> Click your Win7 start button
> Enter cmd in the search field and hit enter
> Windows command interpreter will pop up
> Type ipconfig at the prompt within the command interperter and hit enter
> You should now see a listing
> Your computers local IP address should be the top result found under Ethernet adapter Local Area Connection listed to the right of IPv4 Address.

XBMC LOCAL IP SMB SHARE WALK-THRU
From home page click "Videos"
1> Add source
2> Browse
3> Add network location...
4> Server name (enter your PC's local IP address here)
5> Shared folder (enter specific folder you want to share or leave blank to see all shares)
6> Username (enter the usename of your PC account)
7> Password (enter the password of your PC account)
8> OK (If you clicked OK and still get promted for username and password, then click the "add network anyways" button, and reboot your XBOX. Then go to next step and see if your shares appear. If not, your username and pass may not have been properly entered, try again ensuring you entered everything correctly)
9> Your PC's IP address should now appear e.g. smb://192.168.1.2/, click it
10> You should now see all your shares, either click a specific share or click OK
11> Now you can change the name of the share, set content, or just click OK
12> Your share should now appear in the Videos section

end user interface walk-thru

=====================================================================

For those familiar on how to edit xml's, you could also set your share up that way. Example shown below, more info can also be read in the manual. If you're not familiar with editing XML's, then stick to creating a share through the user interface as explained above.

FTP into your XBMC UserData folder and edit the sources.xml file by adding the following to the <video> section:

QUOTE
<source>
<name>My Win7 Share</name>
<path pathversion="1">smb://AccountName:Password@Computer_IP_Address/</path>
</source>

Remember to change the pathversion smb path with your computer IP, Computer user account name and password.

As an example, here's how my <video> section looks in sources.xml after I've added my share <source>

QUOTE
<video>
<default pathversion="1"></default>
<source>
<name>Win7 Share</name>
<path pathversion="1">smb://JohnSmith:password@192.168.1.2/</path>
</source>
</video>

Edited by xboxbox451, 09 November 2009 - 06:38 AM.


#2 frigusoris

frigusoris

    X-S Member

  • Members
  • Pip
  • 81 posts
  • Location:The Great White North
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 25 November 2009 - 08:27 PM

I have been looking for an answer to that problem for AGES. Thank you soo much, I'm going to try this right now! beerchug.gif Cheers!

#3 tracer2009

tracer2009

    X-S Young Member

  • Members
  • Pip
  • 48 posts

Posted 06 December 2009 - 11:38 PM

xbmc smb share worked almost straight away for me when i upgraded to windows 7 but i upgraded my friends pc to windows 7 and it had problems when trying to add a shared location, always asking for a username and password but not accepting anything

anyway i got it working, basically went to advanced sharing settings and turned off password protection and also enabled file sharing option for 40- or 56- bit encryption.

not sure if it was one or the other or a combination of both settings but its working! and may help someone with similar problems....?

#4 massjohn420

massjohn420

    X-S Young Member

  • Members
  • Pip
  • 40 posts

Posted 28 April 2010 - 03:46 PM

arghh... I have been having this same SMB problem... I couldn't find Windows Live assistant in my uninstall programs... and I tried your workaround # 2, and I am not quite sure what username and password I need... when you say windaows account password... you mean the username and password that you need when you first boot up you pc, right? My problem really isn't with the videos though... because I nave my videos on my external... and it seems to work fine with that... My music on the other hand is on my pc and that is where I am having trouble... and I want to refrain from putting my music on my hard drive... thanx in advance


#5 massjohn420

massjohn420

    X-S Young Member

  • Members
  • Pip
  • 40 posts

Posted 28 April 2010 - 04:00 PM

Got it... figured out workaround 2


#6 stainy

stainy

    X-S Enthusiast

  • Members
  • 19 posts

Posted 28 August 2010 - 10:06 AM

smb problems sad.gif

I have shares configured on the pc with xbox user.. as far as I can see everything is ok pc side.
When I configure the share on the xbox with the IP and username etc it says it cant find it..
If I add it anyway and try to connect the xbox hangs..

I`m pretty good with usernames/password accounts etc.. I`m not sure whats wrong.



#7 Bomb Bloke

Bomb Bloke

    X-S Transcendental

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPip
  • 6,568 posts
  • Gender:Male
  • Location:Tasmania (AU)
  • Xbox Version:v1.0
  • 360 version:none

Posted 29 August 2010 - 02:38 AM

On the PC, in the Network and Sharing Center, make sure network discovery is turned on (in addition to file and printer sharing, of course). Consider turning homegroups off (as XBMC can't join them - note that Windows 7 only uses these if it detects another Windows 7 box on the network, but no older versions (eg XP)).

You may also consider disabling password protected sharing. There's no point to having that on unless you're sharing your LAN.

#8 Heimdall

Heimdall

    X-S Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 5,749 posts
  • Location:UK
  • Xbox Version:v1.4
  • 360 version:v4.0 (jasper)

Posted 29 August 2010 - 02:51 AM

The latest XBMC (r30536 or later) includes a fix for the Windows Live Sign-in Assistant issue - see this post.

Edited by Heimdall, 29 August 2010 - 02:51 AM.


#9 johnnyboy4711

johnnyboy4711

    X-S Enthusiast

  • Members
  • 2 posts

Posted 16 October 2010 - 10:31 PM

Something still flocking my shares as it keeps loading and loading but nothing happens.
Eventually have to reboot xbox 1.
How to check if windows firewall give xbmc permissions and/or also 3rd party firewall what else could be stopping it?
After about 5 mins movie file started to playback but super laggy.
Please help.
Johnnyboy

Ps followed workaround #2

Edited by johnnyboy4711, 16 October 2010 - 10:32 PM.


#10 Topher5000

Topher5000

    X-S Young Member

  • Members
  • Pip
  • 59 posts

Posted 06 November 2010 - 01:39 AM

I've been running a real old version of XBMC & recently upgraded the computer with the media to Win7. I've tried workaround 2, but I can't get it to work. Is it because the computer doesn't have a password? I don't see Windows Live Sign-in Assistant in the program list & I've turned off the Windows firewall.

#11 Heimdall

Heimdall

    X-S Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 5,749 posts
  • Location:UK
  • Xbox Version:v1.4
  • 360 version:v4.0 (jasper)

Posted 06 November 2010 - 02:27 AM

Do what it says in the rest of this thread........

- Upgrade XBMC to the latest version (r30536 or later, the current version is r30707)
- Turn off Windows 7 homegroup

Edited by Heimdall, 06 November 2010 - 02:29 AM.


#12 ckshowtime

ckshowtime

    X-S Enthusiast

  • Members
  • 9 posts

Posted 13 January 2011 - 11:31 PM

I hate to bring up what appears to be an old topic....but I feel like I have read every message board and tried everything on the internet.

I have my original Xbox hooked into a wireless access point that connects to my network in my basement. My Xbox is soft-modded and uses Avalaunch as my dashboard. I can FTP into my Xbox using Flash FXP.

When I got everything hooked up the other night I could see my PC through the SMB Workgroup option, but it kept prompting for a username and password. I had (and still have) password protected sharing turned off. My shared drive doesn't have a lock showing on it.

I am at a loss for what to try next, this is very frustrating and for some reason I just keep coming back for more punishment. If there is anymore information I can provide so you can help, please let me know.

Thanks.

Edited by ckshowtime, 13 January 2011 - 11:32 PM.


#13 Bomb Bloke

Bomb Bloke

    X-S Transcendental

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPip
  • 6,568 posts
  • Gender:Male
  • Location:Tasmania (AU)
  • Xbox Version:v1.0
  • 360 version:none

Posted 14 January 2011 - 12:53 AM

The lock symbol Windows 7 likes to put on some folders simply means that the System account has permissions set on it. Beats me as to why Microsoft feels that fact is worthy of such a highlight.

Even if password protected sharing is turned off, the Everyone group must still have access to your shared folders in order for them to be accessed anonymously.

#14 ckshowtime

ckshowtime

    X-S Enthusiast

  • Members
  • 9 posts

Posted 14 January 2011 - 04:42 AM

So....my EVERYONE has access to the folder. I have even added my Xbox user to the permissions just in case.

Here are a few other things I have done, obviously not in any particular order. My brain is about fried from this
On PC:
- Turned ON network discovery
- Media straming is ON
- Enabled file sharing for devices that use 40 or 56 bit encryption
- Turned OFF password protected sharing
- created the Xbox user with a password and without.
- enabled the guest account without a password, and turned it back off.
- turned OFF the Homegroup feature in Win 7.

On Xbox:
- made DHCP automatic
- entered IP address for the machine connecting to
- edited the SMB information, adding the Xbox user name/password or the Guest account when enabled

I can FTP into my Xbox by going to 192.168.1.105, I Can access all drives on my Xbox.

Xbox is still not seeing the SMB Workgroup. I am rambling...I don't remember having any of these problems with my Xbox + Avalaunch when I was on Win XP. Ever since I have went to Win 7 I have not been able to get this thing to work.

Edited by ckshowtime, 14 January 2011 - 04:46 AM.


#15 sow2

sow2

    X-S Enthusiast

  • Members
  • 1 posts

Posted 15 January 2011 - 02:20 AM

QUOTE(ckshowtime @ Jan 13 2011, 07:42 PM) View Post

So....my EVERYONE has access to the folder. I have even added my Xbox user to the permissions just in case.

Here are a few other things I have done, obviously not in any particular order. My brain is about fried from this
On PC:
- Turned ON network discovery
- Media straming is ON
- Enabled file sharing for devices that use 40 or 56 bit encryption
- Turned OFF password protected sharing
- created the Xbox user with a password and without.
- enabled the guest account without a password, and turned it back off.
- turned OFF the Homegroup feature in Win 7.

On Xbox:
- made DHCP automatic
- entered IP address for the machine connecting to
- edited the SMB information, adding the Xbox user name/password or the Guest account when enabled

I can FTP into my Xbox by going to 192.168.1.105, I Can access all drives on my Xbox.

Xbox is still not seeing the SMB Workgroup. I am rambling...I don't remember having any of these problems with my Xbox + Avalaunch when I was on Win XP. Ever since I have went to Win 7 I have not been able to get this thing to work.

I just ran into and solved this problem myself...

I believe your problem is the Security setup (right click the directory and choose properties). There are two things you have to do in order to properly share in Windows 7. The first is to enable/create the "Everyone" share in the Sharing tab. Read only permissions should be sufficient to allow XMBC to connect. Next (and this is the part nobody seems to talk about or recommend) you need to add Everyone again to the Security tab. Basic access (read&execute, list folder contents, and read) should be enough to get the job done.

Depending on the directory being shared, the everyone user name may already exist in the Security tab, but sometimes it doesn't. This is the reason why this sharing problem seems sporadic. It's definitely not obvious since a username/password prompt implies the sharing isn't setup properly, but it's actually the file/directory security that is the problem.

I hope this helps some people figure out their problem.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users