Jump to content


Photo

Can't Get Usb Drive To Work - First Time Softmoder


  • Please log in to reply
12 replies to this topic

#1 TravisT

TravisT

    X-S Enthusiast

  • Members
  • 4 posts

Posted 15 November 2009 - 06:45 AM

I've been fighting for two days now to get this thing to work, and I've tried everything. I have a slew of different tools downloaded (xplorer360, actionreplay 1.4, usbview, etc) and have read almost every tutorial out there. Seems simple, but it's just not working.

So far, I have disassembled a controller and added a female usb socket. This seems to be working. I am using a Lexar 1GB JumpDrive and can access the USB drive in the xbox dashboard and in xplorer360 and actionreplay.

The problem I'm having is that if I copy gamesaves from the xbox hard drive to the usb drive, I can't see them on the PC. If I copy the softmod games saves on the pc to the usb drive, when I move the usb drive to the xbox, the game saves aren't there. A couple times it shows blocks being used, but doesn't display the files on the drive.

I've tried various drives/cards that I had laying around, and none of them are working. What am I missing here?

The other weird thing is that if I personalize the MU in the xbox memory screen, I can see that change on action replay - it's just the game saves that don't show up either way.

I have giving up on this stuff (guess that's why I've been at it for 10-12 hrs combined now) but I don't know what I'm missing here. Can anyone point me in the right direction? I really want to get xbmc installed on this thing!

#2 TravisT

TravisT

    X-S Enthusiast

  • Members
  • 4 posts

Posted 16 November 2009 - 04:50 AM

Still banging my head against a wall...

Noticed one more thing that may be of importance. In AR (v1.40), if I transfer saves from the codejunkies.com column to the PC database, they don't show up in the Saves folder on my PC (although they do show up in the AR GUI. Also, when I move them to the USB drive, they don't show up on Xplorer360 either. BTW, I am running vista.

I saw in another tutorial on this site that you had to add the datelinfo.xbe file to each folder of the exploit saves - which I hadn't done. Problem is, I can't access the save files in windows explorer to get the datelinfo.xbe file! I'm almost giving up here...

Anyone want to ship me a xbox memory card with the gamesaves already loaded to it? I'm ready to burn every usb drive I have here!!!!

#3 TravisT

TravisT

    X-S Enthusiast

  • Members
  • 4 posts

Posted 16 November 2009 - 06:14 AM

Ok, so I found one last thumbdrive that I hadn't checked, and lo and behold.... it doesn't work either. Screen just flashes.

I realized why no saves were showing up in the saves directory. Stupid vista only lets administrators save to program files directories. Changed the folder permissions to allow anyone to write to the saves folder, and things are working better now. Online saves now show up when I transfer them over to PC.

I tried copying the SplinterCell softmod_profile from the online saves over to the hard drive and the thumd drive. All looked good so far. I then opened xplorer360 to see if I could see anything there. I saw three files, although they were not readable (nothing but special characters, etc in the file name block). I decided to give it a shot anyway. No dice in the xbox. Still no files showing up under controller.

So from here I try formatting the thumbdrive in the PC again to FAT32. Put back in the xbox, turn on, go to memory, and get the error message saying it's erasing the card. Good. Before removing the card, I go to hard drive and copy a game save over to the USB drive. Copy failed.

I've had this problem several times, but not consistantly, over the (well I've lost count of the hours I spent on this) hours I've been working this. Sometimes when I insert the USB drive, it says damaged, others it just works like it's supposed to. I have successfully copied gamesaves to this usb drive and removed and reinserted the drive and the saves were still there. Several times I have copied one game save over and when I try to copy a second one I get a copy failed.

Although my thumbdrive is listed on the compatible hardware list, could I be doing something wrong still? I feel like I'm getting closer, but I'm hitting a wall now.

The offer still stands for someone to send a xbox mu with the softmod files on it. I'll pay shipping both ways and make it worth your while to help me out!!! (otherwise any help with the @!&* USB drive would be great!)

#4 savageinjun

savageinjun

    X-S Enthusiast

  • Members
  • 11 posts

Posted 19 November 2009 - 02:06 PM

comp.gif hey there...well...i'm in the same boat as you...i think....anyhoo...i've done everything that the toot has asked me to do..i still cannot get the thunbdrive to be recognized by A.R. at 1 stage i thought i had it but it wouldn't let me copy anything over as the blocks were at zero...no storage..on right click in memcard area, it asked if i wanted to format, refresh and forgot the otherone... but i did the format and it worked fine...gave me alot of blocks to write to...exceeeeept..when i went to save the mech assault/linux install...it went nuts....mass title copying and then it crashed...i'm using a kingston 4g usb...i bought a cheap ass 1 gig stick and that just shows up as broken or damaged...it's file system was FAT...no x or 16 or 32 or anythin...just FAT (no harm intended to our o/w friends...)...formatted it to fat32 and put it onto the xbox(orig) and still came up as broken...so.....where oh where did it go bad.....i don't want to buy any other usb's as ii have a few but nothing under 4 except the 1 g which i now have given away...i don't know anyone with a modded xbox to copy to as i have homebrewed up a usb/xbox cable..it workes a treat...i even put some saves onto the usb but A.R still won't recognize the damn thing....will let you know after i lose it....lol...keep on testing. smile.gif

#5 TravisT

TravisT

    X-S Enthusiast

  • Members
  • 4 posts

Posted 19 November 2009 - 04:30 PM

Yea, the times that I have got mine to work, my usb drive shows 50000+ blocks, and I've even been successful in writing one game save to the usb drive. Seems the second time I try it gives me a "copy failed" message and doesn't like anything after that. I'm looking into just buying an Action Replay setup from fleabay to do this with. I'll post on here if I figure out anything else along the way.

Comments/suggestions welcome...

#6 savageinjun

savageinjun

    X-S Enthusiast

  • Members
  • 11 posts

Posted 19 November 2009 - 11:20 PM

well it would seem that as long as the blocks to be written are no more than 10...it will not fail. at least thats what happens for mine. when i try to copy a save from xbox to usb , it goes fine if its under 10 blocks but when i try to move 1 that is 69 blocks it goes about halfway then says failed to write...i take out usb then plug it back in and the game save is there but corrupt. i'm a firm believer now that the usb sticks to have are the early models that are under 512 mb and WHERE OH WHERE??? can they be found at a cheap price (if the bastards still stock them, i was told that they will still want that 40$ for it...f*ck that..here's 2 bucks...lol). i really don't want to buy off fleabay if that or craigslist or wherever has them posted as i don't know if i'm getting a working usb or not. and i don't want secondhand sh*t either....gonna buy 1 more then will have to search out someone with a modded xbox from one of the shops that do mods....willing to give em 10 bucks for the usb exchange..(modded save to usb). you know...thats not a bad idea...buy cheap usb's...put the modded saves on them and sell them on ebay....i've not seen anything like that as yet....i want 10% profits lol...

*edit*... well i just read another post that some dude had probs with...it seems that it really comes down to what usb you are using...i'm off to get a lexar 2gb drive (didn't say if it was a jump drive or not....) the post title was about him/her spending 5hrs trying to mod. will let you know how i went. wink.gif

Edited by savageinjun, 19 November 2009 - 11:35 PM.


#7 savageinjun

savageinjun

    X-S Enthusiast

  • Members
  • 11 posts

Posted 26 November 2009 - 02:35 AM

well..i'm gonna try one of the autoinstallers..maybe slayers....have about 3 of them. gonna try the hotswap method. and yes ..will be following the toot to the letter.i really don't care if i brick it as they are cheap as chips to buy nowadays....35$ at the pawnshop. or 25 bucks at a garage sale....i have a version 1.1 and a 1.6( i believe) and the latter will be the one that stays stock....i cannot get my hands on a working usb drive...i have a kingston data traveller 4gb that is recognised in the xbox ( it first says there is a prob with it sometimes and other times it shows up..it doesnt say there is a prob and has been erased(formatted)..it just shows up and i am able to copy a few saves to it so long as the files are very small...anything over 20-30 blocks and it fails) ...when it shows up in AR(not always)...it shows as full with no blocks available and when it is formatted by AR.. it goes nuts and it crashes with the 'xbox powersaves mfc application..blahblahblah'...
btw..i have done all steps as-per-se...to the T if you will, but still does not work. trying it on the stock 1.1 box that has been 'refurbished' from eb games...i'm beginning to think that something has been done to it as it has been 'messed with' by them. (how else are you gonna get an xbox with nothing on the hard drive..no saves ..nada...sfa...??)....sooooo..OFF TO THE RACES BOYS!!!! muhaha.gif

#8 savageinjun

savageinjun

    X-S Enthusiast

  • Members
  • 11 posts

Posted 26 November 2009 - 01:15 PM

i realise that i might have hijacked his thread but was hoping to exchange ideas on the usb method...it didn't work for me and i really don't need about 7 usb's ranging between the 2 and 4 variety.. blink.gif ..woulda been 8 but gave a 1 gb stick away that was from officeworks..it was in the shape of a pin..took it apart and the thing is so tiny..its basically the bit you plug in!!!???.... tongue.gif read this fully before you try this method out. huh.gif wtf you talkin' bout willis??..... just read it and then try it. cool.gif oh yeah...you'll need Xplorer360 to inject the files in....google for it or pm me and i'll point you in the right direction...put 360 in the header or i wont take notice of the pm....

well i hot-swapped the hard-drive of the xbox and this is how i did it...before i started anything i took off the side panel of the poot'r, the top off the xbox...and before i turned either of them on i made sure that the cables i was going to swap were accessible..the xbox CAN be pulled off and put back on without removing it from the tray(the 1.6 version refused to boot up when i did remove it where as the 1.1 version was fine). the xbox MUST be beside the poot'r for the cable to reach the xbox hard-drive....ok now..i fired up the poot'r let it do its thang..done. plugged the video cable(doesn't need to be attached to the television) and the controller in...and yeah...d'uhh the power too.. rolleyes.gif .lol. rolleyes.gif ...fired up the xbox and let it do its thAng for about a minute( remember, no telly to see what's happening...). on the computer..i started up Xplorer360 ...i NOW take the cable off the dvd/cd-rom drive( the master plug..the top plug if there are 2 on it) and also took off the cable from the xbox hard-drive..being careful NOT to jiggle it to much as this will freeze the hard-drive(thats what i've been told so i'm not going to question that as it might happen and i'll have to start all over again..)..it might... anyhooo...once the SWAP is successful i opened up device manager and refreshed it so that it will recognise the hard-drive...you might have to make sure its plugged in firmly as it might not recognise it first time around...once its been recognised and drivers installed for it we go over to the open prog...click the drive tab and open image or hard-drive/memcard....give it a min and then it will open up 4 partitions...i looked for the ones with the cache, tdata, and udata folders..i opened udata folder...now..go to where you have the mechassault_run linux.zip file is..unzip it and go to the udata folder..it will have this foldername---> 4d530017 ...take that folder and drag and drop it into the right-hand pane in the Xplorer360 window in the udata folder ...it will have the same files there ( with different number file names...those are your game saves...) let it inject the files....if it doesnt start after 30 seconds...go to the device manager window and refresh it...it will start the inject files procedure...after the files were injected...( sounds like a junkie ..eh?)...hit the device tab and close the files...then exit the program.
DO NOT TURN OFF THE XBOX !!! you will have a paperweight if you do....remove the cable from the xbox and attach it back to your pooter's dvd/cd-rom drive...then re-attach the cable back to xbox hard-drive..make sure that it is on tight...not loose as the start-up ring will just flash red and yellow... on securely??? good..NOW you can turn off the xbox.
hook it back up to the t.v to test it out. if all went well..VIOLA!!! you have soft-modded your xbox with the hotswap method. you can now use SlaYer's EvoX Auto-Installer 2.7...this will further update your modded xbox..so... it seems daunting at first but once you've done it...you'll think..gee??? there's really nothing to it.
sooo...all apologies for hijacking the thread..i honestly didn't mean too..it just happened....i just wanted to be friends... wink.gif

Edited by savageinjun, 26 November 2009 - 01:20 PM.


#9 HiTMaN-239

HiTMaN-239

    X-S Young Member

  • Members
  • Pip
  • 57 posts

Posted 07 December 2009 - 07:55 AM

QUOTE(savageinjun @ Nov 26 2009, 06:15 AM) View Post

i realise that i might have hijacked his thread but was hoping to exchange ideas on the usb method...it didn't work for me and i really don't need about 7 usb's ranging between the 2 and 4 variety.. blink.gif ..woulda been 8 but gave a 1 gb stick away that was from officeworks..it was in the shape of a pin..took it apart and the thing is so tiny..its basically the bit you plug in!!!???.... tongue.gif read this fully before you try this method out. huh.gif wtf you talkin' bout willis??..... just read it and then try it. cool.gif oh yeah...you'll need Xplorer360 to inject the files in....google for it or pm me and i'll point you in the right direction...put 360 in the header or i wont take notice of the pm....

well i hot-swapped the hard-drive of the xbox and this is how i did it...before i started anything i took off the side panel of the poot'r, the top off the xbox...and before i turned either of them on i made sure that the cables i was going to swap were accessible..the xbox CAN be pulled off and put back on without removing it from the tray(the 1.6 version refused to boot up when i did remove it where as the 1.1 version was fine). the xbox MUST be beside the poot'r for the cable to reach the xbox hard-drive....ok now..i fired up the poot'r let it do its thang..done. plugged the video cable(doesn't need to be attached to the television) and the controller in...and yeah...d'uhh the power too.. rolleyes.gif .lol. rolleyes.gif ...fired up the xbox and let it do its thAng for about a minute( remember, no telly to see what's happening...). on the computer..i started up Xplorer360 ...i NOW take the cable off the dvd/cd-rom drive( the master plug..the top plug if there are 2 on it) and also took off the cable from the xbox hard-drive..being careful NOT to jiggle it to much as this will freeze the hard-drive(thats what i've been told so i'm not going to question that as it might happen and i'll have to start all over again..)..it might... anyhooo...once the SWAP is successful i opened up device manager and refreshed it so that it will recognise the hard-drive...you might have to make sure its plugged in firmly as it might not recognise it first time around...once its been recognised and drivers installed for it we go over to the open prog...click the drive tab and open image or hard-drive/memcard....give it a min and then it will open up 4 partitions...i looked for the ones with the cache, tdata, and udata folders..i opened udata folder...now..go to where you have the mechassault_run linux.zip file is..unzip it and go to the udata folder..it will have this foldername---> 4d530017 ...take that folder and drag and drop it into the right-hand pane in the Xplorer360 window in the udata folder ...it will have the same files there ( with different number file names...those are your game saves...) let it inject the files....if it doesnt start after 30 seconds...go to the device manager window and refresh it...it will start the inject files procedure...after the files were injected...( sounds like a junkie ..eh?)...hit the device tab and close the files...then exit the program.
DO NOT TURN OFF THE XBOX !!! you will have a paperweight if you do....remove the cable from the xbox and attach it back to your pooter's dvd/cd-rom drive...then re-attach the cable back to xbox hard-drive..make sure that it is on tight...not loose as the start-up ring will just flash red and yellow... on securely??? good..NOW you can turn off the xbox.
hook it back up to the t.v to test it out. if all went well..VIOLA!!! you have soft-modded your xbox with the hotswap method. you can now use SlaYer's EvoX Auto-Installer 2.7...this will further update your modded xbox..so... it seems daunting at first but once you've done it...you'll think..gee??? there's really nothing to it.
sooo...all apologies for hijacking the thread..i honestly didn't mean too..it just happened....i just wanted to be friends... wink.gif


I have done the USB method easily before, too tired to go through your posts to see if you still need help, if you do post here again, I should be able to guide you through it.

Cheers

#10 kolosus

kolosus

    X-S Young Member

  • Members
  • Pip
  • 49 posts
  • Xbox Version:v1.0
  • 360 version:none

Posted 09 December 2009 - 05:58 AM

@ savageinjun, TravisT

Where do you live? Have either of you tried a 1 gb mp3 player/usb stick that you plug directly into a computer? Most of those should work. I've used a coby branded one. I partitioned it with gparted. There was only one partition but it was a 16mb block. There were no other partitions on the drive. After transferring the gamesave I repartitioned the drive/mp3 player back to one big block of fat16.

The mp3 player survived the experience. But that's a side note. Since I'd decided that I was going to chalk the cost of the player as a learning experience. But it worked. I now have 2 xboxes that I have the gamesaves on. But alas, only one set plugs.

I think the more generic the drive the better it'll work. You really need a drive that identifies itself to the computer as a mass storage device and not something exotic.

gparted is free. GPL. My two xboxes are a 1.0 and a 1.6.

Unfortunately, I found out that a xbox by itself (no power no composite) is not worth much. I have two xboxes but one set or cords... I found out that, if you look, its cheaper to get another xbox, including adapter/composite, than it is to get the adapter/composite by itself.

1.0 k4034, d5960 samsung, stock hdd.
1.6 k5838' d5960 thompson, 160gb hdd.

Its late here... If you have questions, ask. But I gotta go to sleep now... Best $40 I ever spent.. zzz


#11 2 Bunny

2 Bunny

    X-S X-perience

  • Members
  • PipPip
  • 323 posts
  • Location:home, school, or on vacation
  • Xbox Version:v1.0
  • 360 version:none

Posted 09 December 2009 - 05:29 PM

QUOTE(kolosus @ Dec 8 2009, 11:58 PM) View Post
@ savageinjun, TravisT

Where do you live? Have either of you tried a 1 gb mp3 player/usb stick that you plug directly into a computer? Most of those should work. I've used a coby branded one. I partitioned it with gparted. There was only one partition but it was a 16mb block. There were no other partitions on the drive. After transferring the gamesave I repartitioned the drive/mp3 player back to one big block of fat16.

The mp3 player survived the experience. But that's a side note. Since I'd decided that I was going to chalk the cost of the player as a learning experience. But it worked. I now have 2 xboxes that I have the gamesaves on. But alas, only one set plugs.

I think the more generic the drive the better it'll work. You really need a drive that identifies itself to the computer as a mass storage device and not something exotic.

gparted is free. GPL. My two xboxes are a 1.0 and a 1.6.

Unfortunately, I found out that a xbox by itself (no power no composite) is not worth much. I have two xboxes but one set or cords... I found out that, if you look, its cheaper to get another xbox, including adapter/composite, than it is to get the adapter/composite by itself.

1.0 k4034, d5960 samsung, stock hdd.
1.6 k5838' d5960 thompson, 160gb hdd.

Its late here... If you have questions, ask. But I gotta go to sleep now... Best $40 I ever spent.. zzz


That is right. Internal power supplies for the xBox are around twenty dollars on eBay (it is better off fixing yours if possible, this board, the xBox Scene may be able to help with that). A composite cable is probably relatively cheap though - usually a dollar, and maybe a couple for shipping.


As for the usb drive thing: I know, a lot of usb drives simply will not work. I had a teensy tiny 128MB one that refused to work, but a good sturdy 256MB Memorex that did work. What I did the very first time I did a gamesave exploit, was I found a buddy with an already modified box, FTPd over the save to that, used its MS dashboard to copy the save to his memory card, and then plugged that into my box and got it that way.
As it looks like you already figured out, its not anything you are doing wrong, its just that the machine just will not format certain drives. An idea to ask about though: if you can manually format the drive to FATX from the computer or something smile.gif .

Good Luck.

- 2 Bunny


#12 Fox9p3400

Fox9p3400

    X-S Young Member

  • Members
  • Pip
  • 58 posts
  • Xbox Version:v1.0
  • 360 version:v4.0 (jasper)

Posted 27 December 2009 - 10:08 PM

get a mu from gamestop and solder up usb cable...

#13 JordanQ

JordanQ

    X-S Enthusiast

  • Members
  • 26 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 31 December 2009 - 10:48 AM

/\ lol i know, simple as that.

s'what i did..




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users