Jump to content


Photo

Xlink Kai + Mw2 Always "unable To Connect To Host"


  • Please log in to reply
4 replies to this topic

#1 legssmit

legssmit

    X-S Young Member

  • Members
  • Pip
  • 44 posts

Posted 28 November 2009 - 12:13 PM

Hi guys,

Im trying to get XLink Kai to work with MW2. I think Ive got everything setup correctly. I changed my Xbox 360s MAC address and Xlink Kai recognizes it correctly. Ive opened up the correct ports for Xlink and it says Network: Reachable.

When I get in an arena in Xlink, most of the time it shows ping 31 ms. This should be just okay right ?
The game shows up in MW2 system link, but when I try to join I always get:

Attempting connection 1...2...3...4..ERROR:
Unable to connect to Host

The thing is, Ive blocked my Xbox 360s MAC address from the internet (so it doesnt get banned from xbox live)....but this isnt blocking it right? cause my xbox can still connect to the PC with xlink kai correctly.

Any help would be awesome!
Gr.

Edited by legssmit, 28 November 2009 - 12:13 PM.


#2 me2611

me2611

    X-S Member

  • Members
  • Pip
  • 120 posts

Posted 29 November 2009 - 05:53 PM

Just disable XBL sign in on your console settings - family settings etc. When trying to connect just keep trying. You only need your ping to dip to 30 or under for a second to join the room. Also make sure you have no torrents or you tube vids web browsers running etc. Also use the Xlinks Standard GUI and not the web interface.

Enable PAT in the web config settings should help also.


GL

Edited by me2611, 29 November 2009 - 05:59 PM.


#3 twisted89

twisted89

    X-S Member

  • Members
  • Pip
  • 99 posts

Posted 17 January 2010 - 11:35 PM

I was having the exact same problem and it definitly wasnt the ping as i was trying to connect to a friend with 24 ping. Turned out in the end it was his zone alarm firewall soon as he tuned it off i connected straight away.

#4 brain27

brain27

    X-S Member

  • Members
  • Pip
  • 104 posts
  • Location:UK>LONDON
  • Interests:like hacking and making things.
  • Xbox Version:none
  • 360 version:v4.0 (jasper)

Posted 05 May 2010 - 04:13 PM

I have the exact same problem.
I can see the game when i go on join game, but when click connect it always says
awaiting connection 1...2...3...4...5 error unable to connect to host.
On xlink kai my ping is always 31ms sometimes 46 but it rarely drops blow 31ms.
does anyone have a solution?

#5 _GhOsT_

_GhOsT_

    X-S Genius

  • Members
  • PipPipPipPip
  • 970 posts
  • Location:
  • Xbox Version:v1.6
  • 360 version:v4.0 (jasper)

Posted 06 May 2010 - 12:25 AM

if i do recall
some games have the programming in the game set the disconnect point for network play at 7ms
so MW2 could have a hit and miss with being able to connect

Edited by _GhOsT_, 06 May 2010 - 12:27 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users