Jump to content


Photo

Ps3 Usb Ports Broken?


  • Please log in to reply
5 replies to this topic

#1 PRiME2008

PRiME2008

    X-S Young Member

  • Members
  • Pip
  • 51 posts

Posted 20 January 2010 - 02:30 AM

Well I have a 60GB PS3 here that has sometimes working USB ports. I do not know exactly the issue but it appears that ports are not getting any power (according to multimeter) But when I striped it down and rebuilt it the ports worked that time.

So I have a spare PS3 mobo and was wondering the first approach I should do, perhaps check some caps/resist near the USB plugs (which are not bent btw).

Any suggestions would be helpful, maybe someone has resolved this odd issue before. Hoping its not firmware related.

#2 PRiME2008

PRiME2008

    X-S Young Member

  • Members
  • Pip
  • 51 posts

Posted 20 January 2010 - 03:48 AM

May be the 5v Line from the PSU. Would explain a bit. I am testing with a different mobo atm (same model etc) but the BR-Drive may not accept this different motherboard (once updated, dialup speed). But this may help some people in future whom loose usb port power.

#3 PRiME2008

PRiME2008

    X-S Young Member

  • Members
  • Pip
  • 51 posts

Posted 20 January 2010 - 09:01 AM

Turns out it was a cut line on the board. Fixed and going now. Maybe for anyone else getting mysterious no power to usb, check the circuits around the port area and its control chip (follow the tracks)).

#4 Debdasmptr

Debdasmptr

    X-S Enthusiast

  • Members
  • 2 posts

Posted 13 April 2010 - 04:49 AM

Yaa it happens in these types of item, sometimes if insert any jack improperly it affects the port. And sometimes it also also disconnected to get power supply, so check it out and it will be better to put a new one.

Edited by RDC, 27 May 2010 - 02:57 AM.


#5 coneseth

coneseth

    X-S Enthusiast

  • Members
  • 3 posts

Posted 14 June 2011 - 09:49 PM

I have a 60 GB fat model and it fell off the entertainment center with all the plugs still connected. Hdmi and usb ports were damaged and I thought I would have to buy a new system. I searched alittle on the web and found a place called www.videogame911.com. They fixed the broken ports and even gave it a good cleaning. It was fast too.

#6 BengaSon

BengaSon

    X-S Enthusiast

  • Members
  • 2 posts

Posted 23 February 2012 - 07:27 AM

QUOTE(PRiME2008 @ Jan 20 2010, 03:48 AM)  

May be the 5v Line from the PSU. Would explain a bit. I am testing with a different mobo atm (same model etc) but the BR-Drive may not accept this different motherboard (once updated, dialup speed). But this may help some people in future whom loose usb port power.

jailbreak 2 buy jb2 dongle jb2 true blue





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users