Jump to content


Photo

Help With Installing Ubuntu


  • Please log in to reply
5 replies to this topic

#1 slymambo1234

slymambo1234

    X-S Member

  • Members
  • Pip
  • 82 posts

Posted 25 February 2010 - 10:46 AM

Im trying to install ubuntu on my 360 and im following the guide on here but ive got to this bit and the server doesnt appear to be working?

sudo su
wget http://mydedibox.fr/...buntuinstall.sh
sh ./ubuntuinstall.sh

Anyone know if theres another server working?

Cheers

Slymambo1234

#2 dervboy

dervboy

    X-S Enthusiast

  • Members
  • 17 posts

Posted 25 February 2010 - 10:52 AM

Hey, that never worked for me, so I managed to edit the .sh file using some other online server. here is that file I used rmemeber to rename it to .sh

CODE

#!/bin/bash
dd if=/dev/zero of=/dev/sda bs=512 count=1
sfdisk /dev/sda << EOF
,124,S
,,L
EOF
mkfs.ext3 /dev/sda2
mkswap /dev/sda1
sync; sync; sync
swapon /dev/sda1
mkdir /mnt/ubuntu
mount /dev/sda2 /mnt/ubuntu
cd /mnt/ubuntu
mkdir /mnt/ubuntu/work
cd /mnt/ubuntu/work
wget http://ubuntu.interlegis.gov.br/ubuntu/pool/main/d/debootstrap/debootstrap_1.0.3build1_all.deb
ar -xf debootstrap_1.0.3build1_all.deb
cd /mnt/ubuntu
zcat < /mnt/ubuntu/work/data.tar.gz | tar xv
export DEBOOTSTRAP_DIR=/mnt/ubuntu/usr/lib/debootstrap
export PATH=$PATH:/mnt/ubuntu/usr/sbin
debootstrap --arch powerpc gutsy /mnt/ubuntu http://pub.vse.cz/OS/Linux/Ubuntu/
echo Xenon > /mnt/ubuntu/etc/hostname
cat > /mnt/ubuntu/etc/fstab << EOF
/dev/sda2     /          ext3     defaults   0   0
/dev/sda1     none    swap    sw           0   0
EOF
cat > /mnt/ubuntu/etc/network/interfaces << EOF
iface lo inet loopback
auto lo
auto eth0
iface eth0 inet dhcp
EOF
cat > /mnt/ubuntu/etc/apt/sources.list << EOF
deb http://pub.vse.cz/OS/Linux/Ubuntu/ gutsy main restricted universe multiverse
EOF
cp /mnt/ubuntu/root/.bashrc /mnt/ubuntu/root/.bashrc.orginal
cat >> /mnt/ubuntu/root/.bashrc << EOF
passwd
mkdir /lib/modules/2.6.21.1
touch /lib/modules/2.6.21.1/modules.dep
apt-get update
apt-get install ntp wget -y --force-yes
aptitude install ubuntu-desktop -y
echo "AVAHI_DAEMON_START=0" > /etc/default/avahi-daemon
/etc/init.d/networking restart
cd /usr/lib/xorg/modules/drivers/
wget http://home.comcast.net/~ssmurf/xenosfb_drv.so
cd /etc/X11/
wget http://home.comcast.net/~ssmurf/ubuntu.conf
mv ubuntu.conf xorg.conf
cd /usr/lib/xorg/modules/linux/
mv libfbdevhw.so libfbdevhw.so.bk
wget http://home.comcast.net/~ssmurf/libfbdevhw.so
rm -r -f /work/
echo "" > /etc/gdm/gdm.conf-custom
sed -i 's/AllowRoot=false/AllowRoot=true/' /etc/gdm/gdm.conf
rm /root/.bashrc
mv /root/.bashrc.orginal /root/.bashrc
/etc/init.d/gdm start
EOF
echo "Base installation completed."
echo "To finish the installation. Reboot then load the sda2 bootloader CD."


#3 slymambo1234

slymambo1234

    X-S Member

  • Members
  • Pip
  • 82 posts

Posted 25 February 2010 - 10:55 AM

Sorry im a rite noob when it comes to linux. how do i use this?

Cheers

#4 jigglywiggly

jigglywiggly

    X-S Member

  • Members
  • Pip
  • 85 posts

Posted 28 February 2010 - 06:25 AM

I just skimmed over this thread, but I am sure he just means create a new file like
hellolinux.sh

Then in that paste the contents of what he wrote into that.

Also if for whatever reason you can't transfer the file over, you could type it all out(oh lawdy)
by doing
vi hellolinux.sh

Then write it in there. (I assume you have used vi before? If not eh)

#5 juggahax0r

juggahax0r

    X-S Expert

  • Members
  • PipPipPip
  • 603 posts
  • Location:Dayton, OH
  • Xbox Version:none
  • 360 version:v5.0 (360S - trinity)

Posted 27 March 2010 - 04:08 AM

what is the password for the gentoo Live disc


#6 Me9a

Me9a

    X-S Enthusiast

  • Members
  • 18 posts

Posted 27 March 2010 - 02:28 PM

password no idea for me it worked to open an terminal and type in

"Sudo -s" after that you have root rights




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users