Jump to content


Photo

Nandpro Debug Logs Oh And Lpt At 100%cpu?


  • Please log in to reply
7 replies to this topic

#1 ddsdavey

ddsdavey

    X-S X-perience

  • Members
  • PipPip
  • 328 posts
  • Xbox Version:none
  • 360 version:v4.0 (jasper)

Posted 26 February 2010 - 08:28 AM

Is there a command for reproducing a debug log from an older,already read Nand rather than just the last Nand read?
Also ive now got a usb r/w (cheers Thwack,works great biggrin.gif ) and Nandpro uses a fraction of my Pcs cpu yet LPT was ALWAYS 100% regardless of the pc used?
Obviously now im using USB its not an issue but just curious is all or is it just me? I think the first moment you see that Nand reader count through them blocks with usb is a beautiful moment to be cherished,friggin awesome (sorry late to the party etc but meh!).

#2 Martinchris23

Martinchris23

    X-S Messiah

  • Members
  • PipPipPipPipPipPipPip
  • 3,900 posts
  • Location:Scotland, UK
  • Xbox Version:v1.6
  • 360 version:v4.0 (jasper)

Posted 26 February 2010 - 09:51 AM

QUOTE(ddsdavey @ Feb 26 2010, 07:28 AM) View Post

Is there a command for reproducing a debug log from an older,already read Nand rather than just the last Nand read?
Also ive now got a usb r/w (cheers Thwack,works great biggrin.gif ) and Nandpro uses a fraction of my Pcs cpu yet LPT was ALWAYS 100% regardless of the pc used?
Obviously now im using USB its not an issue but just curious is all or is it just me? I think the first moment you see that Nand reader count through them blocks with usb is a beautiful moment to be cherished,friggin awesome (sorry late to the party etc but meh!).


LPT SPI flashing is extremely inefficient but you shouldn't have had 100% CPU usage - this points to a driver/Operating System issue. USB R/W is fantastic and there's no way I could offer the services I do without it smile.gifsmile.gif

#3 thwack

thwack

    X-S Freak

  • Last Chance
  • PipPipPipPipPip
  • 1,334 posts
  • Location:Yorkshire at heart.....
  • Xbox Version:unk
  • 360 version:unknown

Posted 26 February 2010 - 10:16 AM

Glad you like it smile.gif I reckon that over LPT as MartinChris said, it's the OS - possibly continuously polling the LPT port? Combination of motherboard and XP.....

And yep - seeing those blocks dash by quicker than me at a bar when it's my turn to buy a round is great smile.gif


#4 ddsdavey

ddsdavey

    X-S X-perience

  • Members
  • PipPip
  • 328 posts
  • Xbox Version:none
  • 360 version:v4.0 (jasper)

Posted 26 February 2010 - 01:07 PM

Just out of interest how long does it take you guys to dump a 512,just curious is all.
Oh and them old debug logs etc????

#5 Martinchris23

Martinchris23

    X-S Messiah

  • Members
  • PipPipPipPipPipPipPip
  • 3,900 posts
  • Location:Scotland, UK
  • Xbox Version:v1.6
  • 360 version:v4.0 (jasper)

Posted 26 February 2010 - 02:25 PM

QUOTE(ddsdavey @ Feb 26 2010, 12:07 PM) View Post

Just out of interest how long does it take you guys to dump a 512,just curious is all.
Oh and them old debug logs etc????


Well you only need to dump the first 64MB so..

nandpro.exe usb: -r512 orig.bin 0 1000

Takes about 10 mins smile.gif

#6 thwack

thwack

    X-S Freak

  • Last Chance
  • PipPipPipPipPip
  • 1,334 posts
  • Location:Yorkshire at heart.....
  • Xbox Version:unk
  • 360 version:unknown

Posted 26 February 2010 - 03:35 PM

As for the debug log - default is the last dump sadly - guess you could edit NandPro to record more?

#7 ddsdavey

ddsdavey

    X-S X-perience

  • Members
  • PipPip
  • 328 posts
  • Xbox Version:none
  • 360 version:v4.0 (jasper)

Posted 05 March 2010 - 01:00 PM

Me? Coding? no Thwack im afraid i still have partial human genetics.Im not full bred MARTIAN like you clever dudes!

#8 Martinchris23

Martinchris23

    X-S Messiah

  • Members
  • PipPipPipPipPipPipPip
  • 3,900 posts
  • Location:Scotland, UK
  • Xbox Version:v1.6
  • 360 version:v4.0 (jasper)

Posted 05 March 2010 - 03:06 PM

Are the source files available then?

In the absence of source files, just create a batch file called nand-pro.cmd (or similar) and copy/paste this content:

CODE
@echo off
nandpro.exe %1 %2 %3 %4 %5 %6 %7 %8 %9
IF EXIST debuglog.txt. (rename debuglog.txt debuglog_%date:/=-%_%time::=_%.txt.) ELSE echo debuglog.txt missing!



It's pretty basic but should do the job for the time being. You then just use 'nand-pro.cmd' instead of 'nandpro.exe' smile.gif

Edited by Martinchris23, 05 March 2010 - 04:00 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users