Jump to content


Photo

Nandpro Io Patcher


  • Please log in to reply
19 replies to this topic

#1 Ethan0026

Ethan0026

    X-S Enthusiast

  • Members
  • 11 posts

Posted 20 April 2010 - 08:18 AM

Hi !

It's now possible to use a PCI card or what you want !! I have created a program to change nandpro ports and it work pretty well !! You just have to remove resistors on the lpt connector to make it work beacause pci card doesn't deliver much power.

NandPro IO Patcher by Ethan0026

IPB Image

Download : http://www.megaupload.com/?d=3JGZJ7SQ


sry for my english i'm a french guy



#2 Siilentone

Siilentone

    X-S Member

  • Members
  • Pip
  • 75 posts
  • Xbox Version:unk
  • 360 version:v1 (xenon)

Posted 20 April 2010 - 01:15 PM

Very nice post!

Unfortunately yesterday i had just brought a computer which had LPT on the motherboard specifically for jTag and now you release this.. But its very nice thanks!!

#3 Ethan0026

Ethan0026

    X-S Enthusiast

  • Members
  • 11 posts

Posted 21 April 2010 - 09:38 AM

up

#4 sh1tty

sh1tty

    X-S Enthusiast

  • Members
  • 8 posts

Posted 21 April 2010 - 12:30 PM

this is awesome !

#5 thwack

thwack

    X-S Freak

  • Last Chance
  • PipPipPipPipPip
  • 1,334 posts
  • Location:Yorkshire at heart.....
  • Xbox Version:unk
  • 360 version:unknown

Posted 21 April 2010 - 12:59 PM

QUOTE(Ethan0026 @ Apr 21 2010, 09:38 AM) View Post
up




Nice app, many thanks (although haven't been able to test it) - would say though - don't bump your topic, peeps will test this out and bump it for you wink.gif



#6 brandogg

brandogg

    X-S Messiah

  • Members
  • PipPipPipPipPipPipPip
  • 3,091 posts
  • Xbox Version:v1.6
  • 360 version:v4.0 (jasper)

Posted 21 April 2010 - 04:59 PM

This is on the front page too, but you can't reply to the topic. I'm gonna have to go get a new PCI LPT card ($5 or so), since the one I bought has no drivers anywhere (LiteOn 2S1P), but at least I can throw out my piece of shit Pentium 2 Windows 95 machine now.

#7 brandogg

brandogg

    X-S Messiah

  • Members
  • PipPipPipPipPipPipPip
  • 3,091 posts
  • Xbox Version:v1.6
  • 360 version:v4.0 (jasper)

Posted 22 April 2010 - 01:52 AM

Has anyone used this? I supposedly patched NandPro with it, but it still looks for the same ports, and finds nothing.

Edit - didn't see the part about removing the resistors. I'm gonna give that a try and get back to everyone shortly.

Edited by brandogg, 22 April 2010 - 02:47 AM.


#8 brandogg

brandogg

    X-S Messiah

  • Members
  • PipPipPipPipPipPipPip
  • 3,091 posts
  • Xbox Version:v1.6
  • 360 version:v4.0 (jasper)

Posted 22 April 2010 - 03:47 AM

Looks like it's a bust, at least for me. My PCI card shows up fine in the device manager, but patching Nandpro with this appears to do nothing. I'm running as administrator, and Nandpro's "date modified" changes to when I patch it, but it still looks for the standard ports (or at least says it's doing that) and finds nothing, then gives up. Oh well, back to the shitty PC in the garage.

#9 Ethan0026

Ethan0026

    X-S Enthusiast

  • Members
  • 11 posts

Posted 22 April 2010 - 08:56 PM

i'm the dev, and it work fine i have done my jtag with my program

you do something wrong, is nandpro try your ports ? it should

#10 brandogg

brandogg

    X-S Messiah

  • Members
  • PipPipPipPipPipPipPip
  • 3,091 posts
  • Xbox Version:v1.6
  • 360 version:v4.0 (jasper)

Posted 23 April 2010 - 12:47 AM

When I patch NandPro (ports for my LPT card are 9800 and 9400 - the same ports work with my VIA SATA card if I put it in that slot), it still looks for 0378 0278 and 03BC. IO Patcher says it has patched NandPro, and the timestamp does get changed, but it appears it's not actually doing anything.

Edit - would you mind trying it for me? Just patch your own Nandpro for ports 9800 and 9400 and upload it, then I can try it, that would be awesome if you could do it.

Edited by brandogg, 23 April 2010 - 12:48 AM.


#11 Ethan0026

Ethan0026

    X-S Enthusiast

  • Members
  • 11 posts

Posted 23 April 2010 - 12:22 PM

ok works good for me. Upload here : http://www.mediafire.com/?emrkmry4jwy

i think i have found the issue, my patch only work with nandpro 2.0d...

#12 brandogg

brandogg

    X-S Messiah

  • Members
  • PipPipPipPipPipPipPip
  • 3,091 posts
  • Xbox Version:v1.6
  • 360 version:v4.0 (jasper)

Posted 23 April 2010 - 01:00 PM

Well that must be it, I was using Nandpro 2.0b/e. Thanks, I'll try this one.

#13 Pacotera

Pacotera

    X-S Member

  • XS-BANNED
  • Pip
  • 108 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 23 April 2010 - 08:10 PM

I dont know if might have been the drivers but on window xp i got nothing working

Then i remove the pci card and installed on another computer with windows 7

worked first time biggrin.gif

#14 Ethan0026

Ethan0026

    X-S Enthusiast

  • Members
  • 11 posts

Posted 24 April 2010 - 09:15 AM

feedback brandogg ?

#15 shreaded_teddy

shreaded_teddy

    X-S Enthusiast

  • Members
  • 3 posts

Posted 10 November 2010 - 11:41 PM

I'm trying to jtag with a PCI card but how do I know which ports to change it to?

Edit: never mind, you have to go to properties for the pci card in the device manager and click resources. Its finally reading, THANKS!

Edited by shreaded_teddy, 11 November 2010 - 12:20 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users