Jump to content


Photo

Can I Reinstall The X-clamps?


  • Please log in to reply
2 replies to this topic

#1 HaLo2FrEeEk

HaLo2FrEeEk

    X-S Young Member

  • Members
  • Pip
  • 50 posts

Posted 26 April 2010 - 06:49 AM

After taking them off, cleaning my CPU and GPU with rubbing alcohol, then putting new Silver Thermal Compound on both them and the heatsinks, I'd like to reattach the X-Clamps. They don't seem to fit on anymore and I wanted to know, is it possible to reinstall them and if so, how?

And for the record, I have a RROD fix kit from Xecuter on order, it should be here by Friday, at which point I'll remove the clamps again and install the kit, but I just want to know for now if the new thermal paste worked at all, or if I completely borked my board with the rubbing alcohol.

#2 360ballin

360ballin

    X-S Member

  • Members
  • Pip
  • 108 posts

Posted 26 April 2010 - 06:55 AM

dont know about the clamps, but i really doubt the alcohol did anything to mess your board up.... guides say to use it if u dont have the cleaner

#3 HaLo2FrEeEk

HaLo2FrEeEk

    X-S Young Member

  • Members
  • Pip
  • 50 posts

Posted 26 April 2010 - 07:31 AM

Well good, and with the new paste things should work much better, if I could just get these stupid clamps back on. I know this paste is good stuff, I've used it on my PC and it works great.

I'm just having a hell of a time getting these clamps back on.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users