Jump to content


Photo

Xboxhdm Not Mounting Drives


  • Please log in to reply
1 reply to this topic

#1 bagmansgambit

bagmansgambit

    X-S Enthusiast

  • Members
  • 2 posts

Posted 15 May 2010 - 10:07 PM

So i've been trying to softmod this xbox i've acquired for the past few days and I'm stuck.

The Issue:
1. I can't do anything through xboxhdm. it looks for linux cd-rom in all dev/hda dev/hdb etc. and utlimately says linux cd-rom not found. If i do xboxhd it shows it cannot mount /dev/hda etc. I get these same errors even when theres nothing connected to the ide cable. I do notice whether or not it sees the drive in the string of text before it loads. I can also see what i believe to be whether it is locked or not by the presence of drive seek errors.

2. If i use an older PC (drive on primary master cd-drive on secondary master) i get 'this is no xbox' error through hdm


The Setup:
I have xboxhdm v1.9. I copied the Clean 5960 Dash files into the C: folder and Put empty folders UDATA and TDATA in E: (ive also tried it without either of those). I have ndure 3.1 with the correct kernel selected (5101) create a folder in the xboxhdm/linux folder. Ive created and burned probably about 10 iso's on cd and dvd so its not a bad burn. ive also booted the linux iso from usb. same error

The master/slave condition: i have a motherboard with 4 sata and 1 IDE. If I go to my bios with a hd hooked up it'll show the hd as IDE channel 0 master and the sata cd-drive as ide channel 3 slave. if i connect the hd while in the bios and click ide auto detection it will say detecting hd but nothing shows up afterwards. (although after hotswapping the drive after booting to linux cd xboxhdm still detects it).

Im using the error 12 to unlock the HD (have also used the song on the harddrive method). Ive tried having the jumper on master for the xbox hd from the initial powering on of the xbox and Ive tried changing the jumper from cable select to master after disconnecting the ide cable at error 12 then connecting my ide cable.

What I don't have: i don't have the xbox hdd eeprom or password. I'm under the impression from the readme these are not neccesary but are suggested. My xbox is also not updated to the 5960 dash seeing a i have no games at all much less halo2 or newer xbox live games.

Ive searched multiple forums and have found many threads with similar issues but almost none seem to be solved. I'm hoping we can solve this and allow the others who are having this problem to be able to search this thread and find their solution.

So the question is: why wold i get this same error whether or not the xbox hard drive is connected, disconnected, locked, or unlocked. I feel it has something to do with the hardware and perhaps is fixable through bios. I have not been able to accomplish the pause break method because pause break does not seem to work when my system boots.

If anyone can give any tips for troubleshooting or knows of any hardware limitations for xboxhdm that would be greatly appreciated.

** i just found something i havent seen before in other forums. Someone is suggesting that the cd-drive cannot be sata. can anyone confirm or deny this allegation? The second computer i tried it on does have an ide cd drive but gives a different error (this is no xbox) with the cd drive being secondary master instead of slave. xbox hdd is still primary master.

Edited by bagmansgambit, 15 May 2010 - 10:15 PM.


#2 Heimdall

Heimdall

    X-S Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 5,749 posts
  • Location:UK
  • Xbox Version:v1.4
  • 360 version:v4.0 (jasper)

Posted 15 May 2010 - 11:23 PM

QUOTE(bagmansgambit @ May 15 2010, 10:07 PM) View Post
i have a motherboard with 4 sata and 1 IDE.

And that's your problem. xboxhdm 1.9 needs 2 separate IDE ports on the motherboard, with the CD on one and the Xbox disk on the other.

xboxhdm 2.1 gives you more flexibility, and boots from USB, so you might want to try that instead.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users