Jump to content


Photo

Puppyx Wip


  • Please log in to reply
7 replies to this topic

#1 luther349

luther349

    X-S Hacker

  • Members
  • PipPipPipPipPipPip
  • 2,360 posts
  • Location:irvine ky
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 26 June 2010 - 06:30 AM

well cheers to the few xbox linux users still out there. i managed to retofix puppy 5 aka woof aka puppy lucid to the 2.4.31 xbox kernel. 2.4.37-9 crashed at fatx guess the guys patch had bugs.

its compiling as we speak turns out i can still use the dev file for lucid pup so my puppy is a full compiling environment and having both gcc versions installed don't conflict. you just need to tell it to use gcc 2.95. so this is still a work in progress in a big way but i whanted to tell everyone a new linux is on its way unless i run across another wall to slow me down. with fatx support you should even be able to make puppy save files on the xbox hd. this will be a live cd with the abilty to save but not install being i have no friggen clue on how to make a loopback style.

whats done

xbox kernel on puppy check

whats to get done for at least a beta

xorg patched for xbox video.
alsa patched for sound.

Edited by luther349, 26 June 2010 - 06:50 AM.


#2 luther349

luther349

    X-S Hacker

  • Members
  • PipPipPipPipPipPip
  • 2,360 posts
  • Location:irvine ky
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 26 June 2010 - 08:48 AM

yet another brick wall. looks like i cant patch for puppys squish fs and fax x. the patch files conflict. squish fs 3.0 patch would need to be alterd to play nice with the changes made to the xbox kernel. this is byond my abilty.

wile i can still not use fatx and make this a live cd only using the xbox kernel without fatx im shure users what the abilty to save use swap and so on.

Edited by luther349, 26 June 2010 - 08:52 AM.


#3 joesnose

joesnose

    X-S Senior Member

  • Members
  • PipPip
  • 175 posts

Posted 18 July 2010 - 02:14 AM

Hello,

Glad someone is attempting this. wish i could help but i am very limited in such matters. well i have wanted puppy for xbox for a long time.

If you are saying you have puppyx running only without fax support, please let this puppy out into the wild.

niceone.

#4 luther349

luther349

    X-S Hacker

  • Members
  • PipPipPipPipPipPip
  • 2,360 posts
  • Location:irvine ky
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 24 August 2010 - 04:48 AM

the issue is i cant get squish and the xbox kernel to play nice. when i finnly did patch the kernel to work puppy simply when into panic mode. i think its due to it using a newer squish fs then the kernel supports. iv seem some tools to retro it into a older squish.

but even getting passed that the other patches llike alisa and x are just to old. so unfortunately i had to abandon the project. its just not possible to get a new distro on the xbox anymore without massive downgrading of pretty much everything.

if the guys at xbox linux would get us some new patches like a new 2.6 kernel with squish support built in witch it has by default and modern xorg and alisa patches i could make puppy x. but there to busy with the 360.

if i did have these things the woof builder is a easy gui i could use to inject the patches and xbox kernel into the source code and wala puppy x in a matter of hrs or days depending on hoe fast my pc would compile it. but being gcc4 can compile 2.4 kernels and nooine of the patches will work on the new xorg or alisa that will not work.

Edited by luther349, 24 August 2010 - 05:06 AM.


#5 f34rther34pr

f34rther34pr

    X-S Member

  • Members
  • Pip
  • 71 posts
  • Interests:modding, hacking
  • Xbox Version:v1.4
  • 360 version:v5.0 (360S - trinity)

Posted 28 August 2010 - 02:47 AM

QUOTE(luther349 @ Aug 23 2010, 10:48 PM) View Post

the issue is i cant get squish and the xbox kernel to play nice. when i finnly did patch the kernel to work puppy simply when into panic mode. i think its due to it using a newer squish fs then the kernel supports. iv seem some tools to retro it into a older squish.

but even getting passed that the other patches llike alisa and x are just to old. so unfortunately i had to abandon the project. its just not possible to get a new distro on the xbox anymore without massive downgrading of pretty much everything.

if the guys at xbox linux would get us some new patches like a new 2.6 kernel with squish support built in witch it has by default and modern xorg and alisa patches i could make puppy x. but there to busy with the 360.

if i did have these things the woof builder is a easy gui i could use to inject the patches and xbox kernel into the source code and wala puppy x in a matter of hrs or days depending on hoe fast my pc would compile it. but being gcc4 can compile 2.4 kernels and nooine of the patches will work on the new xorg or alisa that will not work.


if your abandoning the project at least put a download link to wut you have done so far. someone else might be interested in trying to get it working on the xbox. just a thought.

P.S. do u hav the lastest X-dsl? i cant find it anywhere. all the ones that "claim" to be real are just v.1

Edited by f34rther34pr, 28 August 2010 - 02:50 AM.


#6 Man With A Bag

Man With A Bag

    X-S Enthusiast

  • Members
  • 20 posts
  • Xbox Version:v1.0
  • 360 version:none

Posted 29 August 2010 - 05:31 PM

The latest X-DSL is available on this site, if I'm not mistaken...

#7 f34rther34pr

f34rther34pr

    X-S Member

  • Members
  • Pip
  • 71 posts
  • Interests:modding, hacking
  • Xbox Version:v1.4
  • 360 version:v5.0 (360S - trinity)

Posted 29 August 2010 - 08:28 PM

QUOTE(Man With A Bag @ Aug 29 2010, 11:31 AM) View Post

The latest X-DSL is available on this site, if I'm not mistaken...


u forget to link it

#8 luther349

luther349

    X-S Hacker

  • Members
  • PipPipPipPipPipPip
  • 2,360 posts
  • Location:irvine ky
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 31 August 2010 - 02:29 AM

well the kernel is hear http://sourceforge.n...xboxhdm2/files/ in lba48. its 2.4 with squishfs. really that's it. download lucid puppy and the devx.sys file then manually install the gcc2 deb and deps for it. you need gcc 2 to compile a 2.4 kernel gcc 4 does not work. you will have to track down guides on how puppy works being i dont have all the links on hand. but devx.sys pretty much turns puppy into a dev station compiling etc. you need the dev.sys for your version normal in the same folder as the main iso on the ftp server.

idotfan worked on that kernel i just tried to make it work in puppy. but when i couldn't patch xorg sound etc i relised even if i got it working everything else would be broken.

lucid puppy is still puppy but also can use ubuntu files rather then just being restricted to the puppy .pet format.

and hear is xdsl 0.6 http://sourceforge.n...ux/files/X-DSL/

that was the last offical one.

Edited by luther349, 31 August 2010 - 02:49 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users