Jump to content


Photo

Always Having Trouble Installing Via Apt-get


  • Please log in to reply
5 replies to this topic

#1 juliushibert

juliushibert

    X-S Enthusiast

  • Members
  • 6 posts

Posted 04 July 2010 - 11:27 AM

I've been wanting to make use out of my old xbox for a while but always seem to have trouble with apt-get no matter what distro.

Currently I've got Xebian installed and ssh working which seems fine. Ultimately I want to get it running as a sabnzbd and at some point a NAS. At the moment it's just installed on E: but if it would make things easier I could install the whole thing natively as I never use the xbox any more—out of interest is it possible to restore the original state of the xbox to play games if I do this?

I've tried just installing something simple like Samba and I get loads of errors about dependencies.



CODE
xebian:~# apt-get install samba
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  kernel-image-2.6.18-xbox: Depends: initrd-tools (>= 0.1.48) but it is not installable
  locales: Depends: glibc-2.7-1
  samba: Depends: samba-common (= 2:3.2.5-4lenny12) but 3.0.14a-3 is to be installed
         Depends: libattr1 (>= 2.4.41-1) but 2.4.16-1 is to be installed
         Depends: libc6 (>= 2.7-1) but 2.3.2.ds1-22 is to be installed
         Depends: libcups2 (>= 1.3.8) but it is not going to be installed
         Depends: libgnutls26 (>= 2.4.0-0) but it is not going to be installed
         Depends: libkrb53 (>= 1.6.dfsg.2) but 1.3.6-2 is to be installed
         Depends: libldap-2.4-2 (>= 2.4.7) but it is not going to be installed
         Depends: libpam0g (>= 0.99.7.1) but 0.76-22 is to be installed
         Depends: libpopt0 (>= 1.14) but 1.7-5 is to be installed
         Depends: libtalloc1 but it is not going to be installed
         Depends: libwbclient0 (>= 2:3.2.0) but it is not going to be installed
         Depends: update-inetd but it is not going to be installed
W: Couldn't stat source package list http://non-us.debian.org stable/non-US/main Packages (/var/lib/apt/lists/non-us.debian.org_debian-non-US_dists_stable_non-US_main_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://non-us.debian.org stable/non-US/contrib Packages (/var/lib/apt/lists/non-us.debian.org_debian-non-US_dists_stable_non-US_contrib_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://non-us.debian.org stable/non-US/non-free Packages (/var/lib/apt/lists/non-us.debian.org_debian-non-US_dists_stable_non-US_non-free_binary-i386_Packages) - stat (2 No such file or directory)
W: You may want to run apt-get update to correct these problems
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


So I've tried apt-get -f install and again I get more erros and suggestions about updating to 2.6


CODE
xebian:~# apt-get -f install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libc6
Suggested packages:
  glibc-doc libc6-i686
The following packages will be REMOVED:
  kernel-image-2.6.18-xbox
The following packages will be upgraded:
  libc6
1 upgraded, 0 newly installed, 1 to remove and 314 not upgraded.
3 not fully installed or removed.
Need to get 0B/4550kB of archives.
After unpacking 13.8MB disk space will be freed.
Do you want to continue? [Y/n] y
Reading changelogs... Done
W: Couldn't stat source package list http://non-us.debian.org stable/non-US/main Packages (/var/lib/apt/lists/non-us.debian.org_debian-non-US_dists_stable_non-US_main_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://non-us.debian.org stable/non-US/contrib Packages (/var/lib/apt/lists/non-us.debian.org_debian-non-US_dists_stable_non-US_contrib_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://non-us.debian.org stable/non-US/non-free Packages (/var/lib/apt/lists/non-us.debian.org_debian-non-US_dists_stable_non-US_non-free_binary-i386_Packages) - stat (2 No such file or directory)
Preconfiguring packages ...
(Reading database ... 35070 files and directories currently installed.)
Removing kernel-image-2.6.18-xbox ...
(Reading database ... 34800 files and directories currently installed.)
Preparing to replace libc6 2.3.2.ds1-22 (using .../libc6_2.7-18lenny4_i386.deb) ...
Checking for services that may need to be restarted...
Checking init scripts...
readlink: invalid option -- e
Try `readlink --help' for more information.
readlink: invalid option -- e
Try `readlink --help' for more information.
readlink: invalid option -- e
Try `readlink --help' for more information.
readlink: invalid option -- e
Try `readlink --help' for more information.
readlink: invalid option -- e
Try `readlink --help' for more information.
readlink: invalid option -- e
Try `readlink --help' for more information.
readlink: invalid option -- e
Try `readlink --help' for more information.
readlink: invalid option -- e
Try `readlink --help' for more information.
readlink: invalid option -- e
Try `readlink --help' for more information.
readlink: invalid option -- e
Try `readlink --help' for more information.
WARNING: POSIX threads library NPTL requires kernel version
2.6.8 or later. If you use a kernel 2.4, please upgrade it
before installing glibc.

The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add etch sources to your /etc/apt/sources.list and run:
  apt-get install -t etch linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg: error processing /var/cache/apt/archives/libc6_2.7-18lenny4_i386.deb (--unpack):
subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.7-18lenny4_i386.deb
W: Couldn't stat source package list http://non-us.debian.org stable/non-US/main Packages (/var/lib/apt/lists/non-us.debian.org_debian-non-US_dists_stable_non-US_main_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://non-us.debian.org stable/non-US/contrib Packages (/var/lib/apt/lists/non-us.debian.org_debian-non-US_dists_stable_non-US_contrib_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://non-us.debian.org stable/non-US/non-free Packages (/var/lib/apt/lists/non-us.debian.org_debian-non-US_dists_stable_non-US_non-free_binary-i386_Packages) - stat (2 No such file or directory)
W: You may want to run apt-get update to correct these problems
E: Sub-process /usr/bin/dpkg returned an error code (1)



Here's my sources list as well
CODE

deb http://ftp.at.debian.org/debian/ stable main contrib non-free

deb http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free
deb-src http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free  

deb     http://security.debian.org/ stable/updates main contrib non-free
deb-src http://security.debian.org/ stable/updates main contrib non-free

#add this line from http://www.emulab.it/forum/index.php?topic=8.0

deb http://download.webmin.com/download/repository sarge contrib


My knowledge of unix is basic and quite n00bish but it'd be great to get this working but I'm left scratching my head. Is Xebian the best distro to be using or is there something a little bit easier to be using?

Is there some simple way of getting all these dependencies installed as I guess they're need to compile the apps that I want to use like Samba and SABnzbd?
sad.gif

Edited by juliushibert, 04 July 2010 - 11:29 AM.


#2 run088

run088

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,003 posts
  • Interests:rebuilding broken xboxes
  • Xbox Version:v1.0
  • 360 version:none

Posted 04 July 2010 - 07:11 PM

When you run an apt-get update what happens? Do you get errors? Can you not connect to any of the repos? Find out which ones cant connect and comment out with # then apt-get update again and see if that sorts it. It is usually a problem with connecting with the listed repos. Not to mention if your going to use repos for xebian you might want to try "sarge" repos. Anything etch or newer will break your install unless modified. Some stuff will install from etch other things in etch will crash your system

#3 juliushibert

juliushibert

    X-S Enthusiast

  • Members
  • 6 posts

Posted 04 July 2010 - 11:46 PM

Thanks for that. It looks like after updating the sources to below things are working better but not perfectly.

I've downloaded Python2.5 directly from the Python site and I think it installed ok. However when I type in

CODE
python -V


I'm still getting it coming up as Python 2.3.5

Any ideas how to get this updated in order to get SAB up and running?

CODE
deb http://archive.debian.org/debian sarge main contrib non-free

deb http://archive.debian.org/debian-non-US oldstable/non-US main contrib non-f$
deb-src http://archive.debian.org/debian-non-US oldstable/non-US main contrib n$

deb http://archive.debian.org/debian-security sarge/updates main contrib non-fr$
deb-src http://archive.debian.org/debian-security sarge/updates main contrib no$





#4 juliushibert

juliushibert

    X-S Enthusiast

  • Members
  • 6 posts

Posted 05 July 2010 - 12:23 AM

Also forgot to mention I've now done a full native install/cromwell boot.

Even with those updated sources.list entires I'm still getting problems installing samba. Really frustrating.

CODE
box:/etc/apt# apt-get install samba
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be upgraded:
  samba
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
132 not fully installed or removed.
Need to get 0B/2556kB of archives.
After unpacking 53.2kB disk space will be freed.
Reading changelogs... Done
Preconfiguring packages ...
(Reading database ... 36630 files and directories currently installed.)
Preparing to replace samba 3.0.14a-3 (using .../samba_3.0.14a-3sarge11_i386.deb) ...
Unpacking replacement samba ...
/var/lib/dpkg/info/samba.postrm: line 22: update-inetd: command not found
dpkg: warning - old post-removal script returned error exit status 127
dpkg - trying script from the new package instead ...
/var/lib/dpkg/tmp.ci/postrm: line 22: update-inetd: command not found
dpkg: error processing /var/cache/apt/archives/samba_3.0.14a-3sarge11_i386.deb (--unpack):
subprocess new post-removal script returned error exit status 127
/var/lib/dpkg/tmp.ci/postrm: line 22: update-inetd: command not found
dpkg: error while cleaning up:
subprocess post-removal script returned error exit status 127
Errors were encountered while processing:
/var/cache/apt/archives/samba_3.0.14a-3sarge11_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


This samba error seems to be a sticking point though now as installing any other apt packages like apache or swat will return some sort of similar samba error;

CODE
box:/etc/apt# apt-get install apache
Reading Package Lists... Done
Building Dependency Tree... Done
apache is already the newest version.
The following extra packages will be installed:
  samba
The following packages will be upgraded:
  samba
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
132 not fully installed or removed.
Need to get 0B/2556kB of archives.
After unpacking 53.2kB disk space will be freed.
Do you want to continue? [Y/n] y
Reading changelogs... Done
Preconfiguring packages ...
(Reading database ... 36630 files and directories currently installed.)
Preparing to replace samba 3.0.14a-3 (using .../samba_3.0.14a-3sarge11_i386.deb) ...
Unpacking replacement samba ...
/var/lib/dpkg/info/samba.postrm: line 22: update-inetd: command not found
dpkg: warning - old post-removal script returned error exit status 127
dpkg - trying script from the new package instead ...
/var/lib/dpkg/tmp.ci/postrm: line 22: update-inetd: command not found
dpkg: error processing /var/cache/apt/archives/samba_3.0.14a-3sarge11_i386.deb (--unpack):
subprocess new post-removal script returned error exit status 127
/var/lib/dpkg/tmp.ci/postrm: line 22: update-inetd: command not found
dpkg: error while cleaning up:
subprocess post-removal script returned error exit status 127
Errors were encountered while processing:
/var/cache/apt/archives/samba_3.0.14a-3sarge11_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
box:/etc/apt#


Edited by juliushibert, 05 July 2010 - 12:27 AM.


#5 juliushibert

juliushibert

    X-S Enthusiast

  • Members
  • 6 posts

Posted 05 July 2010 - 06:51 PM

@run088

After changing the repos in my source.list to some sarge ones things seem to working a lot better. I think they're from another thread you posted or helped someone with;

CODE
Use these repos for sarge

deb http://archive.debian.org/debian sarge main contrib non-free

deb http://archive.debian.org/debian-non-US oldstable/non-US main contrib non-free
deb-src http://archive.debian.org/debian-non-US oldstable/non-US main contrib non-free

deb http://archive.debian.org/debian-security sarge/updates main contrib non-free
deb-src http://archive.debian.org/debian-security sarge/updates main contrib non-free


I think I'd screwed my old instillation so in the end reformatted and did a new fresh native xebian install and removed all the original sources which all seemed to be causing errors and warnings.

Then replacing with the ones above I seem to be able to run apt-get update and apt-get -f dist-upgrade without any problems.

Samba/Swat etc all seem to install and run fine now as well so huge thanks for that. biggrin.gif



Out of interest is there any point upgrading the kernel to 2.6.18? Will it alleviate any of these problems and allow me to install from etch?


Now I just need to get SABnzbd working--have updated to pytho2.5 but every time I run SABnzbd.py I get an error about

Sorry, requires Python module sqlite3 (pysqlite2 in python2.4)
Try: apt-get install python-pysqlite2


Bit annoying..... the charms of linux?

If I manage to get it all working might stick together a walk thorough in case it helps anyone?

Thanks again run088



#6 run088

run088

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,003 posts
  • Interests:rebuilding broken xboxes
  • Xbox Version:v1.0
  • 360 version:none

Posted 05 July 2010 - 11:29 PM

Only thing the 2.6.18 kernel does for me is enables virtualbox only because that kernel was the only one I could get the dkms package working correctly with which is required to run a virtual envirnorment in virtualbox.



I have sabnzbd running but it has been a while since I built one from scratch. I either might have installed python2.4 and 2.5 somehow or I used a deb package. I have done it a few times and in all likelyhood have done both. I do seem to think I found an etch repo that had all the packages sab requires in it or most. It might have been a backports repo I dont remember. I will look and see if I can find it when I am around that xbox. I always apt-get f dist-upgrade threw the sarge and grab some select packages that dont seem to break the install in etch like a newer perl, python, java etc. You have to be careful with etch alot of stuff in it will break your install.

It took me forever to get sab running but once I did it was worth it

Edited by run088, 05 July 2010 - 11:30 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users