Jump to content


Photo

Disc Reading Problems...


  • Please log in to reply
3 replies to this topic

#1 speedypancake

speedypancake

    X-S Senior Member

  • Members
  • PipPip
  • 154 posts

Posted 07 October 2010 - 01:26 PM

Bought a faulty PS3 off Ebay hoping to fix it.

Found the data cable from the disc drive flopping about as the cable clip was missing. Managed to jam it back in with a bit of plastic, but the drive wouldn't accept any discs, so bought another blu ray drive.

Swapped control boards and thought it was fixed as it now accepted and ejected discs. But.........

Although both lasers appear to be working and discs spin up, no games, CD's or DVD's show up on the menu.

Any ideas on what else to check. It's already had a new disc drive & ribbon cable blink.gif



#2 speedypancake

speedypancake

    X-S Senior Member

  • Members
  • PipPip
  • 154 posts

Posted 07 October 2010 - 02:28 PM


Further reading now makes me wonder if this stupid console had the wrong blu ray drive / board from the start & I've been ripped off grr.gif

Any way to tell for sure (apart from it not working laugh.gif !??)

#3 mygameswirelesscom

mygameswirelesscom

    X-S Senior Member

  • Members
  • PipPip
  • 219 posts
  • Location:9W29st NEW YORK NEW YORK
  • Interests:Repair PSP PS2 XBOX
  • Xbox Version:v1.6b
  • 360 version:v1 (xenon)

Posted 09 October 2010 - 12:09 PM

QUOTE(speedypancake @ Oct 7 2010, 01:26 PM) View Post

Bought a faulty PS3 off Ebay hoping to fix it.

Found the data cable from the disc drive flopping about as the cable clip was missing. Managed to jam it back in with a bit of plastic, but the drive wouldn't accept any discs, so bought another blu ray drive.

Swapped control boards and thought it was fixed as it now accepted and ejected discs. But.........

Although both lasers appear to be working and discs spin up, no games, CD's or DVD's show up on the menu.

Any ideas on what else to check. It's already had a new disc drive & ribbon cable blink.gif

if drive cable clip is missing you must put some card(nameor cr card) or tapit
if cable is not put right it will not read
yes it looks working opening and all that but....
see your cable look see if some pins are ban?
i haed same thing spand so much time
but i did repair !!
so dont give up try to see your cable one more time
make good connection with cable & p3
good luck!

#4 speedypancake

speedypancake

    X-S Senior Member

  • Members
  • PipPip
  • 154 posts

Posted 10 October 2010 - 10:50 AM

thanks for your help.
But I've already replaced the ribbon with another (good) one. Maybe the pins in the connector on the mother board are bent? Very hard to see as they're so tiny






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users