Jump to content


Photo

Falcon Bad Block At 36


  • Please log in to reply
4 replies to this topic

#1 rastiemon

rastiemon

    X-S Member

  • Members
  • Pip
  • 80 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 28 October 2010 - 07:11 AM

Ok got a falcon wired it up dumped the nand. Bad block at 36. Tried installing xellous though all I get is single green light. Switched my wiring around and tried without smc. Still nada. Finally flashed xell got it working only off ROL but not off aud clamp.

Tried manually remapping 36 to 3ff after building my freeboot img. No luck.

Tried flashing through putty with xbrflash and this is what I get.



Free60:/tmp# ./xbrflash -w updflash.bin

XBR-Flash for Linux v0.3.6 beta by trancy (www.modcontrol.com)
Thanks goes to tmbinc, Redline99 and all Beta-Tester on xboxhacker.org

Nandsize: 16 MB detected
Read and write: 16 MB

Flashing from updflash.bin...
0x400 block's to write...
Detected RAW nand file, using raw mode.
Unexpected erase @ block 0x36 with status 0x202
Writing block: 0x3ff of 0x3ff (16MB/16MB)
Speed: 1.33 MB/s
Write done in 12.00 sec.

Verifying flash with updflash.bin...
0x400 block's to verify...
Detected RAW nand file, using raw mode.
Verifying block: 0x36 of 0x3ff (0MB/16MB)
Verify error @ block: 0x36

Corrected ECC: 2
Speed: 0.84 MB/s.
Verify done in 1.00 sec.
Verified correctly, but only 912384 bytes.
Info: I won't flash if you don't have a full, working backup, sorry.
Delete updflash.bin and try to dump again

Free60:/tmp#


Did that and still get flashing green light. I don't know what else to try. Any ideas guys?

#2 deadair4ever

deadair4ever

    X-S Young Member

  • Members
  • Pip
  • 57 posts
  • Location:Paso Robles, CA
  • Xbox Version:v1.6d
  • 360 version:v2 (zephyr)

Posted 28 October 2010 - 07:46 AM

Yeah, sorry, mate... bad blocks 00-50 cannot be remapped... sadly

#3 Looouky

Looouky

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,060 posts
  • Location:Calgary, Alberta Canada
  • Xbox Version:v1.4
  • 360 version:v1 (xenon)

Posted 28 October 2010 - 01:45 PM

It can totally be remapped, i have remapped block 10 without issue before.

Did you remapp a block in the freeboot image, before flashing it with xbrflash you can't do that.

Ok this is what you need to do...

1) Get xell working again.

2) make a backup of your full backup..

3) using a copy of a full original nandbackup move block 3ff to 36, and then erase 3ff

4) build freeboot from the image created in step 3

5) flash again using xbrflash

6) report back

#4 rastiemon

rastiemon

    X-S Member

  • Members
  • Pip
  • 80 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 28 October 2010 - 07:53 PM

Ok these last couple jtags are driving me freakin nuts. Here is what I did.


1. I restored my full original back up and it booted correctly to ms dash.

2. Next I reflashed xell.

3. I took my fullbin and did this:

nandpro full.bin: -r16 3ff.bin 3ff 1
nandpro full.bin: -w16 3ff.bin 36 1
nandpro full.bin: -e16 3ff 1

4. Checked out that image in freeboot tool box everything looked fine. Then made my updflash.bin with best pig.

5. Booted xell used xbrflash. When doing my dump. and doing my flash I still get that same screen.

_______________________________________________________________________________________

Free60:/tmp# ./xbrflash -d dump.bin

XBR-Flash for Linux v0.3.6 beta by trancy (www.modcontrol.com)
Thanks goes to tmbinc, Redline99 and all Beta-Tester on xboxhacker.org

Nandsize: 16 MB detected
Read and write: 16 MB

Dumping to dump.bin...
0x400 block's to dump...
Reading block: 0x3ff of 0x3ff (16MB/16MB)
Corrected ECC: 2
Speed: 1.45 MB/s
Reading done in 11.00 sec.

Verifying flash with dump.bin...
0x400 block's to verify...
Detected RAW nand file, using raw mode.
Verifying block: 0x36 of 0x3ff (0MB/16MB)
Verify error @ block: 0x36

Corrected ECC: 2
Speed: 0.84 MB/s.
Verify done in 1.00 sec.
Verified correctly, but only 912384 bytes.
Info: I won't flash if you don't have a full, working backup, sorry.
Delete dump.bin and try to dump again

Free60:/tmp# ./xbrflash -w updflash.bin

XBR-Flash for Linux v0.3.6 beta by trancy (www.modcontrol.com)
Thanks goes to tmbinc, Redline99 and all Beta-Tester on xboxhacker.org

Nandsize: 16 MB detected
Read and write: 16 MB

Flashing from updflash.bin...
0x400 block's to write...
Detected RAW nand file, using raw mode.
Unexpected erase @ block 0x36 with status 0x202
Writing block: 0x3ff of 0x3ff (16MB/16MB)
Speed: 1.33 MB/s
Write done in 12.00 sec.

Verifying flash with updflash.bin...
0x400 block's to verify...
Detected RAW nand file, using raw mode.
Verifying block: 0x36 of 0x3ff (0MB/16MB)
Verify error @ block: 0x36

Corrected ECC: 2
Speed: 0.84 MB/s.
Verify done in 1.00 sec.
Verified correctly, but only 912384 bytes.
Info: I won't flash if you don't have a full, working backup, sorry.
Delete updflash.bin and try to dump again
__________________________________________________________________________________



and after all this still single green light. I am starting to think this one is never gonna work.

Edited by rastiemon, 28 October 2010 - 07:54 PM.


#5 rastiemon

rastiemon

    X-S Member

  • Members
  • Pip
  • 80 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 28 October 2010 - 09:20 PM

Ok after talking to some people I have found that block 36 is exactly where the freeboot patches go.

So this box is basically screwed i think without a cygnos

Guess I will be ordering one up soon enough.


Thanks for the help guys.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users