Jump to content


Photo

Xbmc With Windows 7.....don't Hate Me


  • Please log in to reply
18 replies to this topic

#1 hunter13in

hunter13in

    X-S Enthusiast

  • Members
  • 5 posts

Posted 13 November 2010 - 01:28 AM

I am sure you guys have seen a post such as this before....rarely do I need to actually ask for help but I cannot find a solution that works.....maybe y'all could help?

Running Win7 64...have a modded XBOX with very old XBMC 1.1.0..I know I know it's old but it has always worked well with XP and I just left good enough alone....anyway I cannot access shared folder on Win 7. I checked the sticky and a million other posts...I have uninstalled live assistant sign-in...network discovery is on and password sharing is off. I have tried the 128 bit and 40/56 choice to no avail. My XBOX does see my pc. It will show WORKGROUP and then all PCs connected to the workgroup.

I figured that I should probably update XBMC but I can't find a detailed enough tutorial on how to do that. I did find the latest edition I think which says XBOX D30710. All there is in this file is a default.xbe file. Don't know what to do with this file. I actually tried ftp'ing it to xbox and overwriting the other one but that just brought up an error when booting xbmc so I put the old deault.xbe back.

Any ideas on what else I can try to share folders and/or updating XBMC. Thanks in advance for any help...

#2 Heimdall

Heimdall

    X-S Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 5,749 posts
  • Location:UK
  • Xbox Version:v1.4
  • 360 version:v4.0 (jasper)

Posted 13 November 2010 - 01:31 AM

Google XBMC4Xbox nightly builds.

You have to delete then replace all the files and folders, not just default.xbe

#3 hunter13in

hunter13in

    X-S Enthusiast

  • Members
  • 5 posts

Posted 13 November 2010 - 02:05 AM

QUOTE(Heimdall @ Nov 13 2010, 01:31 AM) View Post

Google XBMC4Xbox nightly builds.

You have to delete then replace all the files and folders, not just default.xbe


Dude,,,awesome. This was all because I had the very old version. I found the latest version of XBMC...FTP'd it.....added a share location and now I'm good to go. I think the latest version of XBMC must have a work around built into it for Win7 or something...anyways thanks for the help!! biggrin.gif

#4 Heimdall

Heimdall

    X-S Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 5,749 posts
  • Location:UK
  • Xbox Version:v1.4
  • 360 version:v4.0 (jasper)

Posted 13 November 2010 - 02:12 AM

It's not a workround, it's a proper fix smile.gif

#5 hunter13in

hunter13in

    X-S Enthusiast

  • Members
  • 5 posts

Posted 13 November 2010 - 02:49 AM

QUOTE(Heimdall @ Nov 13 2010, 02:12 AM) View Post

It's not a workround, it's a proper fix smile.gif


HA! Got it......

I may have spoke too soon though,,,,my pc setup is 2 drives in RAID0 for my OS.. I don't store any files here. My D: drive is a RAID1 setup with all my personal files and then my E: is simply movies. Through my new XBMC I can easily access and play all my movies from my E: drive with no problem. However on my D: I cannot. It does ask me for a un/pw. I followed the steps in the sticky and was able to have IPaddress added as a source but then it still prompts me for a un/pw once I get into the folders. And then the un/pw don't work. Can ya verify what the username should be? For instance, my main pc is labeled as "office" and then it requires a password to sign on. I used office and the PW to setup the IP source but these won't work once inside the folders....

Anyway, it's not the end of the world because all I want to do is stream movies anyway....but the darn principle of not being able to access my music and pictures is irking me... wink.gif

#6 Sobersally

Sobersally

    X-S Enthusiast

  • Members
  • 22 posts
  • Location:Michigan
  • Interests:Xbox-what else???<br />Criminology
  • Xbox Version:v1.0

Posted 15 November 2010 - 07:03 PM

I am hoping that someone can help me. I have tried all the possible solutions to not being able to see my shares without a password.

Here is what I have done.
Turned off windows 7 homegroup
I have the latest XBMC 30710 from Nightly builds
I set up my computer's IP to go directly to the shares and it still asks for a password.
Checked all the permissions for Everyone
I do not have Windows Live Assistant installed.

The only thing is that I turned off the windows 7 homegroup last night but did not reboot my computer. I tried to access the xbox without restarting the computer. I will do that when I get home tonight. Maybe it will be fixed by then but I doubt it.

Any other suggesstions?

#7 Sobersally

Sobersally

    X-S Enthusiast

  • Members
  • 22 posts
  • Location:Michigan
  • Interests:Xbox-what else???<br />Criminology
  • Xbox Version:v1.0

Posted 15 November 2010 - 09:06 PM

I had time so I shut down my computer and my shares are still looking for a password.

Help!!!

#8 hunter13in

hunter13in

    X-S Enthusiast

  • Members
  • 5 posts

Posted 15 November 2010 - 09:28 PM

QUOTE(Sobersally @ Nov 15 2010, 09:06 PM) View Post

I had time so I shut down my computer and my shares are still looking for a password.

Help!!!


I was only able to get it to work on the files that I have on a separate drive. I cannot share files from main either. I do not know what un/pw XBMC is looking for. I have tried the user and logon password for windows but that didn't work. I don't know what else to do or what advice to give you except maybe add another HD in your PC just for media.

#9 Bomb Bloke

Bomb Bloke

    X-S Transcendental

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPip
  • 6,567 posts
  • Gender:Male
  • Location:Tasmania (AU)
  • Xbox Version:v1.0
  • 360 version:none

Posted 16 November 2010 - 01:47 AM

Even if the Everyone group has access, you still need to disable Password Protected Sharing within the Network and Sharing Center panel.

#10 Sobersally

Sobersally

    X-S Enthusiast

  • Members
  • 22 posts
  • Location:Michigan
  • Interests:Xbox-what else???<br />Criminology
  • Xbox Version:v1.0

Posted 16 November 2010 - 03:41 PM

If you have windows 7 homegroup disconected, how can I make sure to disable Password Protected Sharing within the Network and Sharing Center panel?. Maybe I am missing something but it seems like I have tried everything. But I will look for this when I get home from work.




#11 Sobersally

Sobersally

    X-S Enthusiast

  • Members
  • 22 posts
  • Location:Michigan
  • Interests:Xbox-what else???<br />Criminology
  • Xbox Version:v1.0

Posted 17 November 2010 - 08:20 PM

Last night I checked all my settings in Network and Security and password Protection was password protection was turned off and still no shares.

I am wondering if I should start all over. I mean I used Slayers to setup my xbox and maybe there is something in the old setup that is conflicting with the shares.
That is the only idea I have left. I have Auto installer 4.0 so I will try that. Once that is set up, I will FTP version 30710 to it and see if it fixes it. I will post if it does.

#12 Sobersally

Sobersally

    X-S Enthusiast

  • Members
  • 22 posts
  • Location:Michigan
  • Interests:Xbox-what else???<br />Criminology
  • Xbox Version:v1.0

Posted 18 November 2010 - 06:00 PM

Formatted HD
Installed Autoinstaller 4.0
Still no shares
I give up
Disabled Windows 7 home group
Disabled password protection
No Windows Live Assistant Installed
Any ideas?

#13 hunter13in

hunter13in

    X-S Enthusiast

  • Members
  • 5 posts

Posted 18 November 2010 - 06:51 PM

QUOTE(Sobersally @ Nov 18 2010, 06:00 PM) View Post

Formatted HD
Installed Autoinstaller 4.0
Still no shares
I give up
Disabled Windows 7 home group
Disabled password protection
No Windows Live Assistant Installed
Any ideas?



Try this,,,this was the final step needed to make mine work.....right-click on the file you want and click share with specific people. Then from the drop down menu select Everyone and then hit add next to it.

#14 Bomb Bloke

Bomb Bloke

    X-S Transcendental

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPip
  • 6,567 posts
  • Gender:Male
  • Location:Tasmania (AU)
  • Xbox Version:v1.0
  • 360 version:none

Posted 19 November 2010 - 08:35 AM

If it's still not working after all that, then something is likely wrong with the Guest account (which is required for anonymous access - it may be disabled). You could try providing the username and password for your own user account (assuming that has the correct permissions set on the folder), see if that works.

#15 Sobersally

Sobersally

    X-S Enthusiast

  • Members
  • 22 posts
  • Location:Michigan
  • Interests:Xbox-what else???<br />Criminology
  • Xbox Version:v1.0

Posted 21 November 2010 - 07:24 PM

Thanks for the ideas but I have already done the Everyone setting. I formatted for the 3rd time and used Slayers this time. Now I can't even FTP over to the xbox. My thoughts were to used Evox and just killed the XBMC install and use a new install. So now I am going to go back to Auto installer 4.0 so at least I can FTP to the xbox. I have wasted way too much time on this already. It used to work fine, even on Windows 7 but ever since I had to re-install windows 7 a month or so ago, I have had nothing but problems trying to share on my old xbox. I swear one more time and I am done, I just hate to see something I know should work but doesn't.

I took hunter's advice and my guest account was turned off in Windows 7. I have not checked it yet because I have to reinstall, but I bet he is right. I will let you all know when I successfully reformat. Having that guest account turned off must have happened when I reinstalled windows 7.

I will keep you posted!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users