Jump to content


Photo

Transfer Between 2 Xboxs Using Pc Flashfxp


  • Please log in to reply
5 replies to this topic

#1 dballs442

dballs442

    X-S X-perience

  • Members
  • PipPip
  • 456 posts
  • Location:Durango, CO
  • Interests:Sustainability, Playing music, Mountain Biking, Snowboard, Games, Micro Beer, Camping, River Sports
  • Xbox Version:v1.0
  • 360 version:unknown

Posted 13 November 2010 - 08:47 AM

so i have 2 xboxs hooked to a switch. the switch is then connected to my pc.

i use flashfxp to transfer files between the 2 xboxs . i just set up one xbox on one side of flashfxp and the other xbox on the other side of flashfxp.

HOWEVER i must turn off my firewall for the transfers to go through. other wise i get this:

CODE
[R] TYPE I
[R] 200 Type set to I
[L] TYPE I
[L] 200 Type set to I
[R] SIZE Movie.avi
[R] 213 367644672
[R] MDTM Movie.avi
[R] 213 20100219232506
[L] SIZE Movie.avi
[L] 550 File not found
[R] PASV
[R] 227 Entering Passive Mode (192,168,1,121,4,16)
[L] PORT 192,168,1,121,4,16
[L] 200 Port command successful
[L] STOR Movie.avi
[L] 150 Opening data channel for file transfer.
[R] RETR Movie.avi
[L] 425 Can't open data connection.
[R] ABOR
[R] 500 Syntax error, command unrecognized.
[L] ABOR
[L] 500 Syntax error, command unrecognized.
[L] Transfer Failed!
[L] TYPE A
[L] 200 Type set to A
[L] PASV
[L] 227 Entering Passive Mode (192,168,1,122,4,20)
[L] Opening data connection IP: 192.168.1.122 PORT: 1044
[L] LIST -al
[L] 150 Connection accepted
[L] 226- Free space: [C:\ 185.11 MB] [E:\ 4.11 GB] [F:\ 16.80 GB] [G:\ 0.00 bytes]
[L] 226 Transfer OK
[L] List Complete: 1 KB in 0.03 seconds (34.1 KB/s)
[R] TYPE A
[R] 200 Type set to A
[R] PASV
[R] 227 Entering Passive Mode (192,168,1,121,4,17)
[R] Opening data connection IP: 192.168.1.121 PORT: 1041
[R] LIST -al
[R] 150 Connection accepted
[R] 226- Free space: [C:\ 321.89 MB] [E:\ 4.10 GB] [F:\ 26.55 GB] [G:\ 180.53 GB]
[R] 226 Transfer OK
[R] List Complete: 525 bytes in 0.02 seconds (32.0 KB/s)
Transfer queue completed
Transferred 0 Files (0 bytes) in 10.50 seconds (0.0 KB/s)
1 File Failed


I have tried:
-active and pasv modes.
-"limit local port range 1024-2048"
-windows firewall>advanced tab>Network Connection Settings>Settings>ticked FTP Server for both 1394 and network bridge.

Disabling the whole firewall works fine but i want set it up so i don't have to have my whole system vulnerable. there must be a setting some where in either FlashFXP or windows firewall.

Im guessing this is due to my NAT in my firewall. but i dont really know much about advanced networking.

as a side note i use flashfxp to transfer between 2 xboxs rather than use the built in ftp in either unleashx or xbmc because its much more stable, i can see what files went trough and what didnt, and i can use the "skip all" function if i want to resume where i left off transferring or insure i got all the files.

Edited by dballs442, 13 November 2010 - 08:48 AM.


#2 Bomb Bloke

Bomb Bloke

    X-S Transcendental

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPip
  • 6,568 posts
  • Gender:Male
  • Location:Tasmania (AU)
  • Xbox Version:v1.0
  • 360 version:none

Posted 16 November 2010 - 02:08 AM

You're using NAT to access the internet. NAT runs on your router (which will likely be in the form of a DSL/cable/whatever modem which is also connected to your switch) and allows all your devices to access the internet using the single IP address your ISP has provided you with.

While using NAT, the only incoming connections your computer can receive from outside your LAN are those which your router is specifically configured to pass on to it - which is why later versions of Windows automatically turn the Windows Firewall OFF when you tell them you're connected to your "home network". There's no point in running a firewall when no one can get past your router in the first place (unless your router is re-configurable over the internet (blast your ISP if they tell you this is the case), or your computer is infected with a virus and is attempting to make unwanted outgoing connections (in which case the Windows Firewall will likely be taken out by the same virus)).

Note that NAT is not part of your firewall, a firewall in its own right, nor does it have anything to do with your firewall. It merely acts a lot like a firewall, so much so that a "true" firewall is often redundant. But that is merely a side effect of NAT's true function (allowing multiple devices within a local network (eg your home setup) to access an external network (eg the Internet) via a single IP address).

How you can check your router configuration depends on what the router is, though you can find more general info here. Long story short, by default your router should have no forwards in place unless you put them there, and if it DOES have forwards you don't know about, you should have stern words with the company that gave it to you... assuming you don't have kids, who likely will've set some up for their online games or BitTorrent clients.

If, on the other hand, you truly don't trust that concept, then all you need to do is unplug your router from the mains power. Hey presto, your machines now have no link to the outside world, you can turn off the firewall and get your transfers done.

Edited by Bomb Bloke, 16 November 2010 - 02:16 AM.


#3 dballs442

dballs442

    X-S X-perience

  • Members
  • PipPip
  • 456 posts
  • Location:Durango, CO
  • Interests:Sustainability, Playing music, Mountain Biking, Snowboard, Games, Micro Beer, Camping, River Sports
  • Xbox Version:v1.0
  • 360 version:unknown

Posted 16 November 2010 - 05:29 AM

thanks. i dont really understand what NAT is. only that i read it has something to do with certain firewalls and i read that windows has NAT in it.

here:
http://technet.micro.....28WS.10).aspx

but i should elaborate on how my system is set up.

Modem>Wireless Router>Computer (wirelessly)>Bridge to LAN card>switch>xbox (2).
IPB Image

so basically i can shut down my wireless router and still transfer between xboxs. the switch is just hooked to my computer and then to the 2 xboxs in my room.

i understand i can disconnect from the internet when i want to shutdown my firewall and do my transfers safely but i was hoping for a workaround. a network setting or solution so i can still use FlashFXP to manage my transfers between my 2 xboxs locally while my firewall and internet is still on. i do a lot of transfers for i upgrade and build ~7 ppls xboxs for them.

#4 Bomb Bloke

Bomb Bloke

    X-S Transcendental

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPip
  • 6,568 posts
  • Gender:Male
  • Location:Tasmania (AU)
  • Xbox Version:v1.0
  • 360 version:none

Posted 16 November 2010 - 08:18 AM

If I were you, I'd delete the bridge, then enable Internet Connection Sharing (ICS) on the wireless card. I suspect this'll solve your issues (though the consoles may end up with different IPs then the ones they have at present, and you may need to enable DHCP on those systems if you're not already using it (it's on by default)).

Windows Firewall exceptions often only apply to interfaces on what Windows perceives to be the local network. Your computer treats the wireless card as an "internet-facing"-connection (because, well, it can access the internet through it and not through the Ethernet card), and so the exceptions are disregarded. When you bridge the wireless card with the Ethernet card, they're treated as one device - so both are assumed to be internet-facing and the exceptions are applied to neither.

Now, you could change your exceptions so that they apply even to devices Windows thinks are connected straight to the internet, but just switching to ICS is easier.

(Not that it matters, and nor do you need to understand it, but just as a point of interest - enabling ICS on the computer will cause it to start using NAT. laugh.gif )

#5 dballs442

dballs442

    X-S X-perience

  • Members
  • PipPip
  • 456 posts
  • Location:Durango, CO
  • Interests:Sustainability, Playing music, Mountain Biking, Snowboard, Games, Micro Beer, Camping, River Sports
  • Xbox Version:v1.0
  • 360 version:unknown

Posted 17 November 2010 - 10:02 PM

well i tried enabling ICS but only my LAN card had the option to enable it (which didnt help). my wireless did not have the option to enable ICS. and i get my internet from my wireless card.

Network Connections>right click cards>properties>advanced tab.

any help?

xp pro sp3

#6 Bomb Bloke

Bomb Bloke

    X-S Transcendental

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPip
  • 6,568 posts
  • Gender:Male
  • Location:Tasmania (AU)
  • Xbox Version:v1.0
  • 360 version:none

Posted 18 November 2010 - 08:48 AM

No idea, I can share my wired/wireless cards either way around, but I never bothered to upgrade from SP2 - I suppose you could try asking here. huh.gif

Edited by Bomb Bloke, 18 November 2010 - 08:49 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users