Jump to content


Photo

Screen Turns Purple On Dash Often


  • Please log in to reply
4 replies to this topic

#1 Jinkz

Jinkz

    X-S Member

  • Members
  • Pip
  • 108 posts
  • Xbox Version:v1.0
  • 360 version:unknown

Posted 19 December 2010 - 02:20 PM

When it flicks between video sources (like opening a video and it changing resolutions etc) sometimes it goes completely purple, and everything else that opens is purple. The only way to fix this is rebooting the console, but it's happening more often now (like a few times a month).

Is it the GPU dying very slowly or something else?

I've got it running through HDMI on a Panasonic 40" Plasma, and it's happened to my other consoles in the past (which all died also).

#2 JuliVerHJ

JuliVerHJ

    X-S Member

  • Members
  • Pip
  • 143 posts
  • Xbox Version:v1.6
  • 360 version:v3.0 (falcon)

Posted 19 December 2010 - 06:22 PM

Firstable check your HDMI cable.
And yes maybe the console is going to rrod...BTW what revision is your xbox?

#3 Jinkz

Jinkz

    X-S Member

  • Members
  • Pip
  • 108 posts
  • Xbox Version:v1.0
  • 360 version:unknown

Posted 20 December 2010 - 05:32 PM

Hdmi all good and ive got an elite, pretty sure its a jasper its a 2008 model that got fixed last year from rrod at ms

Edit: yup checked it was fixed on 22/12/2009

Edited by Jinkz, 20 December 2010 - 05:38 PM.


#4 likethegun

likethegun

    X-S Enthusiast

  • Members
  • 2 posts

Posted 14 January 2011 - 01:01 AM

What's happening is the result of your GPU. This was happening to me on my elite (well it was alternating between all green or like your case sometimes purple) after I did the x-clamp mod. After the mod it was working fine for about 2 months then it started to happen. All I did was remove the heatsink from the gpu and cleaned and polished the heck out of the chip, then I re-applied some good quality heat paste (I use Dynex) and whaa-baam! been working fine ever since. If your box is already modded (the x-xlamps) then I suggest trying this. If you've never touched them before, then I suggest doing the clamp fix. In reality you probably just need to get rid of the old cracked and crusty low quality heat grease that microsoft uses and re-apply some nice shtuff to your GPU.

#5 Jinkz

Jinkz

    X-S Member

  • Members
  • Pip
  • 108 posts
  • Xbox Version:v1.0
  • 360 version:unknown

Posted 28 January 2011 - 02:01 AM

Sounds like an idea, but when it goes back to the dash, it's fine, not purple, it's just on videos?

Edited by Jinkz, 28 January 2011 - 02:03 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users