Jump to content


Photo

Xbmc Resolution Problem


  • Please log in to reply
4 replies to this topic

#1 somebuckeye

somebuckeye

    X-S Enthusiast

  • Members
  • 2 posts

Posted 15 January 2011 - 04:46 PM

I bought a modded xbox which autoloads T3CH xbmc at startup. It is set to play at NTSC 4:3 480i. I have a widescreen analog (they exist) and a widescreen HDTV, so obviously this is not ideal. I would like to change the resolution to 16:9 720p for xbmc, and play xbox discs in 480p. I have the xbox HDTV connection pack.

The problem is, there is no option to do this in my xbmc. It only lets me choose auto and 4:3 480i. I tried going to the MS dashboard, but it seems to be gone. When I select dashboard from the xbmc menu, it goes to a black screen. When I tried to select the default dash on the C: from the config menu, it gave me error 21. I believe my xbmc dash is on the E:

Do I even need MS Dash to do this?
Why would I only have one choice for resolution in xbmc?


Everything works perfectly, xbmc recognizes that I have the HDTV connection, I just can't change my screen resolution or format...

#2 Bomb Bloke

Bomb Bloke

    X-S Transcendental

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPip
  • 6,568 posts
  • Gender:Male
  • Location:Tasmania (AU)
  • Xbox Version:v1.0
  • 360 version:none

Posted 16 January 2011 - 02:06 AM

Older versions of XBMC rely on the settings within the MS dash to determine the highest resolution they'll let you change to. Later XBMC builds should allow you free reign to choose whatever your cables support.

It would be a good idea to work out how your console is modded before messing with things. Changing your dashboard files may result in a system that won't boot anymore if you jump in without knowing the specifics. A good start would be to install the latest XBMC revision (google XBMC4Xbox) to a new location on your HDD, then launch that from there and see whether it'll do what you're after.

#3 somebuckeye

somebuckeye

    X-S Enthusiast

  • Members
  • 2 posts

Posted 17 January 2011 - 09:18 PM

Okay, So I figure you are right so I tried to update my xbmc. I got the files for the latest build, then ftp'd them to my xbox, overwriting the old ones. I rebooted. It loaded the new build of xbmc just fine but...

All of my emulators were gone, and there were also no fonts on any of the menus so I couldn't read any menus. I went to the video settings anyway just to check. The only option I could choose is 4:3 480i. So I decided, this is dumb, and I put the old xbmc files (which I had saved on my pc) back onto my xbox and it is the same as it was.

I looked around a little more, and my box appears to be soft-modded with a font exploit. There's a 007 save file on my box as well, so I'm guessing that was used to softmod it. I'm really learning much more about xbox modding than I really wanted to, that why I bought a modded box in the first place!

#4 Heimdall

Heimdall

    X-S Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 5,749 posts
  • Location:UK
  • Xbox Version:v1.4
  • 360 version:v4.0 (jasper)

Posted 17 January 2011 - 09:25 PM

You have to run another dash e.g. UnleashX, while running that you delete XBMC completely, then install the new version. Old versions leave all sorts of files behind that interfere with the newer versions.

You need to re-add the emulators etc. to the new installation to get them to appear in the menu.

Edited by Heimdall, 17 January 2011 - 10:20 PM.


#5 RMM

RMM

    X-S Senior Member

  • Members
  • PipPip
  • 264 posts

Posted 18 January 2011 - 12:58 AM

Heimdall is right. You should put a second dash like UnleashX on your hard drive and use that while deleting XBMC and installing a new one. If your Xbox is running XBMC and you try to replace it with a new XBMC when your old version is still running you could have all kinds of stuff that doesnt get replaced.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users